summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2006-06-05 19:14:14 +0000
committerBenedikt Boehm <hollow@gentoo.org>2006-06-05 19:14:14 +0000
commit7e7f11ceb0cb4757ca532c2984572c05926fa552 (patch)
tree33224a186145d76135c06ba1a0f2975ba083605f /net-www
parentremoved 1.0-r4, as LD_RUN_PATH are not to be used (#111340) (diff)
downloadgentoo-2-7e7f11ceb0cb4757ca532c2984572c05926fa552.tar.gz
gentoo-2-7e7f11ceb0cb4757ca532c2984572c05926fa552.tar.bz2
gentoo-2-7e7f11ceb0cb4757ca532c2984572c05926fa552.zip
fix #132391
(Portage version: 2.1_rc3-r1)
Diffstat (limited to 'net-www')
-rw-r--r--net-www/mod_auth_mysql/ChangeLog8
-rw-r--r--net-www/mod_auth_mysql/files/digest-mod_auth_mysql-3.0.02
-rw-r--r--net-www/mod_auth_mysql/files/digest-mod_auth_mysql-3.0.0-r13
-rw-r--r--net-www/mod_auth_mysql/mod_auth_mysql-3.0.0-r1.ebuild41
-rw-r--r--net-www/mod_auth_mysql/mod_auth_mysql-3.0.0.ebuild4
5 files changed, 55 insertions, 3 deletions
diff --git a/net-www/mod_auth_mysql/ChangeLog b/net-www/mod_auth_mysql/ChangeLog
index c2dae5168cb6..2cd0045fe099 100644
--- a/net-www/mod_auth_mysql/ChangeLog
+++ b/net-www/mod_auth_mysql/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-www/mod_auth_mysql
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_mysql/ChangeLog,v 1.21 2006/06/04 19:26:46 vericgar Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_mysql/ChangeLog,v 1.22 2006/06/05 19:14:14 hollow Exp $
+
+*mod_auth_mysql-3.0.0-r1 (05 Jun 2006)
+
+ 05 Jun 2006; Benedikt Böhm <hollow@gentoo.org>
+ -mod_auth_mysql-2.8.1.ebuild, +mod_auth_mysql-3.0.0-r1.ebuild:
+ fix #132391
04 Jun 2006; Michael Stewart <vericgar@gentoo.org>
-mod_auth_mysql-2.0.0_pre20030510.ebuild:
diff --git a/net-www/mod_auth_mysql/files/digest-mod_auth_mysql-3.0.0 b/net-www/mod_auth_mysql/files/digest-mod_auth_mysql-3.0.0
index aba095c94806..b841d6624e79 100644
--- a/net-www/mod_auth_mysql/files/digest-mod_auth_mysql-3.0.0
+++ b/net-www/mod_auth_mysql/files/digest-mod_auth_mysql-3.0.0
@@ -1 +1,3 @@
MD5 a9ffde3dabeddf32de50bf75597c809e mod_auth_mysql-3.0.0.tar.gz 19257
+RMD160 ef68d6ec7c99c4059a38ba74f41c22e2f88f3863 mod_auth_mysql-3.0.0.tar.gz 19257
+SHA256 56da2e386583548f2fd9976101633f028d5d4649b46f428ff1d0dd1639efbad4 mod_auth_mysql-3.0.0.tar.gz 19257
diff --git a/net-www/mod_auth_mysql/files/digest-mod_auth_mysql-3.0.0-r1 b/net-www/mod_auth_mysql/files/digest-mod_auth_mysql-3.0.0-r1
new file mode 100644
index 000000000000..b841d6624e79
--- /dev/null
+++ b/net-www/mod_auth_mysql/files/digest-mod_auth_mysql-3.0.0-r1
@@ -0,0 +1,3 @@
+MD5 a9ffde3dabeddf32de50bf75597c809e mod_auth_mysql-3.0.0.tar.gz 19257
+RMD160 ef68d6ec7c99c4059a38ba74f41c22e2f88f3863 mod_auth_mysql-3.0.0.tar.gz 19257
+SHA256 56da2e386583548f2fd9976101633f028d5d4649b46f428ff1d0dd1639efbad4 mod_auth_mysql-3.0.0.tar.gz 19257
diff --git a/net-www/mod_auth_mysql/mod_auth_mysql-3.0.0-r1.ebuild b/net-www/mod_auth_mysql/mod_auth_mysql-3.0.0-r1.ebuild
new file mode 100644
index 000000000000..a161e2cadac9
--- /dev/null
+++ b/net-www/mod_auth_mysql/mod_auth_mysql-3.0.0-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_mysql/mod_auth_mysql-3.0.0-r1.ebuild,v 1.1 2006/06/05 19:14:14 hollow Exp $
+
+inherit eutils apache-module
+
+DESCRIPTION="Basic authentication for Apache using a MySQL database"
+HOMEPAGE="http://modauthmysql.sourceforge.net/"
+SRC_URI="mirror://sourceforge/modauthmysql/${P}.tar.gz"
+
+DEPEND="dev-db/mysql"
+LICENSE="Apache-1.1"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+BASE_CONFIG_PVR="2.8.1"
+
+APXS1_ARGS="-DENABLE=0 -c -I/usr/include/mysql -lmysqlclient -lm -lz ${PN}.c"
+APACHE1_MOD_CONF="${BASE_CONFIG_PVR}/12_mod_auth_mysql"
+APACHE1_MOD_DEFINE="AUTH_MYSQL"
+
+APXS2_ARGS="-c -I/usr/include/mysql -lmysqlclient -lm -lz ${PN}.c"
+APACHE2_MOD_CONF="${BASE_CONFIG_PVR}/12_mod_auth_mysql"
+APACHE2_MOD_DEFINE="AUTH_MYSQL"
+
+DOCFILES="README"
+
+need_apache
+
+pkg_postinst() {
+ if ! useq apache2; then
+ ewarn "With regard to bug #132391 the behaviour of mod_auth_mysql"
+ ewarn "has changed for apache-1.3.x"
+ ewarn
+ ewarn "You need to enable mod_auth_ldap in your .htaccess files"
+ ewarn "explicitely using:"
+ ewarn
+ ewarn " AuthMySQLEnable On"
+ ewarn
+ fi
+}
diff --git a/net-www/mod_auth_mysql/mod_auth_mysql-3.0.0.ebuild b/net-www/mod_auth_mysql/mod_auth_mysql-3.0.0.ebuild
index c2d78bd832d1..7ae4d564967e 100644
--- a/net-www/mod_auth_mysql/mod_auth_mysql-3.0.0.ebuild
+++ b/net-www/mod_auth_mysql/mod_auth_mysql-3.0.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_mysql/mod_auth_mysql-3.0.0.ebuild,v 1.3 2005/12/10 13:10:49 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_mysql/mod_auth_mysql-3.0.0.ebuild,v 1.4 2006/06/05 19:14:14 hollow Exp $
inherit eutils apache-module