summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChuck Short <zul@gentoo.org>2004-06-04 00:01:36 +0000
committerChuck Short <zul@gentoo.org>2004-06-04 00:01:36 +0000
commitedc9da600f1d6d647c8d3ca5c0d2044489e97fd4 (patch)
treef3aff4a82a50769253ce7dc8a2716fa65359a13d /net-www
parentStable on mips. (Manifest recommit) (diff)
downloadgentoo-2-edc9da600f1d6d647c8d3ca5c0d2044489e97fd4.tar.gz
gentoo-2-edc9da600f1d6d647c8d3ca5c0d2044489e97fd4.tar.bz2
gentoo-2-edc9da600f1d6d647c8d3ca5c0d2044489e97fd4.zip
Added patch, closes #52865.
Diffstat (limited to 'net-www')
-rw-r--r--net-www/mod_auth_mysql/ChangeLog9
-rw-r--r--net-www/mod_auth_mysql/files/mod_auth_mysql.patch12
-rw-r--r--net-www/mod_auth_mysql/metadata.xml8
-rw-r--r--net-www/mod_auth_mysql/mod_auth_mysql-20030510-r1.ebuild3
-rw-r--r--net-www/mod_auth_mysql/mod_auth_mysql-20030510-r2.ebuild5
-rw-r--r--net-www/mod_auth_mysql/mod_auth_mysql-20030510.ebuild3
6 files changed, 35 insertions, 5 deletions
diff --git a/net-www/mod_auth_mysql/ChangeLog b/net-www/mod_auth_mysql/ChangeLog
index 8b5f42e19279..416db896f3d3 100644
--- a/net-www/mod_auth_mysql/ChangeLog
+++ b/net-www/mod_auth_mysql/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-www/mod_auth_mysql
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_mysql/ChangeLog,v 1.7 2004/04/22 18:08:40 zul Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_mysql/ChangeLog,v 1.8 2004/06/04 00:01:36 zul Exp $
+
+ 03 Jun 2004; Chuck Short <zul@gentoo.org> metadata.xml,
+ mod_auth_mysql-20030510-r1.ebuild, mod_auth_mysql-20030510-r2.ebuild,
+ mod_auth_mysql-20030510.ebuild, files/mod_auth_mysql.patch:
+ Added metadata.xml.
+ Added patch closes #52865.
+ -r2 marked stable.
22 Apr 2004; Chuck Short <zul@gentoo.org> mod_auth_mysql-20030510-r2.ebuild:
Installation of apache1 and apache2 modules. Closes #40265.
diff --git a/net-www/mod_auth_mysql/files/mod_auth_mysql.patch b/net-www/mod_auth_mysql/files/mod_auth_mysql.patch
new file mode 100644
index 000000000000..785a5aba0ace
--- /dev/null
+++ b/net-www/mod_auth_mysql/files/mod_auth_mysql.patch
@@ -0,0 +1,12 @@
+--- mod_auth_mysql.c.orig Thu Jun 3 11:40:27 2004
++++ mod_auth_mysql.c Thu Jun 3 11:32:24 2004
+@@ -746,6 +746,9 @@
+ "mysql user %s not in group table %s: %s",
+ user, sec->mysqlgrptable, r->uri);
+ #endif
++ if (!sec->mysqlAuthoritative)
++ return DECLINED;
++
+ ap_note_basic_auth_failure(r);
+ #ifdef APACHE2
+ return HTTP_UNAUTHORIZED;
diff --git a/net-www/mod_auth_mysql/metadata.xml b/net-www/mod_auth_mysql/metadata.xml
new file mode 100644
index 000000000000..bcaabdbbd0d3
--- /dev/null
+++ b/net-www/mod_auth_mysql/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>apache</herd>
+<longdescription>
+The Apache HTTP Server Project is an effort to develop and maintain an open-source HTTP server for modern operating systems including UNIX and Windows NT. The goal of this project is to provide a secure, efficient and extensible server that provides HTTP services in sync with the current HTTP standards.
+</longdescription>
+</pkgmetadata>
diff --git a/net-www/mod_auth_mysql/mod_auth_mysql-20030510-r1.ebuild b/net-www/mod_auth_mysql/mod_auth_mysql-20030510-r1.ebuild
index 3d3097ffb2b2..c00d7347c9ba 100644
--- a/net-www/mod_auth_mysql/mod_auth_mysql-20030510-r1.ebuild
+++ b/net-www/mod_auth_mysql/mod_auth_mysql-20030510-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_mysql/mod_auth_mysql-20030510-r1.ebuild,v 1.2 2004/01/05 23:28:33 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_mysql/mod_auth_mysql-20030510-r1.ebuild,v 1.3 2004/06/04 00:01:36 zul Exp $
DESCRIPTION="Basic authentication for Apache using a MySQL database"
HOMEPAGE="http://modauthmysql.sourceforge.net/"
@@ -26,6 +26,7 @@ else
fi
src_compile() {
+ epatch ${FILESDIR}/mod_auth_mysql.patch || die
$APXS -c ${PN}.c -I/usr/include/mysql -lmysqlclient -lm -lz || die
}
diff --git a/net-www/mod_auth_mysql/mod_auth_mysql-20030510-r2.ebuild b/net-www/mod_auth_mysql/mod_auth_mysql-20030510-r2.ebuild
index f5884ad85443..f993f3e40719 100644
--- a/net-www/mod_auth_mysql/mod_auth_mysql-20030510-r2.ebuild
+++ b/net-www/mod_auth_mysql/mod_auth_mysql-20030510-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_mysql/mod_auth_mysql-20030510-r2.ebuild,v 1.3 2004/04/22 18:08:40 zul Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_mysql/mod_auth_mysql-20030510-r2.ebuild,v 1.4 2004/06/04 00:01:36 zul Exp $
DESCRIPTION="Basic authentication for Apache using a MySQL database"
HOMEPAGE="http://modauthmysql.sourceforge.net/"
@@ -11,7 +11,7 @@ DEPEND="dev-db/mysql
net-www/apache
apache2? ( >=net-www/apache-2* )"
LICENSE="Apache-1.1"
-KEYWORDS="~x86"
+KEYWORDS="x86"
IUSE="apache2"
SLOT="0"
@@ -26,6 +26,7 @@ else
fi
src_compile() {
+ epatch ${FILESDIR}/mod_auth_mysql.patch || die
$APXS -c ${PN}.c -I/usr/include/mysql -lmysqlclient -lm -lz || die
}
diff --git a/net-www/mod_auth_mysql/mod_auth_mysql-20030510.ebuild b/net-www/mod_auth_mysql/mod_auth_mysql-20030510.ebuild
index a60ca6329f73..e4dcd04d5812 100644
--- a/net-www/mod_auth_mysql/mod_auth_mysql-20030510.ebuild
+++ b/net-www/mod_auth_mysql/mod_auth_mysql-20030510.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_mysql/mod_auth_mysql-20030510.ebuild,v 1.3 2004/01/05 23:28:33 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_mysql/mod_auth_mysql-20030510.ebuild,v 1.4 2004/06/04 00:01:36 zul Exp $
DESCRIPTION="Basic authentication for Apache using a MySQL database"
HOMEPAGE="http://modauthmysql.sourceforge.net/"
@@ -20,6 +20,7 @@ else
fi
src_compile() {
+ epatch ${FILESDIR}/mod_auth_mysql.patch || die
$APXS -c ${PN}.c -I/usr/include/mysql -lmysqlclient -lm -lz || die
}