summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-02-14 19:58:49 +0000
committerJustin Lecher <jlec@gentoo.org>2012-02-14 19:58:49 +0000
commitb68f8e7dcc0e1afb4a6c3e42280f6b9242eb4a04 (patch)
tree2ac7de86a7325bd0a91d86b3a1cec00585ec6911 /sci-chemistry
parentupdate header per bug #403671 (diff)
downloadgentoo-2-b68f8e7dcc0e1afb4a6c3e42280f6b9242eb4a04.tar.gz
gentoo-2-b68f8e7dcc0e1afb4a6c3e42280f6b9242eb4a04.tar.bz2
gentoo-2-b68f8e7dcc0e1afb4a6c3e42280f6b9242eb4a04.zip
Version Bump
(Portage version: 2.2.0_alpha86/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/burrow-owl/ChangeLog10
-rw-r--r--sci-chemistry/burrow-owl/burrow-owl-1.5.ebuild58
-rw-r--r--sci-chemistry/burrow-owl/files/burrow-owl-1.5-prll.patch20
3 files changed, 86 insertions, 2 deletions
diff --git a/sci-chemistry/burrow-owl/ChangeLog b/sci-chemistry/burrow-owl/ChangeLog
index 494ce1777cad..39655e33fbac 100644
--- a/sci-chemistry/burrow-owl/ChangeLog
+++ b/sci-chemistry/burrow-owl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/burrow-owl
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/burrow-owl/ChangeLog,v 1.4 2010/08/24 17:54:56 xarthisius Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/burrow-owl/ChangeLog,v 1.5 2012/02/14 19:58:49 jlec Exp $
+
+*burrow-owl-1.5 (14 Feb 2012)
+
+ 14 Feb 2012; Justin Lecher <jlec@gentoo.org> +burrow-owl-1.5.ebuild,
+ +files/burrow-owl-1.5-prll.patch:
+ Version Bump
*burrow-owl-1.4-r1 (24 Aug 2010)
diff --git a/sci-chemistry/burrow-owl/burrow-owl-1.5.ebuild b/sci-chemistry/burrow-owl/burrow-owl-1.5.ebuild
new file mode 100644
index 000000000000..a2a81f393e0b
--- /dev/null
+++ b/sci-chemistry/burrow-owl/burrow-owl-1.5.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/burrow-owl/burrow-owl-1.5.ebuild,v 1.1 2012/02/14 19:58:49 jlec Exp $
+
+EAPI=4
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils
+
+DESCRIPTION="Visualize multidimensional nuclear magnetic resonance (NMR) spectra"
+HOMEPAGE="http://burrow-owl.sourceforge.net/"
+SRC_URI="
+ mirror://sourceforge/${PN}/${P}.tar.gz
+ examples? ( mirror://sourceforge/${PN}/burrow-demos.tar )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples static-libs"
+
+RDEPEND="
+ dev-libs/g-wrap
+ dev-libs/glib:2
+ dev-scheme/guile[networking,regex]
+ dev-scheme/guile-cairo
+ dev-scheme/guile-gnome-platform
+ sci-libs/starparse
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ dev-util/indent
+ dev-util/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-prll.patch
+ )
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with doc doxygen doxygen)
+ )
+ autotools-utils_src_configure
+}
+
+src_test () {
+ autotools-utils_src_compile -C test-suite check
+}
+
+src_install() {
+ use doc && HTML_DOCS=("${AUTOTOOLS_BUILD_DIR}/doc/api/html/")
+ autotools-utils_src_install
+
+ use examples && \
+ insinto /usr/share/${PN} && \
+ doins -r "${WORKDIR}"/burrow-demos/*
+}
diff --git a/sci-chemistry/burrow-owl/files/burrow-owl-1.5-prll.patch b/sci-chemistry/burrow-owl/files/burrow-owl-1.5-prll.patch
new file mode 100644
index 000000000000..340ccd2366e5
--- /dev/null
+++ b/sci-chemistry/burrow-owl/files/burrow-owl-1.5-prll.patch
@@ -0,0 +1,20 @@
+ burrow/canvas/gw/Makefile.am | 4 +++-
+ 1 files changed, 3 insertions(+), 1 deletions(-)
+
+diff --git a/burrow/canvas/gw/Makefile.am b/burrow/canvas/gw/Makefile.am
+index da50ee3..2ed89bc 100644
+--- a/burrow/canvas/gw/Makefile.am
++++ b/burrow/canvas/gw/Makefile.am
+@@ -31,9 +31,11 @@ H2DEF=@top_srcdir@/utils/h2def.py
+ canvas.defs: $(HEADERS_1)
+ $(H2DEF) --all $(HEADERS_1) > $@
+
+-canvas-gw.c canvas-gw.h canvas-gw.scm: canvas.defs
++canvas-gw.c canvas-gw.h: canvas.defs
+ GUILE_LOAD_PATH=@srcdir@:@builddir@:@GUILE_GNOME_MODULE_DIR@:@G_WRAP_MODULE_DIR@:$$GUILE_LOAD_PATH $(GUILE) -s @srcdir@/run-g-wrap.scm
+
++BUILT_SOURCES=canvas-gw.c canvas-gw.h canvas.defs
++
+ INCLUDES=@GTK_CFLAGS@ @G_WRAP_CFLAGS@ @GUILE_GNOME_CFLAGS@ @GUILE_CAIRO_CFLAGS@ @GUILE_CFLAGS@ -I$(headers_dir) -I@top_srcdir@
+
+ moduledir=$(datadir)/guile/burrow