summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2008-07-27 15:02:09 +0000
committerMarkus Dittrich <markusle@gentoo.org>2008-07-27 15:02:09 +0000
commitdd3d8614878f236af65c785f6fbbc5f48f8e408d (patch)
treed06dea1d74604d10d9067917ea07943244ac2122 /sci-chemistry
parentwhitespace (diff)
downloadgentoo-2-dd3d8614878f236af65c785f6fbbc5f48f8e408d.tar.gz
gentoo-2-dd3d8614878f236af65c785f6fbbc5f48f8e408d.tar.bz2
gentoo-2-dd3d8614878f236af65c785f6fbbc5f48f8e408d.zip
Added gcc-4.3 compatibility patch.
(Portage version: 2.2_rc3/cvs/Linux 2.6.25-SENTINEL-5 i686)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/maid/ChangeLog6
-rw-r--r--sci-chemistry/maid/files/maid-gcc4.3.patch67
-rw-r--r--sci-chemistry/maid/maid-20011112.ebuild9
3 files changed, 77 insertions, 5 deletions
diff --git a/sci-chemistry/maid/ChangeLog b/sci-chemistry/maid/ChangeLog
index b327e7fb7121..7ff8a32a47fe 100644
--- a/sci-chemistry/maid/ChangeLog
+++ b/sci-chemistry/maid/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-chemistry/maid
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/maid/ChangeLog,v 1.13 2008/06/27 10:27:19 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/maid/ChangeLog,v 1.14 2008/07/27 15:02:08 markusle Exp $
+
+ 27 Jul 2008; Markus Dittrich <markusle@gentoo.org>
+ +files/maid-gcc4.3.patch, maid-20011112.ebuild:
+ Added gcc-4.3 compatibility patch.
27 Jun 2008; Ulrich Mueller <ulm@gentoo.org> maid-20011112.ebuild:
Change dependency from virtual/motif to x11-libs/openmotif, bug 224749.
diff --git a/sci-chemistry/maid/files/maid-gcc4.3.patch b/sci-chemistry/maid/files/maid-gcc4.3.patch
new file mode 100644
index 000000000000..6b793541b837
--- /dev/null
+++ b/sci-chemistry/maid/files/maid-gcc4.3.patch
@@ -0,0 +1,67 @@
+diff -Naur glmaid_dist/bone.c++ glmaid_dist.new/bone.c++
+--- glmaid_dist/bone.c++ 2001-11-12 08:35:49.000000000 -0500
++++ glmaid_dist.new/bone.c++ 2008-07-27 10:52:35.000000000 -0400
+@@ -15,7 +15,7 @@
+ 2) Set value that are going to be revoved equal to -MARCHAR rather then +MAXCHAR so can use MAXCHAR as a real value
+ 3) Set removed value = REMOVE (- =100), rather then 0
+ */
+-
++#include <cstring>
+ #include "drawwindow.h"
+ //#include "screen.h"
+ #include "math.h"
+diff -Naur glmaid_dist/checkfit.c++ glmaid_dist.new/checkfit.c++
+--- glmaid_dist/checkfit.c++ 2001-11-12 08:35:49.000000000 -0500
++++ glmaid_dist.new/checkfit.c++ 2008-07-27 10:52:05.000000000 -0400
+@@ -1,7 +1,7 @@
+ /* checkfit.c++ Moved routines used to check and cut the final fit
+ for trace.c++ to here
+ */
+-
++#include <cstring>
+ #include "drawwindow.h"
+ #include "math.h"
+ #include "trace.h"
+diff -Naur glmaid_dist/combine.c++ glmaid_dist.new/combine.c++
+--- glmaid_dist/combine.c++ 2001-11-12 08:35:50.000000000 -0500
++++ glmaid_dist.new/combine.c++ 2008-07-27 10:52:12.000000000 -0400
+@@ -22,6 +22,7 @@
+ 6) Next - run combinefit:
+ This looks through fits to find fits with some overlap of seq. assighment.
+ */
++#include <cstring>
+ #include "drawwindow.h"
+ #include "math.h"
+ #include "trace.h" // includes a number of "extern .... " lines
+diff -Naur glmaid_dist/fittopdb.c++ glmaid_dist.new/fittopdb.c++
+--- glmaid_dist/fittopdb.c++ 2001-11-12 08:35:50.000000000 -0500
++++ glmaid_dist.new/fittopdb.c++ 2008-07-27 10:52:48.000000000 -0400
+@@ -56,6 +56,7 @@
+ strcpy(aaname[2],"SER");
+ VIII) in maid - each fit is a separate file, in maid - one file
+ */
++#include <cstring>
+ #include "peptide.h"
+ #include "drawwindow.h" // also calls global.h
+ #include "trace.h"
+diff -Naur glmaid_dist/initialize.c++ glmaid_dist.new/initialize.c++
+--- glmaid_dist/initialize.c++ 2001-11-12 08:35:50.000000000 -0500
++++ glmaid_dist.new/initialize.c++ 2008-07-27 10:52:42.000000000 -0400
+@@ -1,4 +1,5 @@
+ // Initial values called from main
++#include <cstring>
+ #include "tordyn.h" // routines for torsiondynamics
+ #include "peptide.h" // routines for peptide creation and drawing
+ #include "drawwindow.h" // also calls global.h
+diff -Naur glmaid_dist/trace.c++ glmaid_dist.new/trace.c++
+--- glmaid_dist/trace.c++ 2001-11-12 08:35:49.000000000 -0500
++++ glmaid_dist.new/trace.c++ 2008-07-27 10:52:22.000000000 -0400
+@@ -3,7 +3,7 @@
+ SEE: trace.notes
+ 1=ca,2=c,3=o;4=n,5=cb; 6=cb2 in pos
+ */
+-
++#include <cstring>
+ #include "drawwindow.h"
+ #include "math.h"
+ #include "trace.h"
diff --git a/sci-chemistry/maid/maid-20011112.ebuild b/sci-chemistry/maid/maid-20011112.ebuild
index 7abdddeb2d3b..127276b9e26a 100644
--- a/sci-chemistry/maid/maid-20011112.ebuild
+++ b/sci-chemistry/maid/maid-20011112.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/maid/maid-20011112.ebuild,v 1.8 2008/06/27 10:27:19 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/maid/maid-20011112.ebuild,v 1.9 2008/07/27 15:02:08 markusle Exp $
inherit eutils toolchain-funcs
@@ -32,10 +32,11 @@ src_unpack() {
fi
unpack ${A}
- cd ${S}
+ cd "${S}"
- epatch ${DISTDIR}/maid-fix-compilation.patch.bz2
- epatch ${FILESDIR}/fix-warnings.patch
+ epatch "${DISTDIR}"/maid-fix-compilation.patch.bz2
+ epatch "${FILESDIR}"/fix-warnings.patch
+ epatch "${FILESDIR}"/${PN}-gcc4.3.patch
if use X; then
ln -s makefile_graphics makefile