summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2008-08-03 17:54:18 +0000
committerMarkus Dittrich <markusle@gentoo.org>2008-08-03 17:54:18 +0000
commit641377f67ecd00f845e65f7dc7cac903f83f363b (patch)
treec18fa1137aa58223673a02e9776ca372c949eef5 /sci-libs/blas-atlas
parentamd64 stable wrt security bug #222275 (diff)
downloadgentoo-2-641377f67ecd00f845e65f7dc7cac903f83f363b.tar.gz
gentoo-2-641377f67ecd00f845e65f7dc7cac903f83f363b.tar.bz2
gentoo-2-641377f67ecd00f845e65f7dc7cac903f83f363b.zip
Added patches to fix infinite recursion during bootstrapping and to improve Core2Duo detection (fixes bug #233614).
(Portage version: 2.2_rc5/cvs/Linux 2.6.26-SENTINEL-1 i686)
Diffstat (limited to 'sci-libs/blas-atlas')
-rw-r--r--sci-libs/blas-atlas/ChangeLog8
-rw-r--r--sci-libs/blas-atlas/blas-atlas-3.9.1.ebuild4
-rw-r--r--sci-libs/blas-atlas/files/blas-atlas-3.9.1-Core2Duo-detect.patch26
-rw-r--r--sci-libs/blas-atlas/files/blas-atlas-3.9.1-timing.patch45
4 files changed, 81 insertions, 2 deletions
diff --git a/sci-libs/blas-atlas/ChangeLog b/sci-libs/blas-atlas/ChangeLog
index 25c06e3be180..3d36cebc94c1 100644
--- a/sci-libs/blas-atlas/ChangeLog
+++ b/sci-libs/blas-atlas/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/blas-atlas
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-atlas/ChangeLog,v 1.82 2008/07/23 14:43:51 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-atlas/ChangeLog,v 1.83 2008/08/03 17:54:18 markusle Exp $
+
+ 03 Aug 2008; Markus Dittrich <markusle@gentoo.org>
+ +files/blas-atlas-3.9.1-Core2Duo-detect.patch,
+ +files/blas-atlas-3.9.1-timing.patch, blas-atlas-3.9.1.ebuild:
+ Added patches to fix infinite recursion during bootstrapping and to
+ improve Core2Duo detection (fixes bug #233614).
*blas-atlas-3.9.1 (22 Jul 2008)
diff --git a/sci-libs/blas-atlas/blas-atlas-3.9.1.ebuild b/sci-libs/blas-atlas/blas-atlas-3.9.1.ebuild
index 4fbd74027fdf..d0827ebe26bd 100644
--- a/sci-libs/blas-atlas/blas-atlas-3.9.1.ebuild
+++ b/sci-libs/blas-atlas/blas-atlas-3.9.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-atlas/blas-atlas-3.9.1.ebuild,v 1.1 2008/07/23 14:43:51 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-atlas/blas-atlas-3.9.1.ebuild,v 1.2 2008/08/03 17:54:18 markusle Exp $
inherit eutils toolchain-funcs fortran multilib
@@ -60,6 +60,8 @@ src_unpack() {
epatch "${DISTDIR}"/${MY_PN}-${PATCH_V}-shared-libs.patch.bz2
epatch "${FILESDIR}"/${MY_PN}-asm-gentoo.patch
epatch "${FILESDIR}"/${MY_PN}-${PATCH_V}-decl-fix.patch
+ epatch "${FILESDIR}"/${P}-Core2Duo-detect.patch
+ epatch "${FILESDIR}"/${P}-timing.patch
BLD_DIR="${S}"/gentoo-build
mkdir "${BLD_DIR}" || die "failed to generate build directory"
diff --git a/sci-libs/blas-atlas/files/blas-atlas-3.9.1-Core2Duo-detect.patch b/sci-libs/blas-atlas/files/blas-atlas-3.9.1-Core2Duo-detect.patch
new file mode 100644
index 000000000000..ab3ccd6ce990
--- /dev/null
+++ b/sci-libs/blas-atlas/files/blas-atlas-3.9.1-Core2Duo-detect.patch
@@ -0,0 +1,26 @@
+diff -Naur ATLAS/CONFIG/src/backend/archinfo_x86.c ATLAS.new/CONFIG/src/backend/archinfo_x86.c
+--- ATLAS/CONFIG/src/backend/archinfo_x86.c 2008-07-22 10:32:34.000000000 -0400
++++ ATLAS.new/CONFIG/src/backend/archinfo_x86.c 2008-08-02 07:17:09.000000000 -0400
+@@ -92,11 +92,11 @@
+ */
+ do_cpuid(r, 1);
+ *family = (r[EAX] >> 8) & 0xf; /* base family in bits 11-8 */
+- if (*family == 0xf || *family == 0) /* extended family is added in */
++/* if (*family == 0xf || *family == 0) */ /* extended family is added in */
+ *family += ((r[EAX] >> 20) & 0xff);
+
+ *model = (r[0] >> 4) & 0xf; /* model in bits 7-4 */
+- if (*model == 0xf) /* extended model is concatenated */
++ /* if (*model == 0xf) */ /* extended model is concatenated */
+ *model |= ((r[0] >> 12) & 0xf0);
+
+ /*
+@@ -294,7 +294,7 @@
+ case 14:
+ iret = IntCoreDuo;
+ break;
+- case 15:
++ case 15: ; case 23:
+ iret = IntCore2Duo;
+ break;
+ default:
diff --git a/sci-libs/blas-atlas/files/blas-atlas-3.9.1-timing.patch b/sci-libs/blas-atlas/files/blas-atlas-3.9.1-timing.patch
new file mode 100644
index 000000000000..5bbecfc7c696
--- /dev/null
+++ b/sci-libs/blas-atlas/files/blas-atlas-3.9.1-timing.patch
@@ -0,0 +1,45 @@
+diff -Naur ATLAS/makes/Make.l1tune ATLAS.new/makes/Make.l1tune
+--- ATLAS/makes/Make.l1tune 2008-07-22 10:32:34.000000000 -0400
++++ ATLAS.new/makes/Make.l1tune 2008-08-02 07:17:40.000000000 -0400
+@@ -46,7 +46,7 @@
+
+ force_build :
+ auxlib :
+- cd $(AUXdir) ; make lib
++# cd $(AUXdir) ; make lib
+ $(BINdir)/xsubstr:
+ cd $(BINdir) ; $(MAKE) xsubstr
+ cdotc.dsc : $(mySRCdir)/DOT/ccasesc.dsc $(BINdir)/xsubstr
+diff -Naur ATLAS/tune/blas/level1/dottime.c ATLAS.new/tune/blas/level1/dottime.c
+--- ATLAS/tune/blas/level1/dottime.c 2008-07-22 10:33:17.000000000 -0400
++++ ATLAS.new/tune/blas/level1/dottime.c 2008-08-02 07:20:23.000000000 -0400
+@@ -198,6 +198,7 @@
+ #define TEST_DOT ATL_DOT
+ #endif
+
++#if 0
+ double DoOneTiming(int N, int nkflop, int cachesize, int incX, int incY)
+ /*
+ * This method of timing can be used when we have a cycle-accurate timer
+@@ -253,6 +254,8 @@
+ FA_free(Y, FAy, MAy);
+ return(t1-t0);
+ }
++#endif
++
+ double DoTiming(int N, int nkflop, int cachesize, int incX, int incY)
+ {
+ #ifdef TREAL
+@@ -322,9 +325,9 @@
+ int i;
+ for (i=0; i < nrep; i++)
+ {
+- if (nkflop <= 0)
+- tims[i] = DoOneTiming(N, nkflop, cachesize, incX, incY);
+- else
++ // if (nkflop <= 0)
++ // tims[i] = DoOneTiming(N, nkflop, cachesize, incX, incY);
++ // else
+ tims[i] = DoTiming(N, nkflop, cachesize, incX, incY);
+ fprintf(stdout, " N=%d, tim=%e\n", N, tims[i]);
+ }