summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2010-06-16 19:17:43 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2010-06-16 19:17:43 +0000
commit1f2df225586e14a3dd4c1bf9e728560dcbe1983a (patch)
treea930eb7975db34452f3730f90ef34295cfbd65a3 /sci-libs/hdf5
parentFix shebangs. (diff)
downloadgentoo-2-1f2df225586e14a3dd4c1bf9e728560dcbe1983a.tar.gz
gentoo-2-1f2df225586e14a3dd4c1bf9e728560dcbe1983a.tar.bz2
gentoo-2-1f2df225586e14a3dd4c1bf9e728560dcbe1983a.zip
Version bump. Fixes bug 324119
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/hdf5')
-rw-r--r--sci-libs/hdf5/ChangeLog8
-rw-r--r--sci-libs/hdf5/files/hdf5-1.8.5-noreturn.patch73
-rw-r--r--sci-libs/hdf5/hdf5-1.8.5.ebuild105
3 files changed, 185 insertions, 1 deletions
diff --git a/sci-libs/hdf5/ChangeLog b/sci-libs/hdf5/ChangeLog
index 456f8dc93b94..0e2d8ba9acdb 100644
--- a/sci-libs/hdf5/ChangeLog
+++ b/sci-libs/hdf5/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/hdf5
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/ChangeLog,v 1.55 2010/05/04 19:05:48 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/ChangeLog,v 1.56 2010/06/16 19:17:43 xarthisius Exp $
+
+*hdf5-1.8.5 (16 Jun 2010)
+
+ 16 Jun 2010; Kacper Kowalik <xarthisius@gentoo.org> +hdf5-1.8.5.ebuild,
+ +files/hdf5-1.8.5-noreturn.patch:
+ Version bump. Fixes bug 324119
04 May 2010; Sébastien Fabbro <bicatali@gentoo.org> hdf5-1.8.4-r1.ebuild:
Changed SRC_URI, per bug #317649
diff --git a/sci-libs/hdf5/files/hdf5-1.8.5-noreturn.patch b/sci-libs/hdf5/files/hdf5-1.8.5-noreturn.patch
new file mode 100644
index 000000000000..40065f7b83fe
--- /dev/null
+++ b/sci-libs/hdf5/files/hdf5-1.8.5-noreturn.patch
@@ -0,0 +1,73 @@
+--- hl/src/H5LTanalyze.c
++++ hl/src/H5LTanalyze.c
+@@ -2329,7 +2329,7 @@
+ return ret;
+ }
+
+-int H5LTyyerror(char *msg)
++void H5LTyyerror(char *msg)
+ {
+ printf("ERROR: %s before \"%s\".\n", msg, yytext);
+ }
+--- hl/src/H5LTanalyze.l
++++ hl/src/H5LTanalyze.l
+@@ -181,7 +181,7 @@
+ return ret;
+ }
+
+-int H5LTyyerror(char *msg)
++void H5LTyyerror(char *msg)
+ {
+ printf("ERROR: %s before \"%s\".\n", msg, yytext);
+ }
+--- hl/src/H5LTparse.c
++++ hl/src/H5LTparse.c
+@@ -64,7 +64,7 @@
+ #include<hdf5.h>
+
+ extern int yylex();
+-extern int yyerror(char *);
++extern void yyerror(char *);
+
+ #define STACK_SIZE 16
+
+--- test/dt_arith.c
++++ test/dt_arith.c
+@@ -3408,6 +3408,7 @@
+ else if(run_test==TEST_DENORM || run_test==TEST_SPECIAL)
+ return 1;
+ #endif
++ return 1;
+ }
+
+
+--- tools/h5dump/h5dump.c
++++ tools/h5dump/h5dump.c
+@@ -602,6 +602,7 @@
+ *
+ *-------------------------------------------------------------------------
+ */
++static void leave(int ret) __attribute__ ((__noreturn__));
+ static void
+ leave(int ret)
+ {
+--- tools/h5ls/h5ls.c
++++ tools/h5ls/h5ls.c
+@@ -2147,6 +2147,7 @@
+ *
+ *-------------------------------------------------------------------------
+ */
++static void leave(int ret) __attribute__ ((__noreturn__));
+ static void
+ leave(int ret)
+ {
+--- tools/h5stat/h5stat.c
++++ tools/h5stat/h5stat.c
+@@ -181,6 +181,7 @@
+ { NULL, 0, '\0' }
+ };
+
++static void leave(int ret) __attribute__ ((__noreturn__));
+ static void
+ leave(int ret)
+ {
diff --git a/sci-libs/hdf5/hdf5-1.8.5.ebuild b/sci-libs/hdf5/hdf5-1.8.5.ebuild
new file mode 100644
index 000000000000..cc0a01c62e98
--- /dev/null
+++ b/sci-libs/hdf5/hdf5-1.8.5.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/hdf5-1.8.5.ebuild,v 1.1 2010/06/16 19:17:43 xarthisius Exp $
+
+EAPI=2
+
+inherit autotools eutils
+
+DESCRIPTION="General purpose library and file format for storing scientific data"
+HOMEPAGE="http://www.hdfgroup.org/HDF5/"
+SRC_URI="http://www.hdfgroup.org/ftp/HDF5/current/src/${P}.tar.gz"
+
+LICENSE="NCSA-HDF"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="cxx examples fortran mpi szip threads zlib"
+
+RDEPEND="mpi? ( virtual/mpi[romio] )
+ szip? ( >=sci-libs/szip-2.1 )
+ zlib? ( sys-libs/zlib )"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/libtool-2.2
+ sys-process/time"
+
+pkg_setup() {
+ if use mpi; then
+ if has_version 'sci-libs/hdf5[-mpi]'; then
+ ewarn "Installing hdf5 with mpi enabled with a previous hdf5 with mpi disabled may fail."
+ ewarn "Try to uninstall the current hdf5 prior to enabling mpi support."
+ fi
+ if use cxx; then
+ ewarn "Simultaneous mpi and cxx is not supported by ${PN}"
+ ewarn "Will disable cxx interface"
+ fi
+ export CC=mpicc
+ if use fortran; then
+ export FC=mpif90
+ fi
+ elif has_version 'sci-libs/hdf5[mpi]'; then
+ ewarn "Installing hdf5 with mpi disabled while having hdf5 installed with mpi enabled may fail."
+ ewarn "Try to uninstall the current hdf5 prior to disabling mpi support."
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.8.3-as-needed.patch
+ epatch "${FILESDIR}"/${PN}-1.8.3-includes.patch
+ epatch "${FILESDIR}"/${P}-noreturn.patch
+ epatch "${FILESDIR}"/${PN}-1.8.4-scaleoffset.patch
+
+ # respect gentoo examples directory
+ sed -i -e "s:hdf5_examples:doc/${PF}/examples:g" \
+ $(find . -name Makefile.am) $(find . -name "run*.sh.in") || die
+ sed -i \
+ -e '/docdir/d' \
+ config/commence.am || die
+ eautoreconf
+ # enable shared libs by default for h5cc config utility
+ sed -i -e "s/SHLIB:-no/SHLIB:-yes/g" tools/misc/h5cc.in \
+ || die "sed h5cc.in failed"
+}
+
+src_configure() {
+ # threadsafe incompatible with many options
+ local myconf="--disable-threadsafe"
+ use threads && ! use fortran && ! use cxx && ! use mpi \
+ && myconf="--enable-threadsafe"
+
+ if use mpi; then
+ myconf="${myconf} --disable-cxx"
+ else
+ # workaround for bug 285148
+ if use cxx; then
+ myconf="${myconf} $(use_enable cxx) CXX=$(tc-getCXX)"
+ fi
+ if use fortran; then
+ myconf="${myconf} FC=$(tc-getFC)"
+ fi
+ fi
+
+ econf \
+ --disable-sharedlib-rpath \
+ --enable-production \
+ --enable-strict-format-checks \
+ --docdir=/usr/share/doc/${PF} \
+ --enable-deprecated-symbols \
+ --enable-shared \
+ $(use_enable fortran) \
+ $(use_enable mpi parallel) \
+ $(use_with szip szlib) \
+ $(use_with threads pthread) \
+ $(use_with zlib) \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README.txt
+ if use examples; then
+ emake DESTDIR="${D}" install-examples \
+ || die "emake install examples failed"
+ fi
+}