summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-07-16 11:57:28 +0000
committerJustin Lecher <jlec@gentoo.org>2011-07-16 11:57:28 +0000
commitdafacbfdca22ff42c74d06da222fa2dfdeaaba49 (patch)
tree4f1fab58c26269a8a33f4e2a61c5616edbd986d4 /sci-libs/ssm/ssm-1.1.ebuild
parentUnmask sci-libs/mmdb as I found the solution for the inline changes (diff)
downloadgentoo-2-dafacbfdca22ff42c74d06da222fa2dfdeaaba49.tar.gz
gentoo-2-dafacbfdca22ff42c74d06da222fa2dfdeaaba49.tar.bz2
gentoo-2-dafacbfdca22ff42c74d06da222fa2dfdeaaba49.zip
Import from sci-overlay
(Portage version: 2.2.0_alpha45/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/ssm/ssm-1.1.ebuild')
-rw-r--r--sci-libs/ssm/ssm-1.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sci-libs/ssm/ssm-1.1.ebuild b/sci-libs/ssm/ssm-1.1.ebuild
new file mode 100644
index 000000000000..341d8d563092
--- /dev/null
+++ b/sci-libs/ssm/ssm-1.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/ssm/ssm-1.1.ebuild,v 1.1 2011/07/16 11:57:28 jlec Exp $
+
+EAPI=4
+
+inherit autotools eutils
+
+DESCRIPTION="A macromolecular coordinate superposition library"
+HOMEPAGE="https://launchpad.net/ssm"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+DEPEND=">=sci-libs/mmdb-1.23"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-mmdb.patch \
+ "${FILESDIR}"/${P}-pc.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}