summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-06-25 19:04:50 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-06-25 19:04:50 +0000
commit302ad0767cfa025dd0b608326ef5805db801738c (patch)
treed57496c711b780477d0c2ecc36706f0d754b53c9 /sys-cluster
parentfix deps (diff)
downloadgentoo-2-302ad0767cfa025dd0b608326ef5805db801738c.tar.gz
gentoo-2-302ad0767cfa025dd0b608326ef5805db801738c.tar.bz2
gentoo-2-302ad0767cfa025dd0b608326ef5805db801738c.zip
fixes for bugs 474060 and 474062
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/nova/ChangeLog10
-rw-r--r--sys-cluster/nova/nova-2012.2.4-r3.ebuild (renamed from sys-cluster/nova/nova-2012.2.4-r2.ebuild)9
-rw-r--r--sys-cluster/nova/nova-2013.1.2-r2.ebuild (renamed from sys-cluster/nova/nova-2013.1.2-r1.ebuild)19
-rw-r--r--sys-cluster/nova/nova-9999.ebuild7
4 files changed, 36 insertions, 9 deletions
diff --git a/sys-cluster/nova/ChangeLog b/sys-cluster/nova/ChangeLog
index 70de5679521d..bba78a73f432 100644
--- a/sys-cluster/nova/ChangeLog
+++ b/sys-cluster/nova/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-cluster/nova
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/nova/ChangeLog,v 1.15 2013/06/09 01:18:13 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/nova/ChangeLog,v 1.16 2013/06/25 19:04:50 prometheanfire Exp $
+
+*nova-2012.2.4-r3 (25 Jun 2013)
+*nova-2013.1.2-r2 (25 Jun 2013)
+
+ 25 Jun 2013; Matthew Thode <prometheanfire@gentoo.org>
+ +nova-2012.2.4-r3.ebuild, +nova-2013.1.2-r2.ebuild, -nova-2012.2.4-r2.ebuild,
+ -nova-2013.1.2-r1.ebuild, nova-9999.ebuild:
+ fixes for bugs 474060 and 474062
*nova-2013.1.2-r1 (09 Jun 2013)
diff --git a/sys-cluster/nova/nova-2012.2.4-r2.ebuild b/sys-cluster/nova/nova-2012.2.4-r3.ebuild
index 4fc43413aaaa..f08ab6c27de0 100644
--- a/sys-cluster/nova/nova-2012.2.4-r2.ebuild
+++ b/sys-cluster/nova/nova-2012.2.4-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/nova/nova-2012.2.4-r2.ebuild,v 1.1 2013/05/17 14:57:48 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/nova/nova-2012.2.4-r3.ebuild,v 1.1 2013/06/25 19:04:50 prometheanfire Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -63,4 +63,11 @@ python_install() {
doins "etc/nova/rootwrap.d/compute.filters"
doins "etc/nova/rootwrap.d/network.filters"
doins "etc/nova/rootwrap.d/volume.filters"
+
+ #copy migration conf file (not coppied on install via setup.py script)
+ insinto /usr/$(get_libdir)/python2.7/site-packages/nova/db/sqlalchemy/migrate_repo/
+ doins "nova/db/sqlalchemy/migrate_repo/migrate.cfg"
+
+ #copy the CA cert dir (not coppied on install via setup.py script)
+ cp -R "${S}/nova/CA" "${D}/usr/$(get_libdir)/python2.7/site-packages/nova/" || die "isntalling CA files failed"
}
diff --git a/sys-cluster/nova/nova-2013.1.2-r1.ebuild b/sys-cluster/nova/nova-2013.1.2-r2.ebuild
index f032042db550..17eb7a3b7b85 100644
--- a/sys-cluster/nova/nova-2013.1.2-r1.ebuild
+++ b/sys-cluster/nova/nova-2013.1.2-r2.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/nova/nova-2013.1.2-r1.ebuild,v 1.1 2013/06/09 01:18:13 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/nova/nova-2013.1.2-r2.ebuild,v 1.1 2013/06/25 19:04:50 prometheanfire Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
-inherit distutils-r1 eutils
+inherit distutils-r1 eutils multilib
DESCRIPTION="Nova is a cloud computing fabric controller (main part of an
IaaS system). It is written in Python."
@@ -62,12 +62,19 @@ python_install() {
insinto /etc/nova
newins "etc/nova/nova.conf.sample" "nova.conf"
- newins "etc/nova/api-paste.ini" "api-paste.ini"
- newins "etc/nova/logging_sample.conf" "logging_sample.conf"
- newins "etc/nova/policy.json" "policy.json"
- newins "etc/nova/rootwrap.conf" "rootwrap.conf"
+ doins "etc/nova/api-paste.ini"
+ doins "etc/nova/logging_sample.conf"
+ doins "etc/nova/policy.json"
+ doins "etc/nova/rootwrap.conf"
insinto /etc/nova/rootwrap.d
doins "etc/nova/rootwrap.d/api-metadata.filters"
doins "etc/nova/rootwrap.d/compute.filters"
doins "etc/nova/rootwrap.d/network.filters"
+
+ #copy migration conf file (not coppied on install via setup.py script)
+ insinto /usr/$(get_libdir)/python2.7/site-packages/nova/db/sqlalchemy/migrate_repo/
+ doins "nova/db/sqlalchemy/migrate_repo/migrate.cfg"
+
+ #copy the CA cert dir (not coppied on install via setup.py script)
+ cp -R "${S}/nova/CA" "${D}/usr/$(get_libdir)/python2.7/site-packages/nova/" || die "isntalling CA files failed"
}
diff --git a/sys-cluster/nova/nova-9999.ebuild b/sys-cluster/nova/nova-9999.ebuild
index 4d46c7f634e8..ea025eb59098 100644
--- a/sys-cluster/nova/nova-9999.ebuild
+++ b/sys-cluster/nova/nova-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/nova/nova-9999.ebuild,v 1.2 2013/06/09 01:18:13 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/nova/nova-9999.ebuild,v 1.3 2013/06/25 19:04:50 prometheanfire Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -78,4 +78,9 @@ python_install() {
doins "etc/nova/rootwrap.d/network.filters"
doins "etc/nova/rootwrap.d/baremetal-compute-ipmi.filters"
doins "etc/nova/rootwrap.d/baremetal-deploy-helper.filters"
+ #copy migration conf file (not coppied on install via setup.py script)
+ insinto /usr/$(get_libdir)/python2.7/site-packages/nova/db/sqlalchemy/migrate_repo/
+ doins "nova/db/sqlalchemy/migrate_repo/migrate.cfg"
+ #copy the CA cert dir (not coppied on install via setup.py script)
+ cp -R "${S}/nova/CA" "${D}/usr/$(get_libdir)/python2.7/site-packages/nova/" || die "isntalling CA files failed"
}