summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-09-14 04:58:13 +0000
committerMike Frysinger <vapier@gentoo.org>2011-09-14 04:58:13 +0000
commit9a87af5a5a05920720a6f17cf519d8d7b4156957 (patch)
tree297ea3b2d2cffbef289016afc0be91f62b86c4cc /sys-fs/quota
parentRefactor src_unpack. Set ESVN_REPO_URI to trunk. (diff)
downloadgentoo-2-9a87af5a5a05920720a6f17cf519d8d7b4156957.tar.gz
gentoo-2-9a87af5a5a05920720a6f17cf519d8d7b4156957.tar.bz2
gentoo-2-9a87af5a5a05920720a6f17cf519d8d7b4156957.zip
Version bump #382797 by Justin Lecher. Add USE=netlink support #382801 by Justin Lecher.
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/quota')
-rw-r--r--sys-fs/quota/ChangeLog9
-rw-r--r--sys-fs/quota/metadata.xml1
-rw-r--r--sys-fs/quota/quota-4.00.ebuild63
3 files changed, 72 insertions, 1 deletions
diff --git a/sys-fs/quota/ChangeLog b/sys-fs/quota/ChangeLog
index c452a92c7323..0fa932eeaa0b 100644
--- a/sys-fs/quota/ChangeLog
+++ b/sys-fs/quota/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-fs/quota
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/quota/ChangeLog,v 1.59 2011/05/21 18:01:37 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/quota/ChangeLog,v 1.60 2011/09/14 04:58:13 vapier Exp $
+
+*quota-4.00 (14 Sep 2011)
+
+ 14 Sep 2011; Mike Frysinger <vapier@gentoo.org> +quota-4.00.ebuild,
+ metadata.xml:
+ Version bump #382797 by Justin Lecher. Add USE=netlink support #382801 by
+ Justin Lecher.
21 May 2011; Raúl Porcel <armin76@gentoo.org> quota-3.17-r1.ebuild:
alpha/ia64/sparc stable wrt #364361
diff --git a/sys-fs/quota/metadata.xml b/sys-fs/quota/metadata.xml
index 9df2fd7c26f1..2732800a7b8d 100644
--- a/sys-fs/quota/metadata.xml
+++ b/sys-fs/quota/metadata.xml
@@ -3,6 +3,7 @@
<pkgmetadata>
<herd>base-system</herd>
<use>
+ <flag name='netlink'>Compile daemon receiving quota messages via netlink</flag>
<flag name='rpc'>Enable quota interaction via RPC</flag>
</use>
</pkgmetadata>
diff --git a/sys-fs/quota/quota-4.00.ebuild b/sys-fs/quota/quota-4.00.ebuild
new file mode 100644
index 000000000000..a97a76bc076c
--- /dev/null
+++ b/sys-fs/quota/quota-4.00.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/quota/quota-4.00.ebuild,v 1.1 2011/09/14 04:58:13 vapier Exp $
+
+EAPI="2"
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Linux quota tools"
+HOMEPAGE="http://sourceforge.net/projects/linuxquota/"
+SRC_URI="mirror://sourceforge/linuxquota/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="ldap netlink nls rpc tcpd"
+
+RDEPEND="ldap? ( >=net-nds/openldap-2.3.35 )
+ netlink? ( sys-apps/dbus dev-libs/libnl )
+ rpc? ( net-nds/rpcbind )
+ tcpd? ( sys-apps/tcp-wrappers )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+S=${WORKDIR}/quota-tools
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable ldap ldapmail) \
+ $(use_enable netlink) \
+ $(use_enable rpc) \
+ $(use_enable rpc rpcsetquota)
+}
+
+src_install() {
+ emake STRIP="" ROOTDIR="${D}" install || die
+ dodoc doc/* README.* Changelog
+ rm -r "${D}"/usr/include || die #70938
+
+ insinto /etc
+ insopts -m0644
+ doins warnquota.conf quotatab || die
+
+ newinitd "${FILESDIR}"/quota.rc7 quota
+ newconfd "${FILESDIR}"/quota.confd quota
+
+ if use rpc ; then
+ newinitd "${FILESDIR}"/rpc.rquotad.initd rpc.rquotad
+ else
+ rm -f "${D}"/usr/sbin/rpc.rquotad
+ fi
+
+ if use ldap ; then
+ insinto /etc/openldap/schema
+ insopts -m0644
+ doins ldap-scripts/quota.schema || die
+
+ exeinto /usr/share/quota/ldap-scripts
+ doexe ldap-scripts/*.pl || die
+ doexe ldap-scripts/edquota_editor || die
+ fi
+}