summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorPeter Johanson <latexer@gentoo.org>2004-10-13 00:51:10 +0000
committerPeter Johanson <latexer@gentoo.org>2004-10-13 00:51:10 +0000
commit94e34860d81eb0ac1b58be59583896b7204de1fb (patch)
treed289fd124ae641460fcfea4d97e008881fc53ec2 /sys-fs
parentMask submount til it's fixed not to depend on config-kernel (diff)
downloadgentoo-2-94e34860d81eb0ac1b58be59583896b7204de1fb.tar.gz
gentoo-2-94e34860d81eb0ac1b58be59583896b7204de1fb.tar.bz2
gentoo-2-94e34860d81eb0ac1b58be59583896b7204de1fb.zip
Revision bump to not use kmod.eclass and config-kernel.
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/submount/ChangeLog8
-rw-r--r--sys-fs/submount/Manifest2
-rw-r--r--sys-fs/submount/files/digest-submount-0.9-r11
-rw-r--r--sys-fs/submount/submount-0.9-r1.ebuild94
4 files changed, 104 insertions, 1 deletions
diff --git a/sys-fs/submount/ChangeLog b/sys-fs/submount/ChangeLog
index b4e49a3c79cc..dec5dbf234f6 100644
--- a/sys-fs/submount/ChangeLog
+++ b/sys-fs/submount/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/submount
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/submount/ChangeLog,v 1.6 2004/09/27 19:48:24 dsd Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/submount/ChangeLog,v 1.7 2004/10/13 00:51:10 latexer Exp $
+
+*submount-0.9-r1 (12 Oct 2004)
+
+ 12 Oct 2004; <peter@gentoo.org> +submount-0.9-r1.ebuild:
+ Revision bump that doesn't use deprecated kmod + config-kernel. Needs quick
+ testing so it can be marked x86 and ppc and then we can un package.mask this.
27 Sep 2004; Daniel Drake <dsd@gentoo.org> submount-0.9.ebuild:
Fix unpack on 2.4 based systems
diff --git a/sys-fs/submount/Manifest b/sys-fs/submount/Manifest
index 783eb6cf3446..a01117a304dc 100644
--- a/sys-fs/submount/Manifest
+++ b/sys-fs/submount/Manifest
@@ -1,4 +1,6 @@
MD5 6097e401c04aa5d24eccd4a88d52d623 submount-0.9.ebuild 1375
+MD5 5dfe51757f381a522942277e028c8f03 submount-0.9-r1.ebuild 1735
MD5 d36532b852e3e576f009b41a7215d955 ChangeLog 725
MD5 c3aedbfe00ee1a825a9d5760b4b4271e metadata.xml 316
+MD5 f4303204067c19d5a000a8b0eac1213c files/digest-submount-0.9-r1 63
MD5 f4303204067c19d5a000a8b0eac1213c files/digest-submount-0.9 63
diff --git a/sys-fs/submount/files/digest-submount-0.9-r1 b/sys-fs/submount/files/digest-submount-0.9-r1
new file mode 100644
index 000000000000..7d8dd43dd198
--- /dev/null
+++ b/sys-fs/submount/files/digest-submount-0.9-r1
@@ -0,0 +1 @@
+MD5 f6abac328dbfb265eff18561065575c6 submount-0.9.tar.gz 75476
diff --git a/sys-fs/submount/submount-0.9-r1.ebuild b/sys-fs/submount/submount-0.9-r1.ebuild
new file mode 100644
index 000000000000..da113f28b5b0
--- /dev/null
+++ b/sys-fs/submount/submount-0.9-r1.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/submount/submount-0.9-r1.ebuild,v 1.1 2004/10/13 00:51:10 latexer Exp $
+
+inherit eutils kernel-mod
+
+IUSE=""
+
+DESCRIPTION="Submount is a new attempt to solve the removable media problem for Linux."
+HOMEPAGE="http://submount.sourceforge.net/"
+
+DEPEND="virtual/linux-sources"
+
+SLOT="${KV}"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~alpha ~ppc ~sparc ~amd64"
+
+if [ "${KV_MINOR}" == "4" ]
+then
+ EXTRA_V="-2.4"
+else
+ EXTRA_V=""
+ RESTRICT=nouserpriv
+fi
+
+MY_P="${PN}${EXTRA_V}-${PV}"
+S="${WORKDIR}/${MY_P}"
+KMOD_SOURCES="${MY_P}.tar.gz"
+
+SRC_URI="mirror://sourceforge/${PN}/${KMOD_SOURCES}"
+
+src_unpack()
+{
+ unpack ${A}
+ cd ${S}
+ kernel-mod_getversion
+
+ if [ "${KV_MINOR}" -gt 5 ] && [ "${KV_PATCH}" -gt 5 ]
+ then
+ sed -i "s:SUBDIRS=:M=:" \
+ ${S}/subfs${EXTRA_V}-${PV}/Makefile
+ else
+ eerror "This version of submount requires a kernel of 2.6.6 or greater"
+ die "Too old of a kernel found."
+ fi
+}
+
+src_compile ()
+{
+ cd ${S}/subfs${EXTRA_V}-${PV}
+ set_arch_to_kernel
+ emake KDIR=${ROOT}/usr/src/linux || die
+ set_arch_to_portage
+
+ cd ${S}/submountd${EXTRA_V}-${PV}
+ econf \
+ --sbindir=/sbin \
+ || die "Confugure error"
+
+ make || die "Make error"
+}
+
+src_install ()
+{
+ local KV_OBJ
+ if [ "${KV_MINOR}" -gt 4 ]
+ then
+ KV_OBJ=ko
+ else
+ KV_OBJ=o
+ fi
+
+ cd ${S}/submountd${EXTRA_V}-${PV}
+ make install DESTDIR=${D} mandir=/usr/share/man
+
+ cd ${S}/subfs${EXTRA_V}-${PV}
+
+ insinto /lib/modules/${KV}/fs/subfs
+
+ doins subfs.$KV_OBJ
+
+ cd ${S}
+ ./rename-docs ${PV}
+ dodoc README* COPYING INSTALL*
+}
+
+pkg_postinst ()
+{
+ if [ "${ROOT}" = / ]
+ then
+ [ -x /usr/sbin/update-modules ] && /usr/sbin/update-modules
+ fi
+}