summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2006-07-13 15:44:13 +0000
committerNed Ludd <solar@gentoo.org>2006-07-13 15:44:13 +0000
commit28ceec72873fadabdbf9648a537c62c672bc5d04 (patch)
tree163451be2f9dca648d8d96e9981111ec246eb84d /sys-libs
parent1.02.00 updated to current stable. (diff)
downloadgentoo-2-28ceec72873fadabdbf9648a537c62c672bc5d04.tar.gz
gentoo-2-28ceec72873fadabdbf9648a537c62c672bc5d04.tar.bz2
gentoo-2-28ceec72873fadabdbf9648a537c62c672bc5d04.zip
- work around broken python support when cross compile. Yanked the hack known as USE=static that should of never been added in the first place.
(Portage version: 2.1.1_pre2-r7)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libcap/ChangeLog6
-rw-r--r--sys-libs/libcap/libcap-1.10-r7.ebuild20
2 files changed, 15 insertions, 11 deletions
diff --git a/sys-libs/libcap/ChangeLog b/sys-libs/libcap/ChangeLog
index 55c8c45dedc4..1562669a0ca2 100644
--- a/sys-libs/libcap/ChangeLog
+++ b/sys-libs/libcap/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-libs/libcap
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcap/ChangeLog,v 1.35 2006/07/13 14:42:17 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcap/ChangeLog,v 1.36 2006/07/13 15:44:13 solar Exp $
+
+ 13 Jul 2006; <solar@gentoo.org> libcap-1.10-r7.ebuild:
+ - work around broken python support when cross compile. Yanked the hack
+ known as USE=static
*libcap-1.10-r7 (13 Jul 2006)
diff --git a/sys-libs/libcap/libcap-1.10-r7.ebuild b/sys-libs/libcap/libcap-1.10-r7.ebuild
index efb7fe7e00a5..1ff396ebaa58 100644
--- a/sys-libs/libcap/libcap-1.10-r7.ebuild
+++ b/sys-libs/libcap/libcap-1.10-r7.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcap/libcap-1.10-r7.ebuild,v 1.1 2006/07/13 14:42:17 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcap/libcap-1.10-r7.ebuild,v 1.2 2006/07/13 15:44:13 solar Exp $
-inherit flag-o-matic eutils python
+inherit flag-o-matic eutils python toolchain-funcs
DEB_PVER="14"
DESCRIPTION="POSIX 1003.1e capabilities"
@@ -13,7 +13,7 @@ SRC_URI="http://www.kernel.org/pub/linux/libs/security/linux-privs/kernel-2.4/${
LICENSE="GPL-2 BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="nocxx python static"
+IUSE="nocxx python"
#patch is in recent 2.2 kernels so it works there
DEPEND="virtual/os-headers
@@ -36,11 +36,12 @@ src_unpack() {
src_compile() {
local myflags=
- if use static; then
- append-flags -static
- append-ldflags -static
- fi
- if ! use nocxx && use python ; then
+ # -static is never should never be used on shared objects like a lib.
+ #if use static; then
+ # append-flags -static
+ # append-ldflags -static
+ #fi
+ if ! tc-is-cross-compiler && ! use nocxx && use python ; then
python_version
myflags="${myflags} PYTHON=1 PYTHONMODDIR=/usr/$(get_libdir)/python${PYVER}/site-packages"
append-flags "-I/usr/include/python${PYVER}"
@@ -63,7 +64,7 @@ src_install() {
dodoc CHANGELOG README pgp.keys.asc doc/capability.notes capfaq-0.2.txt
doman doc/*.3
- if ! use nocxx && use python ; then
+ if ! tc-is-cross-compiler && ! use nocxx && use python ; then
python_version
local PYTHONMODDIR="/usr/$(get_libdir)/python${PYVER}/site-packages"
exeinto "${PYTHONMODDIR}"
@@ -72,4 +73,3 @@ src_install() {
doins libcap/libcap.py
fi
}
-