summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Nichols <nichoj@gentoo.org>2006-07-25 21:14:14 +0000
committerJoshua Nichols <nichoj@gentoo.org>2006-07-25 21:14:14 +0000
commitd805401f187721e0223aab6fd131c73eef2e7b5c (patch)
tree75e82bfd62c12756f5f44a2aaf198c9cbc4c7446 /sys-libs
parentFix for as-needed, bug #141709. (diff)
downloadgentoo-2-d805401f187721e0223aab6fd131c73eef2e7b5c.tar.gz
gentoo-2-d805401f187721e0223aab6fd131c73eef2e7b5c.tar.bz2
gentoo-2-d805401f187721e0223aab6fd131c73eef2e7b5c.zip
Revision bumps to support new Java system.
(Portage version: 2.1.1_pre2-r4)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/db/ChangeLog13
-rw-r--r--sys-libs/db/db-4.2.52_p4-r2.ebuild132
-rw-r--r--sys-libs/db/db-4.3.29-r2.ebuild139
-rw-r--r--sys-libs/db/files/db-4.2-jni-check-prefix-first.patch30
-rw-r--r--sys-libs/db/files/db-4.2-listen-to-java-options.patch10
-rw-r--r--sys-libs/db/files/db-4.3-jni-check-prefix-first.patch30
-rw-r--r--sys-libs/db/files/db-4.3-listen-to-java-options.patch10
-rw-r--r--sys-libs/db/files/digest-db-4.2.52_p4-r215
-rw-r--r--sys-libs/db/files/digest-db-4.3.29-r23
9 files changed, 381 insertions, 1 deletions
diff --git a/sys-libs/db/ChangeLog b/sys-libs/db/ChangeLog
index 11c7831cbed4..7623486787c1 100644
--- a/sys-libs/db/ChangeLog
+++ b/sys-libs/db/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for sys-libs/db
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/ChangeLog,v 1.163 2006/06/12 08:37:37 pauldv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/ChangeLog,v 1.164 2006/07/25 21:14:14 nichoj Exp $
+
+*db-4.3.29-r2 (25 Jul 2006)
+*db-4.2.52_p4-r2 (25 Jul 2006)
+
+ 25 Jul 2006; Joshua Nichols <nichoj@gentoo.org>
+ +files/db-4.2-jni-check-prefix-first.patch,
+ +files/db-4.2-listen-to-java-options.patch,
+ +files/db-4.3-jni-check-prefix-first.patch,
+ +files/db-4.3-listen-to-java-options.patch, +db-4.2.52_p4-r2.ebuild,
+ +db-4.3.29-r2.ebuild:
+ Revision bumps to support new Java system.
12 Jun 2006; Paul de Vrieze <pauldv@gentoo.org> db-4.3.29.ebuild:
This upstream tarball has also changed.
diff --git a/sys-libs/db/db-4.2.52_p4-r2.ebuild b/sys-libs/db/db-4.2.52_p4-r2.ebuild
new file mode 100644
index 000000000000..f3559c63d682
--- /dev/null
+++ b/sys-libs/db/db-4.2.52_p4-r2.ebuild
@@ -0,0 +1,132 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.2.52_p4-r2.ebuild,v 1.1 2006/07/25 21:14:14 nichoj Exp $
+
+inherit eutils gnuconfig db java-pkg-opt-2
+
+#Number of official patches
+#PATCHNO=`echo ${PV}|sed -e "s,\(.*_p\)\([0-9]*\),\2,"`
+PATCHNO=${PV/*.*.*_p}
+if [ "${PATCHNO}" == "${PV}" ]; then
+ MY_PV=${PV}
+ MY_P=${P}
+ PATCHNO=0
+else
+ MY_PV=${PV/_p${PATCHNO}}
+ MY_P=${PN}-${MY_PV}
+fi
+
+S=${WORKDIR}/${MY_P}/build_unix
+DESCRIPTION="Berkeley DB"
+HOMEPAGE="http://www.sleepycat.com/"
+SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
+for (( i=1 ; i<=$PATCHNO ; i++ )) ; do
+ export SRC_URI="${SRC_URI} http://www.sleepycat.com/update/${MY_PV}/patch.${MY_PV}.${i}"
+done
+
+LICENSE="DB"
+SLOT="4.2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="tcltk java doc nocxx bootstrap"
+
+DEPEND="tcltk? ( >=dev-lang/tcl-8.4 )
+ java? ( >=virtual/jdk-1.4 )"
+RDEPEND="tcltk? ( dev-lang/tcl )
+ java? ( >=virtual/jre-1.4 )"
+
+src_unpack() {
+ unpack ${MY_P}.tar.gz
+ cd ${WORKDIR}/${MY_P}
+ for (( i=1 ; i<=$PATCHNO ; i++ ))
+ do
+ epatch ${DISTDIR}/patch.${MY_PV}.${i}
+ done
+ epatch ${FILESDIR}/${PN}-${SLOT}-libtool.patch
+ epatch ${FILESDIR}/${PN}-4.0.14-fix-dep-link.patch
+ epatch ${FILESDIR}/${PN}-4.2.52_p2-TXN.patch
+
+ # use the includes from the prefix
+ epatch ${FILESDIR}/${PN}-${SLOT}-jni-check-prefix-first.patch
+ epatch ${FILESDIR}/${PN}-${SLOT}-listen-to-java-options.patch
+
+ gnuconfig_update "${S}/../dist"
+
+ sed -i -e "s,\(ac_compiler\|\${MAKEFILE_CC}\|\${MAKEFILE_CXX}\|\$CC\)\( *--version\),\1 -dumpversion,g" ${S}/../dist/configure
+}
+
+src_compile() {
+ local myconf=""
+
+ use amd64 && myconf="${myconf} --with-mutex=x86/gcc-assembly"
+
+ use bootstrap \
+ && myconf="${myconf} --disable-cxx" \
+ || myconf="${myconf} $(use_enable !nocxx cxx)"
+
+ use tcltk \
+ && myconf="${myconf} --enable-tcl --with-tcl=/usr/$(get_libdir)" \
+ || myconf="${myconf} --disable-tcl"
+
+ myconf="${myconf} $(use_enable java)"
+ if use java; then
+ myconf="${myconf} --with-java-prefix=${JAVA_HOME}"
+ # Can't get this working any other way, since it returns spaces, and
+ # bash doesn't seem to want to pass correctly in any way i try
+ local javaconf="-with-javac-flags=$(java-pkg_javac-args)"
+ fi
+
+ [[ -n ${CBUILD} ]] && myconf="${myconf} --build=${CBUILD}"
+
+ # the entire testsuite needs the TCL functionality
+ if use tcltk && has test $FEATURES; then
+ myconf="${myconf} --enable-test"
+ else
+ myconf="${myconf} --disable-test"
+ fi
+
+ ../dist/configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --datadir=/usr/share \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ --libdir=/usr/$(get_libdir) \
+ --enable-compat185 \
+ --with-uniquename \
+ --enable-rpc \
+ --host=${CHOST} \
+ ${myconf} "${javaconf}" || die "configure failed"
+
+ emake -j1 || die "make failed"
+}
+
+src_install() {
+
+ einstall libdir="${D}/usr/$(get_libdir)" strip="${D}/bin/strip" || die
+
+ db_src_install_usrbinslot
+
+ db_src_install_headerslot
+
+ db_src_install_doc
+
+ db_src_install_usrlibcleanup
+
+ dodir /usr/sbin
+ mv ${D}/usr/bin/berkeley_db_svc ${D}/usr/sbin/berkeley_db42_svc
+
+ if use java; then
+ java-pkg_regso ${D}/usr/lib/libdb_java*.so
+ java-pkg_dojar ${D}/usr/lib/*.jar
+ rm ${D}/usr/lib/*.jar
+ fi
+}
+
+pkg_postinst () {
+ db_fix_so
+}
+
+pkg_postrm () {
+ db_fix_so
+}
diff --git a/sys-libs/db/db-4.3.29-r2.ebuild b/sys-libs/db/db-4.3.29-r2.ebuild
new file mode 100644
index 000000000000..c50caba30e19
--- /dev/null
+++ b/sys-libs/db/db-4.3.29-r2.ebuild
@@ -0,0 +1,139 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.3.29-r2.ebuild,v 1.1 2006/07/25 21:14:14 nichoj Exp $
+
+inherit eutils gnuconfig db flag-o-matic java-pkg-opt-2
+
+#Number of official patches
+#PATCHNO=`echo ${PV}|sed -e "s,\(.*_p\)\([0-9]*\),\2,"`
+PATCHNO=${PV/*.*.*_p}
+if [ "${PATCHNO}" == "${PV}" ]; then
+ MY_PV=${PV}
+ MY_P=${P}
+ PATCHNO=0
+else
+ MY_PV=${PV/_p${PATCHNO}}
+ MY_P=${PN}-${MY_PV}
+fi
+
+S=${WORKDIR}/${MY_P}/build_unix
+DESCRIPTION="Berkeley DB"
+HOMEPAGE="http://www.sleepycat.com/"
+SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
+#SRC_URI="ftp://ftp.sleepycat.com/releases/${MY_P}.tar.gz"
+for (( i=1 ; i<=$PATCHNO ; i++ )) ; do
+ export SRC_URI="${SRC_URI} http://www.sleepycat.com/update/${MY_PV}/patch.${MY_PV}.${i}"
+done
+
+LICENSE="DB"
+SLOT="4.3"
+KEYWORDS="~amd64 ~ia64 ~m68k ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="tcltk java doc nocxx bootstrap"
+
+DEPEND="tcltk? ( >=dev-lang/tcl-8.4 )
+ java? ( >=virtual/jdk-1.4 )
+ >=sys-devel/binutils-2.16.1"
+RDEPEND="tcltk? ( dev-lang/tcl )
+ java? ( >=virtual/jre-1.4 )"
+
+src_unpack() {
+ unpack ${MY_P}.tar.gz
+ cd ${WORKDIR}/${MY_P}
+ for (( i=1 ; i<=$PATCHNO ; i++ ))
+ do
+ epatch ${DISTDIR}/patch.${MY_PV}.${i}
+ done
+ epatch ${FILESDIR}/${PN}-${SLOT}-libtool.patch
+
+ epatch ${FILESDIR}/${PN}-4.3.27-fix-dep-link.patch
+
+ # use the includes from the prefix
+ epatch ${FILESDIR}/${PN}-${SLOT}-jni-check-prefix-first.patch
+ epatch ${FILESDIR}/${PN}-${SLOT}-listen-to-java-options.patch
+
+ gnuconfig_update "${S}/../dist"
+
+ sed -i -e "s,\(ac_compiler\|\${MAKEFILE_CC}\|\${MAKEFILE_CXX}\|\$CC\)\( *--version\),\1 -dumpversion,g" ${S}/../dist/configure
+}
+
+src_compile() {
+ local myconf=""
+
+ use amd64 && myconf="${myconf} --with-mutex=x86/gcc-assembly"
+
+ use bootstrap \
+ && myconf="${myconf} --disable-cxx" \
+ || myconf="${myconf} $(use_enable !nocxx cxx)"
+
+ use tcltk \
+ && myconf="${myconf} --enable-tcl --with-tcl=/usr/$(get_libdir)" \
+ || myconf="${myconf} --disable-tcl"
+
+ myconf="${myconf} $(use_enable java)"
+ if use java; then
+ myconf="${myconf} --with-java-prefix=${JAVA_HOME}"
+ # Can't get this working any other way, since it returns spaces, and
+ # bash doesn't seem to want to pass correctly in any way i try
+ local javaconf="-with-javac-flags=$(java-pkg_javac-args)"
+ fi
+
+ [[ -n ${CBUILD} ]] && myconf="${myconf} --build=${CBUILD}"
+
+ # the entire testsuite needs the TCL functionality
+ if use tcltk && has test $FEATURES ; then
+ myconf="${myconf} --enable-test"
+ else
+ myconf="${myconf} --disable-test"
+ fi
+
+ # Add linker versions to the symbols. Easier to do, and safer than header file
+ # mumbo jumbo.
+ if use userland_GNU; then
+ append-ldflags -Wl,--default-symver
+ fi
+
+ ../dist/configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --datadir=/usr/share \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ --libdir=/usr/$(get_libdir) \
+ --enable-compat185 \
+ --without-uniquename \
+ --enable-rpc \
+ --host=${CHOST} \
+ ${myconf} "${javaconf}" || die "configure failed"
+
+ emake -j1 || die "make failed"
+}
+
+src_install() {
+ einstall libdir="${D}/usr/$(get_libdir)" strip="${D}/bin/strip" || die
+
+ db_src_install_usrbinslot
+
+ db_src_install_headerslot
+
+ db_src_install_doc
+
+ db_src_install_usrlibcleanup
+
+ dodir /usr/sbin
+ mv ${D}/usr/bin/berkeley_db_svc ${D}/usr/sbin/berkeley_db43_svc
+
+ if use java; then
+ java-pkg_regso ${D}/usr/lib/libdb_java*.so
+ java-pkg_dojar ${D}/usr/lib/*.jar
+ rm ${D}/usr/lib/*.jar
+ fi
+}
+
+pkg_postinst() {
+ db_fix_so
+}
+
+pkg_postrm() {
+ db_fix_so
+}
diff --git a/sys-libs/db/files/db-4.2-jni-check-prefix-first.patch b/sys-libs/db/files/db-4.2-jni-check-prefix-first.patch
new file mode 100644
index 000000000000..17f80e1bcfef
--- /dev/null
+++ b/sys-libs/db/files/db-4.2-jni-check-prefix-first.patch
@@ -0,0 +1,30 @@
+--- dist/aclocal_java/ac_jni_include_dirs.ac 2003-10-06 20:41:38.000000000 +0200
++++ dist/aclocal_java/ac_jni_include_dirs.ac 2005-09-23 21:31:26.000000000 +0200
+@@ -43,14 +43,19 @@
+ *) AC_MSG_ERROR([$_ACJNI_JAVAC is not an absolute path name]);;
+ esac
+
+-_ACJNI_FOLLOW_SYMLINKS("$_ACJNI_JAVAC")
+-_JTOPDIR=`echo "$_ACJNI_FOLLOWED" | sed -e 's://*:/:g' -e 's:/[[^/]]*$::'`
+-case "$host_os" in
+- darwin*) _JTOPDIR=`echo "$_JTOPDIR" | sed -e 's:/[[^/]]*$::'`
+- _JINC="$_JTOPDIR/Headers";;
+- *) _JINC="$_JTOPDIR/include";;
+-esac
+-
++# If JAVAPREFIX is defined, look there first
++if test -r "$JAVAPREFIX/include/jni.h"; then
++ _JTOPDIR="$JAVAPREFIX"
++ _JINC="$JAVAPREFIX/include"
++else
++ _ACJNI_FOLLOW_SYMLINKS("$_ACJNI_JAVAC")
++ _JTOPDIR=`echo "$_ACJNI_FOLLOWED" | sed -e 's://*:/:g' -e 's:/[[^/]]*$::'`
++ case "$host_os" in
++ darwin*) _JTOPDIR=`echo "$_JTOPDIR" | sed -e 's:/[[^/]]*$::'`
++ _JINC="$_JTOPDIR/Headers";;
++ *) _JINC="$_JTOPDIR/include";;
++ esac
++fi
+ # If we find jni.h in /usr/include, then it's not a java-only tree, so
+ # don't add /usr/include or subdirectories to the list of includes.
+ # An extra -I/usr/include can foul things up with newer gcc's.
diff --git a/sys-libs/db/files/db-4.2-listen-to-java-options.patch b/sys-libs/db/files/db-4.2-listen-to-java-options.patch
new file mode 100644
index 000000000000..8ddb46b70261
--- /dev/null
+++ b/sys-libs/db/files/db-4.2-listen-to-java-options.patch
@@ -0,0 +1,10 @@
+--- dist/configure.ac 2005-09-23 21:01:26.000000000 +0200
++++ dist/configure.ac 2005-09-23 20:59:20.000000000 +0200
+@@ -385,6 +385,7 @@
+ # A classpath that includes . is needed to check for Java
+ CLASSPATH=".:$CLASSPATH"
+ export CLASSPATH
++ AC_JAVA_OPTIONS
+ AC_PROG_JAVAC
+ AC_PROG_JAR
+ AC_PROG_JAVA
diff --git a/sys-libs/db/files/db-4.3-jni-check-prefix-first.patch b/sys-libs/db/files/db-4.3-jni-check-prefix-first.patch
new file mode 100644
index 000000000000..17f80e1bcfef
--- /dev/null
+++ b/sys-libs/db/files/db-4.3-jni-check-prefix-first.patch
@@ -0,0 +1,30 @@
+--- dist/aclocal_java/ac_jni_include_dirs.ac 2003-10-06 20:41:38.000000000 +0200
++++ dist/aclocal_java/ac_jni_include_dirs.ac 2005-09-23 21:31:26.000000000 +0200
+@@ -43,14 +43,19 @@
+ *) AC_MSG_ERROR([$_ACJNI_JAVAC is not an absolute path name]);;
+ esac
+
+-_ACJNI_FOLLOW_SYMLINKS("$_ACJNI_JAVAC")
+-_JTOPDIR=`echo "$_ACJNI_FOLLOWED" | sed -e 's://*:/:g' -e 's:/[[^/]]*$::'`
+-case "$host_os" in
+- darwin*) _JTOPDIR=`echo "$_JTOPDIR" | sed -e 's:/[[^/]]*$::'`
+- _JINC="$_JTOPDIR/Headers";;
+- *) _JINC="$_JTOPDIR/include";;
+-esac
+-
++# If JAVAPREFIX is defined, look there first
++if test -r "$JAVAPREFIX/include/jni.h"; then
++ _JTOPDIR="$JAVAPREFIX"
++ _JINC="$JAVAPREFIX/include"
++else
++ _ACJNI_FOLLOW_SYMLINKS("$_ACJNI_JAVAC")
++ _JTOPDIR=`echo "$_ACJNI_FOLLOWED" | sed -e 's://*:/:g' -e 's:/[[^/]]*$::'`
++ case "$host_os" in
++ darwin*) _JTOPDIR=`echo "$_JTOPDIR" | sed -e 's:/[[^/]]*$::'`
++ _JINC="$_JTOPDIR/Headers";;
++ *) _JINC="$_JTOPDIR/include";;
++ esac
++fi
+ # If we find jni.h in /usr/include, then it's not a java-only tree, so
+ # don't add /usr/include or subdirectories to the list of includes.
+ # An extra -I/usr/include can foul things up with newer gcc's.
diff --git a/sys-libs/db/files/db-4.3-listen-to-java-options.patch b/sys-libs/db/files/db-4.3-listen-to-java-options.patch
new file mode 100644
index 000000000000..8ddb46b70261
--- /dev/null
+++ b/sys-libs/db/files/db-4.3-listen-to-java-options.patch
@@ -0,0 +1,10 @@
+--- dist/configure.ac 2005-09-23 21:01:26.000000000 +0200
++++ dist/configure.ac 2005-09-23 20:59:20.000000000 +0200
+@@ -385,6 +385,7 @@
+ # A classpath that includes . is needed to check for Java
+ CLASSPATH=".:$CLASSPATH"
+ export CLASSPATH
++ AC_JAVA_OPTIONS
+ AC_PROG_JAVAC
+ AC_PROG_JAR
+ AC_PROG_JAVA
diff --git a/sys-libs/db/files/digest-db-4.2.52_p4-r2 b/sys-libs/db/files/digest-db-4.2.52_p4-r2
new file mode 100644
index 000000000000..58f9581b01fb
--- /dev/null
+++ b/sys-libs/db/files/digest-db-4.2.52_p4-r2
@@ -0,0 +1,15 @@
+MD5 cbc77517c9278cdb47613ce8cb55779f db-4.2.52.tar.gz 4073147
+RMD160 d9095bce12b519695f3d1ff708dc0d1babd7a4b2 db-4.2.52.tar.gz 4073147
+SHA256 72f581d8b91da900434629886d1d1c6ea8b9d2a9329368c3b875e7cd556b6a0e db-4.2.52.tar.gz 4073147
+MD5 1227f5f9ff43d48b5b1759e113a1c2d7 patch.4.2.52.1 988
+RMD160 1ff7d93c4e6223b793ed3038070a4f0957dac44e patch.4.2.52.1 988
+SHA256 98b7580916459ee931b9c7e06dcb9da980732672fe0811714933f366ad97dfa5 patch.4.2.52.1 988
+MD5 3da7efd8d29919a9113e2f6f5166f5b7 patch.4.2.52.2 1433
+RMD160 880cd32f5bd1430463da0f4169e1d6e4a2b96b81 patch.4.2.52.2 1433
+SHA256 c9b132bcc8f1c12e03baaf47abd3801f2adf24ffbd56f35a27617fec12654f32 patch.4.2.52.2 1433
+MD5 0bf9ebbe852652bed433e522928d40ec patch.4.2.52.3 8672
+RMD160 443b5cb93346482166f407c8fb9522035d151f02 patch.4.2.52.3 8672
+SHA256 ca5245d2e1c7a40df5ec57cbabee8bf0106292c69a37eb0ca275d1aa59061907 patch.4.2.52.3 8672
+MD5 9cfeff4dce0c11372c0b04b134f8faef patch.4.2.52.4 1311
+RMD160 d6154a5e1203348d37e2f537300582fc06fc9def patch.4.2.52.4 1311
+SHA256 c15c82071c02ce1a10024c572e2e9fd72006089007141a01fdd37b889411b973 patch.4.2.52.4 1311
diff --git a/sys-libs/db/files/digest-db-4.3.29-r2 b/sys-libs/db/files/digest-db-4.3.29-r2
new file mode 100644
index 000000000000..8b53cf06bcf3
--- /dev/null
+++ b/sys-libs/db/files/digest-db-4.3.29-r2
@@ -0,0 +1,3 @@
+MD5 13585a20ce32f113b8e8cdb57f52e3bb db-4.3.29.tar.gz 6103264
+RMD160 fac910828a74087124e9cc3cad99c6a6dc88c14b db-4.3.29.tar.gz 6103264
+SHA256 db3e762d819f9a31bc4ebf5ecada53e9787aeb26fc92fa6064b2ba57df806af4 db-4.3.29.tar.gz 6103264