summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2008-05-10 06:50:17 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2008-05-10 06:50:17 +0000
commit00998512033f0cec901e70fcf085e20709146748 (patch)
treeb07e37935a0388114db5ebab86c892de17caa16a /x11-base
parentUsing Makefile.PL again. (diff)
downloadgentoo-2-00998512033f0cec901e70fcf085e20709146748.tar.gz
gentoo-2-00998512033f0cec901e70fcf085e20709146748.tar.bz2
gentoo-2-00998512033f0cec901e70fcf085e20709146748.zip
Add patches in my 'server-1.4-branch-gentoo' branch that I've submitted upstream and am waiting for them to take.
(Portage version: 2.1.5_rc7)
Diffstat (limited to 'x11-base')
-rw-r--r--x11-base/xorg-server/ChangeLog17
-rw-r--r--x11-base/xorg-server/files/1.4.0.90/0038-dmx-fix-build-by-adding-New-Delete-InputDeviceRequ.patch31
-rw-r--r--x11-base/xorg-server/files/1.4.0.90/0039-dmx-link-in-XSERVER_LIBS.patch24
-rw-r--r--x11-base/xorg-server/files/1.4.0.90/0040-xephyr-fix-linking-by-adding-pixman-and-using-XSERV.patch38
-rw-r--r--x11-base/xorg-server/files/1.4.0.90/0041-xprint-fix-build-by-adding-New-Delete-InputDeviceR.patch34
-rw-r--r--x11-base/xorg-server/files/1.4.0.90/0042-xprint-fix-linking-by-including-XSERVER_LIBS.patch25
-rw-r--r--x11-base/xorg-server/files/1.4.0.90/0043-Fix-RandR-1.2-driver-interface-conversion-of-two-col.patch31
-rw-r--r--x11-base/xorg-server/files/1.4.0.90/0044-Fix-overly-restrictive-integer-overflow-check-in-EXA.patch28
-rw-r--r--x11-base/xorg-server/xorg-server-1.4.0.90-r4.ebuild7
9 files changed, 228 insertions, 7 deletions
diff --git a/x11-base/xorg-server/ChangeLog b/x11-base/xorg-server/ChangeLog
index b0ae05a087d4..035d3130c11e 100644
--- a/x11-base/xorg-server/ChangeLog
+++ b/x11-base/xorg-server/ChangeLog
@@ -1,6 +1,21 @@
# ChangeLog for x11-base/xorg-server
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-server/ChangeLog,v 1.327 2008/05/09 22:22:54 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-server/ChangeLog,v 1.328 2008/05/10 06:50:16 dberkholz Exp $
+
+ 10 May 2008; Donnie Berkholz <dberkholz@gentoo.org>;
+ +files/1.4.0.90/0038-dmx-fix-build-by-adding-New-Delete-InputDeviceRequ.pa
+ tch, +files/1.4.0.90/0039-dmx-link-in-XSERVER_LIBS.patch,
+ +files/1.4.0.90/0040-xephyr-fix-linking-by-adding-pixman-and-using-XSERV.p
+ atch,
+ +files/1.4.0.90/0041-xprint-fix-build-by-adding-New-Delete-InputDeviceR.pa
+ tch,
+ +files/1.4.0.90/0043-Fix-RandR-1.2-driver-interface-conversion-of-two-col.
+ patch,
+ +files/1.4.0.90/0042-xprint-fix-linking-by-including-XSERVER_LIBS.patch,
+ +files/1.4.0.90/0044-Fix-overly-restrictive-integer-overflow-check-in-EXA.
+ patch, xorg-server-1.4.0.90-r4.ebuild:
+ Add patches in my 'server-1.4-branch-gentoo' branch that I've submitted
+ upstream and am waiting for them to take.
09 May 2008; Donnie Berkholz <dberkholz@gentoo.org>;
xorg-server-1.4.0.90-r4.ebuild:
diff --git a/x11-base/xorg-server/files/1.4.0.90/0038-dmx-fix-build-by-adding-New-Delete-InputDeviceRequ.patch b/x11-base/xorg-server/files/1.4.0.90/0038-dmx-fix-build-by-adding-New-Delete-InputDeviceRequ.patch
new file mode 100644
index 000000000000..aa7ce15a7f62
--- /dev/null
+++ b/x11-base/xorg-server/files/1.4.0.90/0038-dmx-fix-build-by-adding-New-Delete-InputDeviceRequ.patch
@@ -0,0 +1,31 @@
+From 57af7704ec129ae0dbd941dece62bba3401e008f Mon Sep 17 00:00:00 2001
+From: Donnie Berkholz <dberkholz@gentoo.org>
+Date: Thu, 8 May 2008 00:04:36 -0700
+Subject: [PATCH] dmx: fix build by adding {New,Delete}InputDeviceRequest.
+
+---
+ hw/dmx/dmxinput.c | 11 +++++++++++
+ 1 files changed, 11 insertions(+), 0 deletions(-)
+
+diff --git a/hw/dmx/dmxinput.c b/hw/dmx/dmxinput.c
+index d644b5d..83f8a4a 100644
+--- a/hw/dmx/dmxinput.c
++++ b/hw/dmx/dmxinput.c
+@@ -105,3 +105,14 @@ void dmxUpdateWindowInfo(DMXUpdateType type, WindowPtr pWindow)
+ if (!dmxInput->detached && dmxInput->updateWindowInfo)
+ dmxInput->updateWindowInfo(dmxInput, type, pWindow);
+ }
++
++int
++NewInputDeviceRequest (InputOption *options, DeviceIntPtr *pdev)
++{
++ return BadRequest;
++}
++
++void
++DeleteInputDeviceRequest(DeviceIntPtr pDev)
++{
++}
+--
+1.5.5.1
+
diff --git a/x11-base/xorg-server/files/1.4.0.90/0039-dmx-link-in-XSERVER_LIBS.patch b/x11-base/xorg-server/files/1.4.0.90/0039-dmx-link-in-XSERVER_LIBS.patch
new file mode 100644
index 000000000000..b82859a52b53
--- /dev/null
+++ b/x11-base/xorg-server/files/1.4.0.90/0039-dmx-link-in-XSERVER_LIBS.patch
@@ -0,0 +1,24 @@
+From 2ab2b7ced1241afa48c4af953c761c905ec04aee Mon Sep 17 00:00:00 2001
+From: Donnie Berkholz <dberkholz@gentoo.org>
+Date: Thu, 8 May 2008 00:05:00 -0700
+Subject: [PATCH] dmx: link in XSERVER_LIBS.
+
+---
+ hw/dmx/Makefile.am | 1 +
+ 1 files changed, 1 insertions(+), 0 deletions(-)
+
+diff --git a/hw/dmx/Makefile.am b/hw/dmx/Makefile.am
+index 002ea11..15dc281 100644
+--- a/hw/dmx/Makefile.am
++++ b/hw/dmx/Makefile.am
+@@ -87,6 +87,7 @@ Xdmx_LDADD = $(XORG_CORE_LIBS) \
+ $(GLX_LIBS) \
+ input/libdmxinput.a \
+ config/libdmxconfig.a \
++ @XSERVER_LIBS@ \
+ @DMXMODULES_LIBS@
+
+ # Man page
+--
+1.5.5.1
+
diff --git a/x11-base/xorg-server/files/1.4.0.90/0040-xephyr-fix-linking-by-adding-pixman-and-using-XSERV.patch b/x11-base/xorg-server/files/1.4.0.90/0040-xephyr-fix-linking-by-adding-pixman-and-using-XSERV.patch
new file mode 100644
index 000000000000..c5ad8c92b37c
--- /dev/null
+++ b/x11-base/xorg-server/files/1.4.0.90/0040-xephyr-fix-linking-by-adding-pixman-and-using-XSERV.patch
@@ -0,0 +1,38 @@
+From 09df8eb5321d92817f2dd398ad0ae4551163fc82 Mon Sep 17 00:00:00 2001
+From: Donnie Berkholz <dberkholz@gentoo.org>
+Date: Thu, 8 May 2008 00:06:16 -0700
+Subject: [PATCH] xephyr: fix linking by adding pixman and using XSERVER_LIBS.
+
+---
+ configure.ac | 2 +-
+ hw/kdrive/ephyr/Makefile.am | 1 +
+ 2 files changed, 2 insertions(+), 1 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index c73f4a7..6145aa2 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -1814,7 +1814,7 @@ if test "$KDRIVE" = yes; then
+ XSDL_INCS="`sdl-config --cflags` $XSERVER_CFLAGS"
+ fi
+
+- PKG_CHECK_MODULES(XEPHYR, x11 xext xfont xau xdmcp, [xephyr="yes"], [xephyr="no"])
++ PKG_CHECK_MODULES(XEPHYR, x11 xext xfont xau xdmcp $PIXMAN, [xephyr="yes"], [xephyr="no"])
+ if test "x$XEPHYR" = xauto; then
+ XEPHYR=$xephyr
+ fi
+diff --git a/hw/kdrive/ephyr/Makefile.am b/hw/kdrive/ephyr/Makefile.am
+index cc3019f..1738d0f 100644
+--- a/hw/kdrive/ephyr/Makefile.am
++++ b/hw/kdrive/ephyr/Makefile.am
+@@ -28,6 +28,7 @@ Xephyr_LDADD = \
+ libxephyr-hostx.a \
+ ../../../exa/libexa.la \
+ @KDRIVE_LIBS@ \
++ @XSERVER_LIBS@ \
+ @XEPHYR_LIBS@
+
+ Xephyr_DEPENDENCIES = \
+--
+1.5.5.1
+
diff --git a/x11-base/xorg-server/files/1.4.0.90/0041-xprint-fix-build-by-adding-New-Delete-InputDeviceR.patch b/x11-base/xorg-server/files/1.4.0.90/0041-xprint-fix-build-by-adding-New-Delete-InputDeviceR.patch
new file mode 100644
index 000000000000..73a857ced794
--- /dev/null
+++ b/x11-base/xorg-server/files/1.4.0.90/0041-xprint-fix-build-by-adding-New-Delete-InputDeviceR.patch
@@ -0,0 +1,34 @@
+From a678833702ca931687252799fa3453f7decb2e93 Mon Sep 17 00:00:00 2001
+From: Donnie Berkholz <dberkholz@gentoo.org>
+Date: Thu, 8 May 2008 00:07:57 -0700
+Subject: [PATCH] xprint: fix build by adding {New,Delete}InputDeviceRequest.
+
+---
+ hw/xprint/ddxInit.c | 11 +++++++++++
+ 1 files changed, 11 insertions(+), 0 deletions(-)
+
+diff --git a/hw/xprint/ddxInit.c b/hw/xprint/ddxInit.c
+index a465c4c..1e7652e 100644
+--- a/hw/xprint/ddxInit.c
++++ b/hw/xprint/ddxInit.c
+@@ -310,6 +310,17 @@ ChangeDeviceControl (
+ return BadMatch;
+ }
+
++int
++NewInputDeviceRequest(InputOption *options, DeviceIntPtr *pdev)
++{
++ return BadValue;
++}
++
++void
++DeleteInputDeviceRequest(DeviceIntPtr dev)
++{
++}
++
+ void
+ OpenInputDevice (
+ DeviceIntPtr dev,
+--
+1.5.5.1
+
diff --git a/x11-base/xorg-server/files/1.4.0.90/0042-xprint-fix-linking-by-including-XSERVER_LIBS.patch b/x11-base/xorg-server/files/1.4.0.90/0042-xprint-fix-linking-by-including-XSERVER_LIBS.patch
new file mode 100644
index 000000000000..eee0891016ef
--- /dev/null
+++ b/x11-base/xorg-server/files/1.4.0.90/0042-xprint-fix-linking-by-including-XSERVER_LIBS.patch
@@ -0,0 +1,25 @@
+From 1b2d80aa7862397309c59819d42d27dab879b08d Mon Sep 17 00:00:00 2001
+From: Donnie Berkholz <dberkholz@gentoo.org>
+Date: Thu, 8 May 2008 00:08:12 -0700
+Subject: [PATCH] xprint: fix linking by including XSERVER_LIBS.
+
+---
+ hw/xprint/Makefile.am | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/hw/xprint/Makefile.am b/hw/xprint/Makefile.am
+index f834966..2269544 100644
+--- a/hw/xprint/Makefile.am
++++ b/hw/xprint/Makefile.am
+@@ -12,7 +12,7 @@ Xprt_LDFLAGS = -L$(top_srcdir)
+ Xprt_LDADD = @XPRINT_LIBS@ ps/libps.la raster/libraster.la \
+ pcl/libpcl.la pcl-mono/libpcl.la $(top_builddir)/fb/libfb.la \
+ $(top_builddir)/render/librender.la $(top_builddir)/mi/libmi.la \
+- $(top_builddir)/Xext/libXext.la @FREETYPE_LIBS@
++ $(top_builddir)/Xext/libXext.la @FREETYPE_LIBS@ @XSERVER_LIBS@
+
+ miinitext-wrapper.c:
+ echo "#include \"$(top_srcdir)/mi/miinitext.c\"" >> $@
+--
+1.5.5.1
+
diff --git a/x11-base/xorg-server/files/1.4.0.90/0043-Fix-RandR-1.2-driver-interface-conversion-of-two-col.patch b/x11-base/xorg-server/files/1.4.0.90/0043-Fix-RandR-1.2-driver-interface-conversion-of-two-col.patch
new file mode 100644
index 000000000000..e4a501a265e7
--- /dev/null
+++ b/x11-base/xorg-server/files/1.4.0.90/0043-Fix-RandR-1.2-driver-interface-conversion-of-two-col.patch
@@ -0,0 +1,31 @@
+From 0c30521759eb9ad4cbb47b6fd79630a424352bc6 Mon Sep 17 00:00:00 2001
+From: =?utf-8?q?Michel=20D=C3=A4nzer?= <michel@tungstengraphics.com>
+Date: Thu, 20 Mar 2008 09:18:29 -0400
+Subject: [PATCH] Fix RandR 1.2 driver interface conversion of two colour cursors to ARGB
+
+This patch (and not setting HARDWARE_CURSOR_BIT_ORDER_MSBFIRST on big endian
+platforms) fixes it for me with the radeon driver and doesn't break intel.
+
+Correct patch this time :)
+(cherry picked from commit da973e962d09854b571320dee7dd9569060bc39e)
+---
+ hw/xfree86/modes/xf86Cursors.c | 3 ++-
+ 1 files changed, 2 insertions(+), 1 deletions(-)
+
+diff --git a/hw/xfree86/modes/xf86Cursors.c b/hw/xfree86/modes/xf86Cursors.c
+index b510164..a7616e0 100644
+--- a/hw/xfree86/modes/xf86Cursors.c
++++ b/hw/xfree86/modes/xf86Cursors.c
+@@ -137,7 +137,8 @@ cursor_bitpos (int flags, int x, Bool mask)
+ mask = !mask;
+ if (flags & HARDWARE_CURSOR_NIBBLE_SWAPPED)
+ x = (x & ~3) | (3 - (x & 3));
+- if (flags & HARDWARE_CURSOR_BIT_ORDER_MSBFIRST)
++ if (((flags & HARDWARE_CURSOR_BIT_ORDER_MSBFIRST) == 0) ==
++ (X_BYTE_ORDER == X_BIG_ENDIAN))
+ x = (x & ~7) | (7 - (x & 7));
+ if (flags & HARDWARE_CURSOR_SOURCE_MASK_INTERLEAVE_1)
+ x = (x << 1) + mask;
+--
+1.5.5.1
+
diff --git a/x11-base/xorg-server/files/1.4.0.90/0044-Fix-overly-restrictive-integer-overflow-check-in-EXA.patch b/x11-base/xorg-server/files/1.4.0.90/0044-Fix-overly-restrictive-integer-overflow-check-in-EXA.patch
new file mode 100644
index 000000000000..a919ece55e6e
--- /dev/null
+++ b/x11-base/xorg-server/files/1.4.0.90/0044-Fix-overly-restrictive-integer-overflow-check-in-EXA.patch
@@ -0,0 +1,28 @@
+From 2dcdad6747b6af7ffdda2e6374d404d4df4bff22 Mon Sep 17 00:00:00 2001
+From: Eric Anholt <eric@anholt.net>
+Date: Fri, 17 Aug 2007 12:14:16 -0700
+Subject: [PATCH] Fix overly-restrictive integer overflow check in EXA pixmap creation.
+
+The result was that at 32bpp, pixmaps of width 8192 or greater couldn't be
+created, due to treating a pitch value as a width.
+(cherry picked from commit bc2d516f16d94c805b4dfa8e5b9eef40ff0cbe98)
+---
+ exa/exa.c | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/exa/exa.c b/exa/exa.c
+index aa42b92..b2faf2f 100644
+--- a/exa/exa.c
++++ b/exa/exa.c
+@@ -253,7 +253,7 @@ exaCreatePixmap(ScreenPtr pScreen, int w, int h, int depth)
+ pExaScr->info->pixmapPitchAlign);
+ pExaPixmap->fb_size = pExaPixmap->fb_pitch * h;
+
+- if (pExaPixmap->fb_pitch > 32767) {
++ if (pExaPixmap->fb_pitch > 131071) {
+ fbDestroyPixmap(pPixmap);
+ return NULL;
+ }
+--
+1.5.5.1
+
diff --git a/x11-base/xorg-server/xorg-server-1.4.0.90-r4.ebuild b/x11-base/xorg-server/xorg-server-1.4.0.90-r4.ebuild
index 0d6124308d64..5698d0d8197c 100644
--- a/x11-base/xorg-server/xorg-server-1.4.0.90-r4.ebuild
+++ b/x11-base/xorg-server/xorg-server-1.4.0.90-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-server/xorg-server-1.4.0.90-r4.ebuild,v 1.3 2008/05/09 22:22:54 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-server/xorg-server-1.4.0.90-r4.ebuild,v 1.4 2008/05/10 06:50:16 dberkholz Exp $
# Must be before x-modular eclass is inherited
#SNAPSHOT="yes"
@@ -284,11 +284,6 @@ GENTOO_PATCHES=(
# These have been sent upstream
UPSTREAMED_PATCHES=(
"${FILESDIR}/${PV}/"
- "${FILESDIR}/1.4-fix-dmx-build.patch"
- "${FILESDIR}/1.4-fix-dmx-link.patch"
- "${FILESDIR}/1.4-fix-xephyr-link.patch"
- "${FILESDIR}/1.4-fix-xprint-build.patch"
- "${FILESDIR}/1.4-fix-xprint-link.patch"
)
PATCHES=(