summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-04-18 23:52:31 +0000
committerMike Frysinger <vapier@gentoo.org>2005-04-18 23:52:31 +0000
commitc0a7c831084b9fe88b37960877aca9238ebba910 (patch)
tree857347094a1fc5f3051db5c6f2afa486a4f79730 /x11-libs
parentdont need 64-bit eclass (diff)
downloadgentoo-2-c0a7c831084b9fe88b37960877aca9238ebba910.tar.gz
gentoo-2-c0a7c831084b9fe88b37960877aca9238ebba910.tar.bz2
gentoo-2-c0a7c831084b9fe88b37960877aca9238ebba910.zip
Add a cvs ebuild.
(Portage version: 2.0.51.19)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libast/ChangeLog9
-rw-r--r--x11-libs/libast/files/digest-libast-99990
-rw-r--r--x11-libs/libast/libast-9999.ebuild51
3 files changed, 58 insertions, 2 deletions
diff --git a/x11-libs/libast/ChangeLog b/x11-libs/libast/ChangeLog
index 9f00be9dea0f..6fcff6d305e6 100644
--- a/x11-libs/libast/ChangeLog
+++ b/x11-libs/libast/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/libast
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libast/ChangeLog,v 1.15 2005/03/06 11:01:49 corsair Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libast/ChangeLog,v 1.16 2005/04/18 23:52:31 vapier Exp $
+
+*libast-9999 (18 Apr 2005)
+
+ 18 Apr 2005; Mike Frysinger <vapier@gentoo.org> +libast-9999.ebuild:
+ Add a cvs ebuild.
06 Mar 2005; Markus Rothe <corsair@gentoo.org> libast-0.6.1.ebuild:
Added ~ppc64 to KEYWORDS
diff --git a/x11-libs/libast/files/digest-libast-9999 b/x11-libs/libast/files/digest-libast-9999
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/x11-libs/libast/files/digest-libast-9999
diff --git a/x11-libs/libast/libast-9999.ebuild b/x11-libs/libast/libast-9999.ebuild
new file mode 100644
index 000000000000..d0e216ac7c9b
--- /dev/null
+++ b/x11-libs/libast/libast-9999.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libast/libast-9999.ebuild,v 1.1 2005/04/18 23:52:31 vapier Exp $
+
+ECVS_MODULE="eterm/libast"
+ECVS_SERVER="cvs.sourceforge.net:/cvsroot/enlightenment"
+inherit eutils cvs
+
+DESCRIPTION="LIBrary of Assorted Spiffy Things"
+HOMEPAGE="http://www.eterm.org/download/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86 ~ppc64"
+IUSE="imlib mmx pcre"
+
+DEPEND="virtual/x11
+ =media-libs/freetype-2*
+ imlib? ( media-libs/imlib2 )
+ pcre? ( dev-libs/libpcre )"
+
+S=${WORKDIR}/${ECVS_MODULE}
+
+src_unpack() {
+ cvs_src_unpack
+ cd "${S}"
+ # autogen.sh is broken so do this ourselves
+ #./autogen.sh || die "autogen failed"
+ aclocal -I . && \
+ autoheader && \
+ libtoolize -c -f && \
+ autoconf && \
+ automake -a -c || die "autotools failed"
+}
+
+src_compile() {
+ local myregexp="posix"
+ use pcre && myregexp="pcre"
+ econf \
+ $(use_with imlib) \
+ $(use_enable mmx) \
+ --with-regexp=${myregexp} \
+ || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc README DESIGN ChangeLog
+}