summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2007-01-12 14:37:40 +0000
committerMart Raudsepp <leio@gentoo.org>2007-01-12 14:37:40 +0000
commitfc03f9092172026f0055b523e1259ccf1fe5d49a (patch)
tree1ba0bfaafd6434e51efdf354733a99875cab3718 /x11-libs
parentVersion bump. (diff)
downloadgentoo-2-fc03f9092172026f0055b523e1259ccf1fe5d49a.tar.gz
gentoo-2-fc03f9092172026f0055b523e1259ccf1fe5d49a.tar.bz2
gentoo-2-fc03f9092172026f0055b523e1259ccf1fe5d49a.zip
Build fix for wxrc in presence of an already installed (incompatible) wxGTK, bug 150435
(Portage version: 2.1.2_rc4-r8)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/wxGTK/ChangeLog7
-rw-r--r--x11-libs/wxGTK/files/wxGTK-2.6.3.3-wxrc_link_fix.patch14
-rw-r--r--x11-libs/wxGTK/wxGTK-2.6.3.3.ebuild3
3 files changed, 22 insertions, 2 deletions
diff --git a/x11-libs/wxGTK/ChangeLog b/x11-libs/wxGTK/ChangeLog
index f26c8703240f..18cf7d5b4438 100644
--- a/x11-libs/wxGTK/ChangeLog
+++ b/x11-libs/wxGTK/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/wxGTK
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/ChangeLog,v 1.134 2007/01/06 02:11:30 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/ChangeLog,v 1.135 2007/01/12 14:37:40 leio Exp $
+
+ 12 Jan 2007; Mart Raudsepp <leio@gentoo.org>
+ +files/wxGTK-2.6.3.3-wxrc_link_fix.patch, wxGTK-2.6.3.3.ebuild:
+ Build fix for wxrc in presence of an already installed (incompatible) wxGTK,
+ bug 150435
06 Jan 2007; Ryan Hill <dirtyepic@gentoo.org> wxGTK-2.4.2-r4.ebuild,
wxGTK-2.6.2-r1.ebuild:
diff --git a/x11-libs/wxGTK/files/wxGTK-2.6.3.3-wxrc_link_fix.patch b/x11-libs/wxGTK/files/wxGTK-2.6.3.3-wxrc_link_fix.patch
new file mode 100644
index 000000000000..f5e05eba0406
--- /dev/null
+++ b/x11-libs/wxGTK/files/wxGTK-2.6.3.3-wxrc_link_fix.patch
@@ -0,0 +1,14 @@
+Fix bug 150435 - wxrc build fails because it tries to link against system wx libraries, if present,
+ due to LDFLAGS containing -L to /usr/lib as a symlink - swap $LDFLAGS and $LIBDIRNAME
+
+--- utils/wxrc/Makefile.in.orig 2007-01-10 13:25:40.000000000 +0200
++++ utils/wxrc/Makefile.in 2007-01-10 13:27:56.000000000 +0200
+@@ -114,7 +114,7 @@
+ rm -f config.cache config.log config.status bk-deps bk-make-pch shared-ld-sh Makefile
+
+ @COND_USE_XRC_1@wxrc$(EXEEXT): $(WXRC_OBJECTS)
+-@COND_USE_XRC_1@ $(CXX) -o $@ $(WXRC_OBJECTS) $(LDFLAGS) -L$(LIBDIRNAME) $(__WXLIB_XML_p) $(EXTRALIBS_XML) $(__WXLIB_BASE_p) $(__WXLIB_MONO_p) $(__LIB_TIFF_p) $(__LIB_JPEG_p) $(__LIB_PNG_p) $(__LIB_ZLIB_p) $(__LIB_ODBC_p) $(__LIB_REGEX_p) $(__LIB_EXPAT_p) $(EXTRALIBS_FOR_BASE)
++@COND_USE_XRC_1@ $(CXX) -o $@ $(WXRC_OBJECTS) -L$(LIBDIRNAME) $(__WXLIB_XML_p) $(EXTRALIBS_XML) $(__WXLIB_BASE_p) $(__WXLIB_MONO_p) $(__LIB_TIFF_p) $(__LIB_JPEG_p) $(__LIB_PNG_p) $(__LIB_ZLIB_p) $(__LIB_ODBC_p) $(__LIB_REGEX_p) $(__LIB_EXPAT_p) $(LDFLAGS) $(EXTRALIBS_FOR_BASE)
+ @COND_USE_XRC_1@
+ @COND_USE_XRC_1@ $(__wxrc___mac_setfilecmd)
+
diff --git a/x11-libs/wxGTK/wxGTK-2.6.3.3.ebuild b/x11-libs/wxGTK/wxGTK-2.6.3.3.ebuild
index 5cc4d16d8408..ad04677a8a30 100644
--- a/x11-libs/wxGTK/wxGTK-2.6.3.3.ebuild
+++ b/x11-libs/wxGTK/wxGTK-2.6.3.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/wxGTK-2.6.3.3.ebuild,v 1.6 2007/01/05 22:50:01 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/wxGTK-2.6.3.3.ebuild,v 1.7 2007/01/12 14:37:40 leio Exp $
inherit eutils flag-o-matic multilib toolchain-funcs versionator
@@ -122,6 +122,7 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}/${P}-wxrc_build_fix.patch"
+ epatch "${FILESDIR}/${P}-wxrc_link_fix.patch"
epatch "${FILESDIR}/${P}-dialog_focus.patch"
epatch "${FILESDIR}/${P}-slider_linesize.patch"