summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-02-28 17:45:20 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-02-28 17:45:20 +0000
commit0f065943644fd19d752b4cc209b409da94e9e7ef (patch)
tree03996110e3d8681ccf270df61a6fa82c79f72ad5 /x11-plugins/compiz-plugins-extra
parentNew release on the 1.6.2 branch. This is a bugfix release, the official chang... (diff)
downloadgentoo-2-0f065943644fd19d752b4cc209b409da94e9e7ef.tar.gz
gentoo-2-0f065943644fd19d752b4cc209b409da94e9e7ef.tar.bz2
gentoo-2-0f065943644fd19d752b4cc209b409da94e9e7ef.zip
Fix building with x11-libs/libnotify >= 0.7 wrt #354761 by Diego Elio Pettenò.
(Portage version: 2.2.0_alpha25/cvs/Linux x86_64)
Diffstat (limited to 'x11-plugins/compiz-plugins-extra')
-rw-r--r--x11-plugins/compiz-plugins-extra/ChangeLog8
-rw-r--r--x11-plugins/compiz-plugins-extra/compiz-plugins-extra-0.8.6-r1.ebuild4
-rw-r--r--x11-plugins/compiz-plugins-extra/files/compiz-plugins-extra-0.8.6-libnotify.patch36
3 files changed, 40 insertions, 8 deletions
diff --git a/x11-plugins/compiz-plugins-extra/ChangeLog b/x11-plugins/compiz-plugins-extra/ChangeLog
index 6fb3e61c828c..e835b0da1d65 100644
--- a/x11-plugins/compiz-plugins-extra/ChangeLog
+++ b/x11-plugins/compiz-plugins-extra/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-plugins/compiz-plugins-extra
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/compiz-plugins-extra/ChangeLog,v 1.14 2011/02/26 22:49:51 signals Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/compiz-plugins-extra/ChangeLog,v 1.15 2011/02/28 17:45:20 ssuominen Exp $
+
+ 28 Feb 2011; Samuli Suominen <ssuominen@gentoo.org>
+ compiz-plugins-extra-0.8.6-r1.ebuild,
+ files/compiz-plugins-extra-0.8.6-libnotify.patch:
+ Fix building with x11-libs/libnotify >= 0.7 wrt #354761 by Diego Elio
+ Pettenò.
26 Feb 2011; Kevin McCarthy <signals@gentoo.org>
compiz-plugins-extra-0.8.4-r1.ebuild, compiz-plugins-extra-0.8.6-r1.ebuild:
diff --git a/x11-plugins/compiz-plugins-extra/compiz-plugins-extra-0.8.6-r1.ebuild b/x11-plugins/compiz-plugins-extra/compiz-plugins-extra-0.8.6-r1.ebuild
index 24cd0c532c3f..6705a80c46f2 100644
--- a/x11-plugins/compiz-plugins-extra/compiz-plugins-extra-0.8.6-r1.ebuild
+++ b/x11-plugins/compiz-plugins-extra/compiz-plugins-extra-0.8.6-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/compiz-plugins-extra/compiz-plugins-extra-0.8.6-r1.ebuild,v 1.3 2011/02/26 22:49:51 signals Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/compiz-plugins-extra/compiz-plugins-extra-0.8.6-r1.ebuild,v 1.4 2011/02/28 17:45:20 ssuominen Exp $
EAPI="2"
@@ -23,7 +23,7 @@ RDEPEND="
>=x11-libs/compiz-bcop-${MY_PV}
>=x11-plugins/compiz-plugins-main-${PV}
>=x11-wm/compiz-${PV}[gconf?]
- libnotify? ( <x11-libs/libnotify-0.7 )
+ libnotify? ( x11-libs/libnotify )
"
DEPEND="${RDEPEND}
diff --git a/x11-plugins/compiz-plugins-extra/files/compiz-plugins-extra-0.8.6-libnotify.patch b/x11-plugins/compiz-plugins-extra/files/compiz-plugins-extra-0.8.6-libnotify.patch
index 5392fa00d021..967abc4e2044 100644
--- a/x11-plugins/compiz-plugins-extra/files/compiz-plugins-extra-0.8.6-libnotify.patch
+++ b/x11-plugins/compiz-plugins-extra/files/compiz-plugins-extra-0.8.6-libnotify.patch
@@ -1,8 +1,6 @@
-Index: compiz-plugins-extra-0.8.6/configure.ac
-===================================================================
---- compiz-plugins-extra-0.8.6.orig/configure.ac
-+++ compiz-plugins-extra-0.8.6/configure.ac
-@@ -136,9 +136,12 @@ AM_CONDITIONAL(THREED_PLUGIN, test "x$ha
+--- configure.ac
++++ configure.ac
+@@ -136,9 +136,12 @@
PKG_CHECK_MODULES(COMPIZMOUSEPOLL, compiz-mousepoll, [have_compiz_mousepoll=yes], [have_compiz_mousepoll=no])
AM_CONDITIONAL(SHOWMOUSE_PLUGIN, test "x$have_compiz_mousepoll" = "xyes")
@@ -17,3 +15,31 @@ Index: compiz-plugins-extra-0.8.6/configure.ac
AC_DEFINE(USE_NOTIFICATION, 1, [Build notification plugin])
fi
+--- src/notification/notification.c
++++ src/notification/notification.c
+@@ -21,6 +21,11 @@
+
+
+ #include <libnotify/notify.h>
++
++#ifndef NOTIFY_CHECK_VERSION
++#define NOTIFY_CHECK_VERSION(x,y,z) 0
++#endif
++
+ #include <stdio.h>
+ #include <stdarg.h>
+ #include <string.h>
+@@ -103,7 +108,12 @@
+
+ n = notify_notification_new (logLevel,
+ message,
+- iconUri, NULL);
++ iconUri
++#if NOTIFY_CHECK_VERSION (0, 7, 0)
++ );
++#else
++ , NULL);
++#endif
+
+ notify_notification_set_timeout (n, nd->timeout);
+