summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2010-06-29 16:23:19 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2010-06-29 16:23:19 +0000
commit21fc0c559003168b5df468c4a716e0774a876d1b (patch)
tree866f7eaac8278843bb9f59fece0ceef4eadaf73c /x11-terms/mlterm
parentMarked ~x86-macos (diff)
downloadgentoo-2-21fc0c559003168b5df468c4a716e0774a876d1b.tar.gz
gentoo-2-21fc0c559003168b5df468c4a716e0774a876d1b.tar.bz2
gentoo-2-21fc0c559003168b5df468c4a716e0774a876d1b.zip
Version bumped, bug #326051. Fixed dependency.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'x11-terms/mlterm')
-rw-r--r--x11-terms/mlterm/ChangeLog9
-rw-r--r--x11-terms/mlterm/mlterm-3.0.1.ebuild80
2 files changed, 87 insertions, 2 deletions
diff --git a/x11-terms/mlterm/ChangeLog b/x11-terms/mlterm/ChangeLog
index 07bfa549c3ef..adc5099b3713 100644
--- a/x11-terms/mlterm/ChangeLog
+++ b/x11-terms/mlterm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-terms/mlterm
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/mlterm/ChangeLog,v 1.72 2009/10/10 15:12:14 armin76 Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/mlterm/ChangeLog,v 1.73 2010/06/29 16:23:19 matsuu Exp $
+
+*mlterm-3.0.1 (29 Jun 2010)
+
+ 29 Jun 2010; MATSUU Takuto <matsuu@gentoo.org> +mlterm-3.0.1.ebuild:
+ Version bumped, bug #326051. Fixed dependency.
10 Oct 2009; Raúl Porcel <armin76@gentoo.org> mlterm-2.9.4-r4.ebuild:
sparc stable wrt #282924
diff --git a/x11-terms/mlterm/mlterm-3.0.1.ebuild b/x11-terms/mlterm/mlterm-3.0.1.ebuild
new file mode 100644
index 000000000000..1e3e48d6bfeb
--- /dev/null
+++ b/x11-terms/mlterm/mlterm-3.0.1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/mlterm/mlterm-3.0.1.ebuild,v 1.1 2010/06/29 16:23:19 matsuu Exp $
+
+EAPI="2"
+inherit eutils
+
+IUSE="bidi imlib gtk m17n-lib nls scim truetype uim"
+#IUSE="${IUSE} iiimf"
+
+DESCRIPTION="A multi-lingual terminal emulator"
+HOMEPAGE="http://mlterm.sourceforge.net/"
+SRC_URI="mirror://sourceforge/mlterm/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+LICENSE="BSD"
+
+RDEPEND="virtual/utempter
+ x11-libs/libX11
+ x11-libs/libICE
+ x11-libs/libSM
+ gtk? ( x11-libs/gtk+:2 )
+ !gtk? ( imlib? ( media-libs/imlib2 ) )
+ truetype? ( x11-libs/libXft )
+ bidi? ( >=dev-libs/fribidi-0.10.4 )
+ nls? ( virtual/libintl )
+ uim? ( >=app-i18n/uim-1.0 )
+ scim? ( >=app-i18n/scim-1.4 )
+ m17n-lib? ( >=dev-libs/m17n-lib-1.2.0 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.9.4-uim15-fix.patch
+ cd "${S}"/xwindow
+ epatch "${FILESDIR}"/${PN}-2.9.1-gentoo.diff
+}
+
+src_configure() {
+ local myconf
+
+ if use gtk ; then
+ myconf="${myconf} --with-imagelib=gdk-pixbuf"
+ else
+ if use imlib ; then
+ myconf="${myconf} --with-imagelib=imlib2"
+ else
+ myconf="${myconf} --with-imagelib=''"
+ fi
+ myconf="${myconf} --with-tools=mlclient,mlcc"
+ fi
+
+ # iiimf isn't stable enough
+ #myconf="${myconf} $(use_enable iiimf)"
+
+ econf --enable-utmp \
+ $(use_enable truetype anti-alias) \
+ $(use_enable bidi fribidi) \
+ $(use_enable nls) \
+ $(use_enable uim) \
+ $(use_enable scim) \
+ $(use_enable m17n-lib m17nlib) \
+ ${myconf} || die "econf failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die
+
+ doicon contrib/icon/mlterm* || die
+ make_desktop_entry mlterm mlterm mlterm-icon TerminalEmulator || die
+
+ dodoc ChangeLog README || die
+
+ docinto ja
+ dodoc doc/ja/* || die
+ docinto en
+ dodoc doc/en/* || die
+}