summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/actionview/ChangeLog7
-rw-r--r--dev-ruby/actionview/actionview-4.1.7.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/dev-ruby/actionview/ChangeLog b/dev-ruby/actionview/ChangeLog
index d789229615af..99aefb2af873 100644
--- a/dev-ruby/actionview/ChangeLog
+++ b/dev-ruby/actionview/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/actionview
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionview/ChangeLog,v 1.10 2014/09/12 06:27:16 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionview/ChangeLog,v 1.11 2014/10/31 08:57:14 graaff Exp $
+
+*actionview-4.1.7 (31 Oct 2014)
+
+ 31 Oct 2014; Hans de Graaff <graaff@gentoo.org> +actionview-4.1.7.ebuild:
+ Version bump for security issue CVE-2014-7818.
*actionview-4.1.6 (12 Sep 2014)
diff --git a/dev-ruby/actionview/actionview-4.1.7.ebuild b/dev-ruby/actionview/actionview-4.1.7.ebuild
new file mode 100644
index 000000000000..390a4e224d0f
--- /dev/null
+++ b/dev-ruby/actionview/actionview-4.1.7.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionview/actionview-4.1.7.ebuild,v 1.1 2014/10/31 08:57:14 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Simple, battle-tested conventions and helpers for building web pages"
+HOMEPAGE="https://github.com/rails/rails/"
+SRC_URI="http://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/builder-3.1 =dev-ruby/builder-3*
+ >=dev-ruby/erubis-2.7.0
+"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/mocha:0.14
+ ~dev-ruby/actionpack-${PV}
+ ~dev-ruby/activemodel-${PV}
+ )"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|'mysql'\|journey\|ruby-prof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|minitest\)/ s:^:#:" ../Gemfile || die
+
+}