summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-tv/tvbrowser/ChangeLog9
-rw-r--r--media-tv/tvbrowser/files/digest-tvbrowser-2.5-r16
-rw-r--r--media-tv/tvbrowser/files/tvbrowser-2.5_Localizer.patch12
-rw-r--r--media-tv/tvbrowser/tvbrowser-2.5-r1.ebuild148
4 files changed, 174 insertions, 1 deletions
diff --git a/media-tv/tvbrowser/ChangeLog b/media-tv/tvbrowser/ChangeLog
index bf09265707f2..a1b8ece11557 100644
--- a/media-tv/tvbrowser/ChangeLog
+++ b/media-tv/tvbrowser/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-tv/tvbrowser
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/tvbrowser/ChangeLog,v 1.10 2007/01/30 04:45:55 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/tvbrowser/ChangeLog,v 1.11 2007/03/11 16:15:16 zzam Exp $
+
+*tvbrowser-2.5-r1 (11 Mar 2007)
+
+ 11 Mar 2007; Matthias Schwarzott <zzam@gentoo.org>
+ +files/tvbrowser-2.5_Localizer.patch, +tvbrowser-2.5-r1.ebuild:
+ Now systray icon works, Bug #170364. Country options can be changed, Bug
+ #170363. Thanks to Mirko Günther for the changes.
30 Jan 2007; Steve Dibb <beandog@gentoo.org> tvbrowser-2.2.1.ebuild:
Add ~amd64, bug 151858
diff --git a/media-tv/tvbrowser/files/digest-tvbrowser-2.5-r1 b/media-tv/tvbrowser/files/digest-tvbrowser-2.5-r1
new file mode 100644
index 000000000000..5eaf2ca3a1f3
--- /dev/null
+++ b/media-tv/tvbrowser/files/digest-tvbrowser-2.5-r1
@@ -0,0 +1,6 @@
+MD5 672a2f53c54511ced3f796c65a9183f7 allthemepacks.zip 210954
+RMD160 6d456534bd504c98eb57ff39876ee2c2ffabee70 allthemepacks.zip 210954
+SHA256 602d229f734c2fa3e2984a2d86faf6c1825d6db56329b00ce25ba1a2eb5b64b7 allthemepacks.zip 210954
+MD5 a37f6a90cbe52077308649da4dcfe8ae tvbrowser-2.5-src.zip 8865427
+RMD160 2f47f2a9d56f9fac26dae77f6f34dac06bd17b7d tvbrowser-2.5-src.zip 8865427
+SHA256 f2f60303a5600dd3bcd94dc681f469f9e0e6e408581db4eccc2bad3cbdbb3c7a tvbrowser-2.5-src.zip 8865427
diff --git a/media-tv/tvbrowser/files/tvbrowser-2.5_Localizer.patch b/media-tv/tvbrowser/files/tvbrowser-2.5_Localizer.patch
new file mode 100644
index 000000000000..f3065dcf9504
--- /dev/null
+++ b/media-tv/tvbrowser/files/tvbrowser-2.5_Localizer.patch
@@ -0,0 +1,12 @@
+diff -ru tvbrowser-2.5-orig/src/util/ui/Localizer.java tvbrowser-2.5/src/util/ui/Localizer.java
+--- tvbrowser-2.5-orig/src/util/ui/Localizer.java 2007-03-11 17:03:17.662679355 +0100
++++ tvbrowser-2.5/src/util/ui/Localizer.java 2007-03-11 17:03:39.741495254 +0100
+@@ -348,7 +348,7 @@
+ langArray.add(Locale.ENGLISH);
+
+ // First Step: look into tvbrowser.jar
+- JarFile file = new JarFile(new File("tvbrowser.jar"));
++ JarFile file = new JarFile(new File("lib/tvbrowser.jar"));
+
+ Enumeration<JarEntry> entries = file.entries();
+
diff --git a/media-tv/tvbrowser/tvbrowser-2.5-r1.ebuild b/media-tv/tvbrowser/tvbrowser-2.5-r1.ebuild
new file mode 100644
index 000000000000..3726fc31064c
--- /dev/null
+++ b/media-tv/tvbrowser/tvbrowser-2.5-r1.ebuild
@@ -0,0 +1,148 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/tvbrowser/tvbrowser-2.5-r1.ebuild,v 1.1 2007/03/11 16:15:16 zzam Exp $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+
+inherit eutils java-pkg-2 java-ant-2 autotools flag-o-matic
+
+DESCRIPTION="Themeable and easy to use TV Guide - written in Java"
+HOMEPAGE="http://www.tvbrowser.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.zip
+themes? ( http://www.tvbrowser.org/downloads/themepacks/allthemepacks.zip )"
+
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+# missing dependencies commons-compress, TVAnytimeAPI, jRegistryKey , gdata-calendar, gdata-client and jcom
+
+RDEPEND="|| ( ( x11-libs/libXt
+ x11-libs/libSM
+ x11-libs/libICE
+ x11-libs/libXext
+ x11-libs/libXtst
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ )
+ virtual/x11
+ )
+ >=virtual/jre-1.5
+ dev-java/junit
+ dev-java/commons-net
+ >=dev-java/jgoodies-forms-1.0.7
+ >=dev-java/jgoodies-looks-2.0
+ >=dev-java/bsh-2.0_beta1
+ dev-java/skinlf
+ dev-java/l2fprod-common"
+
+DEPEND=">=virtual/jdk-1.5
+ ${RDEPEND}
+ >=dev-java/ant-core-1.5.4
+ app-arch/unzip
+ source? ( app-arch/zip )"
+
+LICENSE="GPL-2"
+
+IUSE="doc themes source"
+
+src_unpack() {
+ unpack ${P}-src.zip
+
+ cd ${S}
+ epatch ${FILESDIR}/${P}-makefiles.patch
+ epatch ${FILESDIR}/${P}_noWin32.patch
+ epatch ${FILESDIR}/${P}_buildxml.patch
+
+ #fix bug #170363
+ epatch ${FILESDIR}/${P}_Localizer.patch
+
+ # missing commons-compress, gdata-calendar, gdata-client
+ rm -r ${S}/src/calendarexportplugin
+ rm -r ${S}/src/bbcbackstagedataservice
+
+ local J_ARCH
+ case "${ARCH}" in
+ x86) J_ARCH=i386 ;;
+ amd64) J_ARCH=amd64 ;;
+ *) die "not supported arch for this ebuild" ;;
+ esac
+
+ sed -i ${S}/deployment/x11/src/Makefile.am \
+ -e "s-/lib/i386/-/lib/${J_ARCH}/-"
+
+ cd ${S}/lib
+ rm *.jar
+
+ java-pkg_jar-from junit
+ java-pkg_jar-from commons-net
+ java-pkg_jar-from jgoodies-forms forms.jar forms-1.0.7.jar
+ java-pkg_jar-from jgoodies-looks-2.0 looks.jar looks-2.0.4.jar
+ java-pkg_jar-from bsh bsh.jar bsh-2.0b1.jar
+ java-pkg_jar-from skinlf
+ java-pkg_jar-from l2fprod-common l2fprod-common-tasks.jar
+
+ #fix bug #170364
+ cd ${S}/deployment/x11
+ chmod u+x configure
+ rm src/libDesktopIndicator.so
+
+ # converting to unix line-endings
+ edos2unix missing depcomp
+
+ eautoreconf
+}
+
+src_compile() {
+ local antflags="runtime-linux"
+ use doc && antflags="${antflags} public-doc"
+ cd ${S}
+ mkdir public
+ eant ${antflags}
+
+ # second part: DesktopIndicator
+ cd ${S}/deployment/x11
+ append-flags -fPIC
+ econf || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ use source && java-pkg_dosrc src/*
+ use doc && java-pkg_dohtml -r doc/*
+ cd runtime/${PN}_linux
+
+ java-pkg_dojar ${PN}.jar
+
+ local todir="/usr/share/${PN}"
+ if [ ${SLOT}q != "0q" ] ; then
+ todir="${todir}-${SLOT}"
+ fi
+
+ cp -a imgs ${D}/${todir}
+ cp -a icons ${D}/${todir}
+ cp -a plugins ${D}/${todir}
+ cp linux.properties ${D}/${todir}
+
+ insinto "/usr/share/${PN}/themepacks"
+ doins themepacks/themepack.zip
+
+ if use themes; then
+ cd "${D}/usr/share/${PN}/themepacks"
+ unpack allthemepacks.zip
+ fi
+
+ java-pkg_dolauncher "tvbrowser" \
+ --jar ${todir}/lib/tvbrowser.jar \
+ --pwd ${todir} \
+ --java_args "-Djava.library.path=${todir} -Dpropertiesfile=${todir}/linux.properties"
+
+ cp ${S}/deployment/x11/src/libDesktopIndicator.so ${D}/${todir}
+}
+
+pkg_postinst() {
+ elog
+ elog "If you want Systray you have to use a jre >= 1.5 !"
+ elog
+}