summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-editors/hteditor/ChangeLog8
-rw-r--r--app-editors/hteditor/hteditor-2.0.14.ebuild35
2 files changed, 42 insertions, 1 deletions
diff --git a/app-editors/hteditor/ChangeLog b/app-editors/hteditor/ChangeLog
index 00d2e84f0063..16283b72413d 100644
--- a/app-editors/hteditor/ChangeLog
+++ b/app-editors/hteditor/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/hteditor
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/hteditor/ChangeLog,v 1.37 2008/03/27 18:52:01 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/hteditor/ChangeLog,v 1.38 2008/08/17 04:47:40 dragonheart Exp $
+
+*hteditor-2.0.14 (17 Aug 2008)
+
+ 17 Aug 2008; Daniel Black <dragonheart@gentoo.org>
+ +hteditor-2.0.14.ebuild:
+ version bump as per bug #234363 thanks to darkdimius
27 Mar 2008; nixnut <nixnut@gentoo.org> hteditor-2.0.10.ebuild:
Stable on ppc wrt bug 214891
diff --git a/app-editors/hteditor/hteditor-2.0.14.ebuild b/app-editors/hteditor/hteditor-2.0.14.ebuild
new file mode 100644
index 000000000000..80de8d1b32da
--- /dev/null
+++ b/app-editors/hteditor/hteditor-2.0.14.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/hteditor/hteditor-2.0.14.ebuild,v 1.1 2008/08/17 04:47:40 dragonheart Exp $
+
+MY_PV=${PV/_/}
+
+DESCRIPTION="editor for executable files"
+HOMEPAGE="http://hte.sourceforge.net/"
+SRC_URI="mirror://sourceforge/hte/ht-${MY_PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="X"
+
+RDEPEND="sys-libs/ncurses
+ X? ( x11-libs/libX11 )
+ >=dev-libs/lzo-2"
+DEPEND="${RDEPEND}
+ sys-devel/bison
+ sys-devel/flex"
+
+S=${WORKDIR}/ht-${MY_PV}
+
+src_compile() {
+ econf --disable-release --enable-maintainer-mode $(use_enable X x11-textmode)
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS KNOWNBUGS TODO README ChangeLog
+ dohtml doc/ht.html
+ doinfo doc/ht.info doc/hthelp.info
+}