summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-emulation/dosemu/ChangeLog5
-rw-r--r--app-emulation/dosemu/dosemu-1.2.2-r1.ebuild7
2 files changed, 7 insertions, 5 deletions
diff --git a/app-emulation/dosemu/ChangeLog b/app-emulation/dosemu/ChangeLog
index a9f22ffdec66..fad170794c4b 100644
--- a/app-emulation/dosemu/ChangeLog
+++ b/app-emulation/dosemu/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-emulation/dosemu
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/dosemu/ChangeLog,v 1.28 2005/05/21 13:13:56 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/dosemu/ChangeLog,v 1.29 2005/05/23 15:26:05 hanno Exp $
+
+ 23 May 2005; Hanno Boeck <hanno@gentoo.org> dosemu-1.2.2-r1.ebuild:
+ Append -fno-pic instead of filtering -fPIC for hardened-gcc.
21 May 2005; Hanno Boeck <hanno@gentoo.org> dosemu-1.2.2-r1.ebuild:
Unset KERNEL-Variable to fix compilation (see bug #91261).
diff --git a/app-emulation/dosemu/dosemu-1.2.2-r1.ebuild b/app-emulation/dosemu/dosemu-1.2.2-r1.ebuild
index a3bf171f61e1..3da9bc8bd64f 100644
--- a/app-emulation/dosemu/dosemu-1.2.2-r1.ebuild
+++ b/app-emulation/dosemu/dosemu-1.2.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/dosemu/dosemu-1.2.2-r1.ebuild,v 1.7 2005/05/21 13:13:56 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/dosemu/dosemu-1.2.2-r1.ebuild,v 1.8 2005/05/23 15:26:05 hanno Exp $
inherit flag-o-matic eutils
@@ -46,9 +46,8 @@ src_compile() {
# Has problems with -O3 on some systems
replace-flags -O[3-9] -O2
- # Fix compilation on hardened. filter -fPIC rather than appending
- # -fno-pic
- filter-flage -fPIC
+ # Fix compilation on hardened
+ append-flags -fno-pic
econf ${myflags} || die "DOSemu Base Configuration Failed"