summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-boot/plymouth/ChangeLog9
-rw-r--r--sys-boot/plymouth/plymouth-0.8.3-r5.ebuild7
-rw-r--r--sys-boot/plymouth/plymouth-0.9_pre20111013-r1.ebuild7
3 files changed, 15 insertions, 8 deletions
diff --git a/sys-boot/plymouth/ChangeLog b/sys-boot/plymouth/ChangeLog
index f0ba553059d7..41c616dba7af 100644
--- a/sys-boot/plymouth/ChangeLog
+++ b/sys-boot/plymouth/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/plymouth
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/plymouth/ChangeLog,v 1.20 2011/11/02 13:07:17 aidecoe Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/plymouth/ChangeLog,v 1.21 2012/03/13 11:27:36 aidecoe Exp $
+
+ 13 Mar 2012; Amadeusz Żołnowski <aidecoe@gentoo.org>
+ plymouth-0.8.3-r5.ebuild, plymouth-0.9_pre20111013-r1.ebuild:
+ Disable tracing by default and enable it with 'debug' flag only.
+ Fixes bug #407365.
02 Nov 2011; Amadeusz Żołnowski <aidecoe@gentoo.org>
plymouth-0.9_pre20111013-r1.ebuild:
diff --git a/sys-boot/plymouth/plymouth-0.8.3-r5.ebuild b/sys-boot/plymouth/plymouth-0.8.3-r5.ebuild
index b8fd04795534..a98c5ac4dd3d 100644
--- a/sys-boot/plymouth/plymouth-0.8.3-r5.ebuild
+++ b/sys-boot/plymouth/plymouth-0.8.3-r5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/plymouth/plymouth-0.8.3-r5.ebuild,v 1.3 2011/10/27 12:37:00 aidecoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/plymouth/plymouth-0.8.3-r5.ebuild,v 1.4 2012/03/13 11:27:36 aidecoe Exp $
EAPI="3"
@@ -16,7 +16,7 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE_VIDEO_CARDS="video_cards_intel video_cards_nouveau video_cards_radeon"
-IUSE="${IUSE_VIDEO_CARDS} gdm +openrc +pango static-libs"
+IUSE="${IUSE_VIDEO_CARDS} debug gdm +openrc +pango static-libs"
COMMON_DEPEND=">=media-libs/libpng-1.2.16
>=x11-libs/gtk+-2.12:2
@@ -49,6 +49,7 @@ src_prepare() {
src_configure() {
local myeconfargs=(
--localstatedir=/var
+ $(use_enable debug tracing)
$(use_enable pango)
$(use_enable gdm gdm-transition)
$(use_enable video_cards_intel libdrm_intel)
diff --git a/sys-boot/plymouth/plymouth-0.9_pre20111013-r1.ebuild b/sys-boot/plymouth/plymouth-0.9_pre20111013-r1.ebuild
index 1d2a9314e46e..74667a3dee70 100644
--- a/sys-boot/plymouth/plymouth-0.9_pre20111013-r1.ebuild
+++ b/sys-boot/plymouth/plymouth-0.9_pre20111013-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/plymouth/plymouth-0.9_pre20111013-r1.ebuild,v 1.3 2011/11/02 13:07:17 aidecoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/plymouth/plymouth-0.9_pre20111013-r1.ebuild,v 1.4 2012/03/13 11:27:36 aidecoe Exp $
EAPI=4
@@ -16,7 +16,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE_VIDEO_CARDS="video_cards_intel video_cards_nouveau video_cards_radeon"
-IUSE="${IUSE_VIDEO_CARDS} gdm +libkms +openrc +pango static-libs"
+IUSE="${IUSE_VIDEO_CARDS} debug gdm +libkms +openrc +pango static-libs"
CDEPEND=">=media-libs/libpng-1.2.16
>=x11-libs/gtk+-2.12:2
@@ -48,6 +48,7 @@ src_configure() {
local myeconfargs=(
--with-system-root-install
--localstatedir=/var
+ $(use_enable debug tracing)
$(use_enable libkms)
$(use_enable pango)
$(use_enable gdm gdm-transition)