summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/apachetop/apachetop-0.12.ebuild')
-rw-r--r--app-admin/apachetop/apachetop-0.12.ebuild16
1 files changed, 9 insertions, 7 deletions
diff --git a/app-admin/apachetop/apachetop-0.12.ebuild b/app-admin/apachetop/apachetop-0.12.ebuild
index f058441c029b..6950db4cbc15 100644
--- a/app-admin/apachetop/apachetop-0.12.ebuild
+++ b/app-admin/apachetop/apachetop-0.12.ebuild
@@ -1,21 +1,21 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/apachetop/apachetop-0.12.ebuild,v 1.5 2004/07/09 19:42:16 stuart Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/apachetop/apachetop-0.12.ebuild,v 1.6 2004/07/15 20:32:50 tigger Exp $
DESCRIPTION="A realtime Apache log analyzer"
HOMEPAGE="http://clueful.shagged.org/apachetop/"
SRC_URI="http://clueful.shagged.org/apachetop/files/${P}.tar.gz"
-IUSE="apache2"
+IUSE="apache2 fam pcre"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ~sparc ~mips"
-DEPEND="!apache2? ( >=net-www/apache-1.3.28 )
- apache2? ( >=net-www/apache-2.0.47 )
- sys-apps/sed
- sys-libs/libtermcap-compat"
+DEPEND="sys-apps/sed"
+RDEPEND="sys-libs/libtermcap-compat
+ fam? ( app-admin/fam )
+ pcre? ( dev-libs/libpcre )"
src_compile() {
if use apache2
@@ -24,7 +24,9 @@ src_compile() {
else
sed -i 's%DEFAULT_LOGFILE "/var/httpd/apache_log"%DEFAULT_LOGFILE "/var/log/apache/access_log"%' src/apachetop.h
fi
- ./configure
+ local myconf
+ myconf="${myconf} $(use_with fam) $(use_with pcre)"
+ econf ${myconf}
emake || die
}