summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/p7zip/ChangeLog7
-rw-r--r--app-arch/p7zip/files/digest-p7zip-4.573
-rw-r--r--app-arch/p7zip/p7zip-4.57.ebuild80
3 files changed, 89 insertions, 1 deletions
diff --git a/app-arch/p7zip/ChangeLog b/app-arch/p7zip/ChangeLog
index 5e04fb3948a9..686d9a84ab1e 100644
--- a/app-arch/p7zip/ChangeLog
+++ b/app-arch/p7zip/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-arch/p7zip
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/p7zip/ChangeLog,v 1.84 2007/12/05 20:27:02 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/p7zip/ChangeLog,v 1.85 2007/12/25 22:32:07 radek Exp $
+
+*p7zip-4.57 (25 Dec 2007)
+
+ 25 Dec 2007; Radoslaw Stachowiak <radek@gentoo.org> +p7zip-4.57.ebuild:
+ Version bump and fix for 194354
05 Dec 2007; Samuli Suominen <drac@gentoo.org> p7zip-4.55-r1.ebuild:
amd64 stable as part of bug 198314, file-collision with lzma-utils.
diff --git a/app-arch/p7zip/files/digest-p7zip-4.57 b/app-arch/p7zip/files/digest-p7zip-4.57
new file mode 100644
index 000000000000..57102795975e
--- /dev/null
+++ b/app-arch/p7zip/files/digest-p7zip-4.57
@@ -0,0 +1,3 @@
+MD5 773f78d8b297eb858626667d4dfa93c7 p7zip_4.57_src_all.tar.bz2 1473608
+RMD160 af40563b4ead84d138e9fff03a2677540c50d29d p7zip_4.57_src_all.tar.bz2 1473608
+SHA256 00e923386dd53d532a86331d1694eaeee626783afa503f91edf7370357e05b53 p7zip_4.57_src_all.tar.bz2 1473608
diff --git a/app-arch/p7zip/p7zip-4.57.ebuild b/app-arch/p7zip/p7zip-4.57.ebuild
new file mode 100644
index 000000000000..4b1543520353
--- /dev/null
+++ b/app-arch/p7zip/p7zip-4.57.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/p7zip/p7zip-4.57.ebuild,v 1.1 2007/12/25 22:32:07 radek Exp $
+
+inherit eutils toolchain-funcs multilib
+
+DESCRIPTION="Port of 7-Zip archiver for Unix"
+HOMEPAGE="http://p7zip.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}_${PV}_src_all.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="static doc"
+
+DEPEND=""
+
+S=${WORKDIR}/${PN}_${PV}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e "/^CXX=/s:g++:$(tc-getCXX):" \
+ -e "/^CC=/s:gcc:$(tc-getCC):" \
+ -e "s:OPTFLAGS=-O:OPTFLAGS=${CXXFLAGS}:" \
+ -e 's:-s ::' \
+ -e '/Rar/d' \
+ makefile* || die "changing makefiles"
+
+ if use amd64; then
+ ewarn "Using suboptimal -fPIC upstream makefile due to amd64 being detected. See #126722"
+ cp -f makefile.linux_amd64 makefile.machine
+ elif [[ ${CHOST} == *-darwin* ]] ; then
+ # Mac OS X needs this special makefile, because it has a non-GNU linker
+ cp -f makefile.macosx makefile.machine
+ elif use x86-fbsd; then
+ # FreeBSD needs this special makefile, because it hasn't -ldl
+ sed -e 's/-lc_r/-pthread/' makefile.freebsd > makefile.machine
+ fi
+ use static && sed -i -e '/^LOCAL_LIBS=/s/LOCAL_LIBS=/&-static /' makefile.machine
+
+ # patching to not included nonfree RAR decompression code is higher a sed call
+ # But we're removing nonfree code just in case sed wasnt enough
+ rm -rf CPP/7zip/Compress/Rar
+}
+
+src_compile() {
+ emake all3 || die "compilation error"
+}
+
+src_install() {
+ # this wrappers can not be symlinks, p7zip should be called with full path
+ make_wrapper 7zr "/usr/lib/${PN}/7zr"
+ make_wrapper 7za "/usr/lib/${PN}/7za"
+ make_wrapper 7z "/usr/lib/${PN}/7z"
+
+ dobin "${FILESDIR}/p7zip" || die
+
+ # gzip introduced in 4.42, so beware :)
+ # mv needed just as rename, because dobin installs using old name
+ mv contrib/gzip-like_CLI_wrapper_for_7z/p7zip contrib/gzip-like_CLI_wrapper_for_7z/7zg || die
+ dobin contrib/gzip-like_CLI_wrapper_for_7z/7zg || die
+
+ exeinto /usr/$(get_libdir)/${PN}
+ doexe bin/7z bin/7za bin/7zr bin/7zCon.sfx || die "doexe bins"
+ exeinto /usr/$(get_libdir)/${PN}
+ doexe bin/*.so || die "doexe *.so files"
+
+ doman man1/7z.1 man1/7za.1 man1/7zr.1
+ dodoc ChangeLog README TODO
+
+ if use doc ; then
+ dodoc DOCS/*.txt
+ dohtml -r DOCS/MANUAL/*
+ fi
+
+ einfo "Please be aware that rar support was removed (it's nonfree)"
+ einfo "You can use app-arch/rar-unpacker for rar support"
+}