summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/cssed')
-rw-r--r--app-editors/cssed/ChangeLog8
-rw-r--r--app-editors/cssed/cssed-0.4.0-r1.ebuild3
-rw-r--r--app-editors/cssed/files/cssed-0.4.0-glibc-2.10.patch12
3 files changed, 20 insertions, 3 deletions
diff --git a/app-editors/cssed/ChangeLog b/app-editors/cssed/ChangeLog
index a5b10f1483b1..9869c17d6e27 100644
--- a/app-editors/cssed/ChangeLog
+++ b/app-editors/cssed/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-editors/cssed
-# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/cssed/ChangeLog,v 1.20 2009/02/11 15:08:51 angelos Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/cssed/ChangeLog,v 1.21 2009/08/05 22:59:04 ssuominen Exp $
+
+ 05 Aug 2009; Samuli Suominen <ssuominen@gentoo.org> cssed-0.4.0-r1.ebuild,
+ +files/cssed-0.4.0-glibc-2.10.patch:
+ Fix building with GCC 4.4+ and GLIBC 2.10+ wrt #273886.
11 Feb 2009; Christoph Mende <angelos@gentoo.org>
+files/cssed-0.4.0-asneeded.patch, cssed-0.4.0-r1.ebuild:
diff --git a/app-editors/cssed/cssed-0.4.0-r1.ebuild b/app-editors/cssed/cssed-0.4.0-r1.ebuild
index a9b2c8b36c1a..42c5596d416e 100644
--- a/app-editors/cssed/cssed-0.4.0-r1.ebuild
+++ b/app-editors/cssed/cssed-0.4.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/cssed/cssed-0.4.0-r1.ebuild,v 1.5 2009/02/11 15:08:51 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/cssed/cssed-0.4.0-r1.ebuild,v 1.6 2009/08/05 22:59:04 ssuominen Exp $
inherit autotools eutils toolchain-funcs
@@ -25,6 +25,7 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/${P}-asneeded.patch
+ epatch "${FILESDIR}"/${P}-glibc-2.10.patch
sed -i -e "/^cssed_LINK/s:g++:$(tc-getCXX) \$(LDFLAGS):" src/Makefile.am
eautoreconf
}
diff --git a/app-editors/cssed/files/cssed-0.4.0-glibc-2.10.patch b/app-editors/cssed/files/cssed-0.4.0-glibc-2.10.patch
new file mode 100644
index 000000000000..7ad886514554
--- /dev/null
+++ b/app-editors/cssed/files/cssed-0.4.0-glibc-2.10.patch
@@ -0,0 +1,12 @@
+diff -ur cssed-0.4.0.orig/scintilla/src/LexCaml.cxx cssed-0.4.0/scintilla/src/LexCaml.cxx
+--- cssed-0.4.0.orig/scintilla/src/LexCaml.cxx 2005-05-27 06:30:23.000000000 +0300
++++ cssed-0.4.0/scintilla/src/LexCaml.cxx 2009-08-06 01:58:38.000000000 +0300
+@@ -273,7 +273,7 @@
+
+ case SCE_CAML_OPERATOR: {
+ // [try to] interpret as [additional] operator char
+- char* o = 0;
++ const char* o = 0;
+ if (iscaml(ch) || isspace(ch) /* ident or whitespace */
+ || ((o = strchr(")]};,\'\"`#", ch)) != 0)/* "termination" chars */
+ || !strchr("!$%&*+-./:<=>?@^|~", ch)/* "operator" chars */) {