summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/emacs-vcs/ChangeLog5
-rw-r--r--app-editors/emacs-vcs/emacs-vcs-23.3.9999.ebuild9
2 files changed, 9 insertions, 5 deletions
diff --git a/app-editors/emacs-vcs/ChangeLog b/app-editors/emacs-vcs/ChangeLog
index 83200ac16e08..bc2f9c987489 100644
--- a/app-editors/emacs-vcs/ChangeLog
+++ b/app-editors/emacs-vcs/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-editors/emacs-vcs
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-vcs/ChangeLog,v 1.61 2011/08/19 17:27:26 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-vcs/ChangeLog,v 1.62 2011/09/09 19:21:18 ulm Exp $
+
+ 09 Sep 2011; Ulrich Mueller <ulm@gentoo.org> emacs-vcs-23.3.9999.ebuild:
+ Merge changes from Emacs overlay.
19 Aug 2011; Ulrich Mueller <ulm@gentoo.org> emacs-vcs-23.3.9999.ebuild,
emacs-vcs-24.0.9999-r1.ebuild:
diff --git a/app-editors/emacs-vcs/emacs-vcs-23.3.9999.ebuild b/app-editors/emacs-vcs/emacs-vcs-23.3.9999.ebuild
index c37e4b8391a2..6ea957fdd704 100644
--- a/app-editors/emacs-vcs/emacs-vcs-23.3.9999.ebuild
+++ b/app-editors/emacs-vcs/emacs-vcs-23.3.9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-vcs/emacs-vcs-23.3.9999.ebuild,v 1.11 2011/08/22 19:31:26 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-vcs/emacs-vcs-23.3.9999.ebuild,v 1.12 2011/09/09 19:21:18 ulm Exp $
EAPI=4
WANT_AUTOMAKE="none"
@@ -156,15 +156,16 @@ src_configure() {
myconf="${myconf} $(use_with gif) $(use_with jpeg)"
myconf="${myconf} $(use_with png) $(use_with svg rsvg)"
myconf="${myconf} $(use_with tiff) $(use_with xpm)"
- myconf="${myconf} $(use_with xft)"
if use xft; then
+ myconf="${myconf} --with-xft"
myconf="${myconf} $(use_with m17n-lib libotf)"
myconf="${myconf} $(use_with m17n-lib m17n-flt)"
else
+ myconf="${myconf} --without-xft"
myconf="${myconf} --without-libotf --without-m17n-flt"
use m17n-lib && ewarn \
- "USE flag \"m17n-lib\" has no effect because xft is not set."
+ "USE flag \"m17n-lib\" has no effect if \"xft\" is not set."
fi
# GTK+ is the default toolkit if USE=gtk is chosen with other
@@ -175,7 +176,7 @@ src_configure() {
myconf="${myconf} --with-x-toolkit=gtk"
elif use Xaw3d; then
einfo "Configuring to build with Xaw3d (Athena/Lucid) toolkit"
- myconf="${myconf} --with-x-toolkit=athena"
+ myconf="${myconf} --with-x-toolkit=lucid"
elif use motif; then
einfo "Configuring to build with Motif toolkit"
myconf="${myconf} --with-x-toolkit=motif"