summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/mg/ChangeLog5
-rw-r--r--app-editors/mg/mg-20080610.ebuild6
2 files changed, 8 insertions, 3 deletions
diff --git a/app-editors/mg/ChangeLog b/app-editors/mg/ChangeLog
index 6ab55605aeab..7a0dea201ab5 100644
--- a/app-editors/mg/ChangeLog
+++ b/app-editors/mg/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-editors/mg
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/mg/ChangeLog,v 1.13 2008/09/11 23:14:53 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/mg/ChangeLog,v 1.14 2008/10/24 06:31:04 ulm Exp $
+
+ 24 Oct 2008; Ulrich Mueller <ulm@gentoo.org> mg-20080610.ebuild:
+ Honour CC variable, fixes bug 243566.
11 Sep 2008; Christian Faulhammer <opfer@gentoo.org> -mg-20080322.ebuild:
clean up
diff --git a/app-editors/mg/mg-20080610.ebuild b/app-editors/mg/mg-20080610.ebuild
index fbbe6c44e3f6..9bca11d09a8a 100644
--- a/app-editors/mg/mg-20080610.ebuild
+++ b/app-editors/mg/mg-20080610.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/mg/mg-20080610.ebuild,v 1.2 2008/08/29 22:14:17 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/mg/mg-20080610.ebuild,v 1.3 2008/10/24 06:31:04 ulm Exp $
+
+inherit toolchain-funcs
DESCRIPTION="Micro GNU/emacs, a port from the BSDs"
HOMEPAGE="http://www.xs4all.nl/~hanb/software/mg/"
@@ -14,7 +16,7 @@ IUSE=""
src_compile() {
# econf won't work, as this script does not accept any parameters
./configure || die "configure failed"
- emake CFLAGS="${CFLAGS}" || die "emake failed"
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die "emake failed"
}
src_install() {