summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/lyx')
-rw-r--r--app-office/lyx/ChangeLog10
-rw-r--r--app-office/lyx/files/digest-lyx-1.2.0.200207051
-rw-r--r--app-office/lyx/lyx-1.2.0.20020705.ebuild60
3 files changed, 70 insertions, 1 deletions
diff --git a/app-office/lyx/ChangeLog b/app-office/lyx/ChangeLog
index 1f88ed6ad033..235a9d00b7ab 100644
--- a/app-office/lyx/ChangeLog
+++ b/app-office/lyx/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-office/lyx
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/ChangeLog,v 1.3 2002/06/07 11:08:06 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/ChangeLog,v 1.4 2002/07/05 16:50:46 danarmak Exp $
+
+*lyx-1.2.0.20020705 (05 Jul 2002)
+
+ 05 Jul 2002; Dan Armak <danarmak@gentoo.org> ChangeLog :
+
+ This is a 20020705 snapshot of the lyx cvs 1.2.x branch - i.e. 1.2.0 plus
+ all the bugfixes made
+ so far, working towards a 1.2.1 release. It fixes fex. #3538.
7 Jun 2002; Dan Armak <danarmak@gentoo.org> changelog:
diff --git a/app-office/lyx/files/digest-lyx-1.2.0.20020705 b/app-office/lyx/files/digest-lyx-1.2.0.20020705
new file mode 100644
index 000000000000..169754b735af
--- /dev/null
+++ b/app-office/lyx/files/digest-lyx-1.2.0.20020705
@@ -0,0 +1 @@
+MD5 db518ac92e9e72878df81eb9353f6bfb lyx-1.2.0.20020705.tar.bz2 3912062
diff --git a/app-office/lyx/lyx-1.2.0.20020705.ebuild b/app-office/lyx/lyx-1.2.0.20020705.ebuild
new file mode 100644
index 000000000000..968a811f8bb9
--- /dev/null
+++ b/app-office/lyx/lyx-1.2.0.20020705.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/lyx-1.2.0.20020705.ebuild,v 1.1 2002/07/05 16:50:46 danarmak Exp $
+
+S=${WORKDIR}/lyx-devel
+DESCRIPTION="LyX is an WYSIWYM frontend for LaTeX"
+SRC_URI="ftp://ftp.lyx.org/pub/lyx/stable/${P}.tar.bz2"
+HOMEPAGE="http://www.lyx.org/"
+LICENSE=GPL-2
+
+# This lyx-base ebuild only depends on the absolutely necessary packages.
+# The acompanying lyx-utils ebuild depends on lyx-base and on everything
+# else that lyx can use.
+DEPEND="virtual/x11
+ x11-libs/xforms
+ app-text/tetex
+ >=sys-devel/perl-5
+ nls? ( sys-devel/gettext )
+ app-text/aiksaurus"
+RDEPEND="$DEPEND
+ app-text/ghostscript
+ app-text/xpdf
+ app-text/ispell
+ app-text/gv
+ app-text/latex2html
+ media-gfx/imagemagick
+ cups? ( virtual/lpr )
+ app-text/rcs
+ dev-util/cvs
+ app-text/sgmltools-lite
+ app-text/noweb
+ app-text/chktex"
+
+src_compile() {
+
+ use nls || myconf="${myconf} --disable-nls"
+ [ -n "$DEBUG" ] && myconf="$myconf --enable-debug" || myconf="$myconf --disable-debug"
+
+ # -O3 and higher breaks
+ export CXXFLAGS="${CXXFLAGS//-O[3..9]/-O2}"
+ export CFLAGS="${CFLAGS//-O[3..9]/-O2}"
+
+ ./autogen.sh
+
+ ./configure --host=${CHOST} --prefix=/usr ${myconf} || die "./configure failed"
+ #--infodir='$(prefix)/share/info' \
+ #--with-extra-inc=/usr/X11R6/include \
+ #--mandir='$(prefix)/share/man' \
+ emake || die "emake failed"
+}
+
+src_install () {
+ # The 'install-strip' target is provided by the LyX makefile
+ # for stripping installed binaries. Use prefix= instead of
+ # DESTDIR=, otherwise it violates the sandbox in the po directory.
+ make prefix=${D}/usr install
+ dodoc README* UPGRADING INSTALL* ChangeLog NEW COPYING ANNOUNCE ABOUT-NLS
+}
+