summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office')
-rw-r--r--app-office/texstudio/ChangeLog8
-rw-r--r--app-office/texstudio/files/texmakerx_my.pri18
-rw-r--r--app-office/texstudio/files/texstudio-2.6.4-hunspell-quazip.patch16
-rw-r--r--app-office/texstudio/texstudio-2.6.4.ebuild79
4 files changed, 120 insertions, 1 deletions
diff --git a/app-office/texstudio/ChangeLog b/app-office/texstudio/ChangeLog
index b78f33fb21ab..5ca603fc556a 100644
--- a/app-office/texstudio/ChangeLog
+++ b/app-office/texstudio/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/texstudio
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/texstudio/ChangeLog,v 1.22 2013/09/05 10:44:55 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/texstudio/ChangeLog,v 1.23 2013/10/22 11:34:23 jlec Exp $
+
+*texstudio-2.6.4 (22 Oct 2013)
+
+ 22 Oct 2013; Justin Lecher <jlec@gentoo.org> +texstudio-2.6.4.ebuild,
+ +files/texstudio-2.6.4-hunspell-quazip.patch, +files/texmakerx_my.pri:
+ Version BUmp, #488942
05 Sep 2013; Agostino Sarubbo <ago@gentoo.org> texstudio-2.6.0.ebuild:
Stable for ppc64, wrt bug #476558
diff --git a/app-office/texstudio/files/texmakerx_my.pri b/app-office/texstudio/files/texmakerx_my.pri
new file mode 100644
index 000000000000..06426fc6a9ce
--- /dev/null
+++ b/app-office/texstudio/files/texmakerx_my.pri
@@ -0,0 +1,18 @@
+CONFIG += link_pkgconfig
+
+# System Quazip
+INCLUDEPATH += @GENTOO_PORTAGE_EPREFIX@/usr/include/quazip
+LIBS += -lquazip
+#INCLUDEPATH += @GENTOO_PORTAGE_EPREFIX@/usr/include/qt4/QCodeEdit
+#INCLUDEPATH += @GENTOO_PORTAGE_EPREFIX@/usr/include/qt4/QtSolutions
+
+# System hunspell
+PKGCONFIG += hunspell
+
+# System qtsingleapplication
+#QT += solutions
+CONFIG += qtsingleapplication
+
+# System qcodeedit
+# Not working currently
+#CONFIG += qcodeedit
diff --git a/app-office/texstudio/files/texstudio-2.6.4-hunspell-quazip.patch b/app-office/texstudio/files/texstudio-2.6.4-hunspell-quazip.patch
new file mode 100644
index 000000000000..0ddcccb06147
--- /dev/null
+++ b/app-office/texstudio/files/texstudio-2.6.4-hunspell-quazip.patch
@@ -0,0 +1,16 @@
+ spellerutility.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/spellerutility.h b/spellerutility.h
+index 7e1b980..b0bc8b8 100644
+--- a/spellerutility.h
++++ b/spellerutility.h
+@@ -13,7 +13,7 @@
+
+ #include "mostQtHeaders.h"
+
+-#include "hunspell/hunspell.hxx"
++#include <hunspell.hxx>
+ class SpellerUtility: public QObject {
+ Q_OBJECT
+ public:
diff --git a/app-office/texstudio/texstudio-2.6.4.ebuild b/app-office/texstudio/texstudio-2.6.4.ebuild
new file mode 100644
index 000000000000..ccb91cad963c
--- /dev/null
+++ b/app-office/texstudio/texstudio-2.6.4.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/texstudio/texstudio-2.6.4.ebuild,v 1.1 2013/10/22 11:34:23 jlec Exp $
+
+EAPI=5
+
+inherit base fdo-mime prefix qt4-r2
+
+DESCRIPTION="Free cross-platform LaTeX editor (fork from texmakerX)"
+HOMEPAGE="http://texstudio.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}/TeXstudio%20${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="video"
+
+COMMON_DEPEND="
+ app-text/hunspell
+ app-text/poppler:=[qt4]
+ dev-libs/quazip
+ x11-libs/libX11
+ x11-libs/libXext
+ || ( ( >=dev-qt/qtgui-4.8.5:4 dev-qt/designer:4 ) <dev-qt/qtgui-4.8.5:4 )
+ >=dev-qt/qtcore-4.6.1:4
+ >=dev-qt/qtscript-4.6.1:4
+ dev-qt/qtsingleapplication
+ >=dev-qt/qtsvg-4.6.1:4
+ >=dev-qt/qttest-4.6.1:4
+ video? ( media-libs/phonon )"
+RDEPEND="${COMMON_DEPEND}
+ virtual/latex-base
+ app-text/psutils
+ app-text/ghostscript-gpl
+ media-libs/netpbm"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}"/${P/-/}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-hunspell-quazip.patch
+ "${FILESDIR}"/${PN}-2.6.0-desktop.patch
+# Get it from fedora
+ "${FILESDIR}"/${PN}-2.5-viewers-use-xdg-open.patch
+ )
+
+src_prepare() {
+ find hunspell quazip utilities/poppler-data qtsingleapplication -delete || die
+
+ if use video; then
+ sed "/^PHONON/s:$:true:g" -i ${PN}.pro || die
+ fi
+
+ sed \
+ -e '/hunspell.pri/d' \
+ -e '/quazip.pri/d' \
+ -e '/qtsingleapplication.pri/d' \
+ -e '/QUAZIP_STATIC/d' \
+ -i ${PN}.pro || die
+
+ cp "${FILESDIR}"/texmakerx_my.pri . || die
+ eprefixify texmakerx_my.pri
+
+ qt4-r2_src_prepare
+}
+
+src_install() {
+ local i
+ for i in 16x16 22x22 32x32 48x48 64x64; do
+ insinto /usr/share/icons/hicolor/${i}
+ newins utilities/${PN}${i}.png ${PN}.png
+ done
+ qt4-r2_src_install
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}