summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office')
-rw-r--r--app-office/koffice/koffice-2.1.1_beta2.ebuild18
1 files changed, 14 insertions, 4 deletions
diff --git a/app-office/koffice/koffice-2.1.1_beta2.ebuild b/app-office/koffice/koffice-2.1.1_beta2.ebuild
index fe679096d193..0126718542a4 100644
--- a/app-office/koffice/koffice-2.1.1_beta2.ebuild
+++ b/app-office/koffice/koffice-2.1.1_beta2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/koffice-2.1.1_beta2.ebuild,v 1.1 2001/05/22 03:48:32 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/koffice-2.1.1_beta2.ebuild,v 1.2 2001/06/08 01:08:06 achim Exp $
P=${PN}-1.1-beta2
A=${P}.tar.bz2
@@ -14,11 +14,12 @@ SRC_URI="ftp://ftp.kde.org/pub/$SRC_PATH
HOMEPAGE="http://www.kde.org/"
DEPEND=">=kde-base/kdelibs-2.1.2
- >=dev-lang/python-2.0-r2
+ >=dev-lang/python-2.0-r2
sys-devel/automake
sys-devel/autoconf"
-RDEPEND=$DEPEND
+RDEPEND=">=kde-base/kdelibs-2.1.2"
+
src_unpack() {
unpack ${A}
@@ -29,8 +30,17 @@ src_unpack() {
src_compile() {
QTBASE=/usr/X11R6/lib/qt
+ local myconf
+ if [ "`use qtmt`" ]
+ then
+ myconf="--enable-mt"
+ fi
+ if [ "`use mitshm`" ]
+ then
+ myconf="$myconf --enable-mitshm"
+ fi
try ./configure --prefix=$KDEDIR --host=${CHOST} \
- --with-qt-dir=$QTBASE
+ --with-qt-dir=$QTBASE $myconf
try make
}