summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-sci')
-rw-r--r--app-sci/epix/ChangeLog7
-rw-r--r--app-sci/epix/Manifest4
-rw-r--r--app-sci/epix/epix-1.0.0.ebuild42
-rw-r--r--app-sci/epix/files/digest-epix-1.0.01
4 files changed, 52 insertions, 2 deletions
diff --git a/app-sci/epix/ChangeLog b/app-sci/epix/ChangeLog
index abe18eafba77..9c32ebb74f1e 100644
--- a/app-sci/epix/ChangeLog
+++ b/app-sci/epix/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-sci/epix
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/epix/ChangeLog,v 1.9 2004/11/22 13:26:40 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/epix/ChangeLog,v 1.10 2004/11/24 00:54:28 ribosome Exp $
+
+*epix-1.0.0 (23 Nov 2004)
+
+ 23 Nov 2004; Olivier Fisette <ribosome@gentoo.org> +epix-1.0.0.ebuild:
+ New version. Credits go to Marcus Hanwell <gentoo@cryos.net>.
22 Nov 2004; Patrick Kursawe <phosphan@gentoo.org> epix-0.8.10a-r1.ebuild:
Using tc-getCXX now (bug #71849). Cleanup.
diff --git a/app-sci/epix/Manifest b/app-sci/epix/Manifest
index 489689fb038d..a6f1ef03ac25 100644
--- a/app-sci/epix/Manifest
+++ b/app-sci/epix/Manifest
@@ -1,4 +1,6 @@
MD5 e9668a0f0e3243a2498154b637592645 epix-0.8.10a-r1.ebuild 1504
-MD5 66f364fd96e24d4e3f519dfd8e5beabf ChangeLog 1083
+MD5 67186318cc129574e49c3edb0c4cec92 epix-1.0.0.ebuild 1183
+MD5 0c44ff652714edd57d3fed10f3f31943 ChangeLog 1248
MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
+MD5 978e21d695848341b116f070137c4a50 files/digest-epix-1.0.0 72
MD5 dc26ec6bc48dee7ffacbe02626c03b78 files/digest-epix-0.8.10a-r1 74
diff --git a/app-sci/epix/epix-1.0.0.ebuild b/app-sci/epix/epix-1.0.0.ebuild
new file mode 100644
index 000000000000..45aa1a1f0f70
--- /dev/null
+++ b/app-sci/epix/epix-1.0.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/epix/epix-1.0.0.ebuild,v 1.1 2004/11/24 00:54:28 ribosome Exp $
+
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="2- and 3-D plotter for creating images (to be used in LaTeX)"
+HOMEPAGE="http://mathcs.holycross.edu/~ahwang/current/ePiX.html"
+SRC_URI="http://mathcs.holycross.edu/~ahwang/epix/${P}_complete.tar.bz2"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND="app-shells/bash
+ >=sys-apps/sed-4"
+
+src_compile() {
+ filter-flags -O1 -O2 -O3 -Os
+ make CXX="$(tc-getCXX)" CFLAGS="-c -Wall ${CXXFLAGS}" prefix="${D}/usr" all || die "emake failed."
+ echo > README.gentoo -e "The full documentation is well hidden in the epix*howto.ps.gz-file in the tutorial subdirectory"
+}
+
+src_test() {
+ make CXX="$(tc-getCXX)" CFLAGS="${CFLAGS}" prefix="${D}/usr" test
+}
+
+src_install() {
+ make CXX="$(tc-getCXX)" CFLAGS="${CFLAGS}" prefix="${D}/usr" install || die
+ dodoc README.gentoo
+ cd ${D}/usr/share/${PN}
+ rm notes/COPYING
+ rm notes/INSTALL
+ dodoc notes/*
+ rm -rf notes
+ insinto /usr/share/doc/${PF}/tutorial
+ doins tutorial/*
+ insinto /usr/share/doc/${PF}/tutorial/contrib
+ doins tutorial/contrib/*
+ rm -rf tutorial
+}
diff --git a/app-sci/epix/files/digest-epix-1.0.0 b/app-sci/epix/files/digest-epix-1.0.0
new file mode 100644
index 000000000000..f2370639b6a7
--- /dev/null
+++ b/app-sci/epix/files/digest-epix-1.0.0
@@ -0,0 +1 @@
+MD5 7138e8084e0dbd2f2c6899835812e5a9 epix-1.0.0_complete.tar.bz2 172151