summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/sqlite')
-rw-r--r--dev-db/sqlite/files/digest-sqlite-2.0.31
-rw-r--r--dev-db/sqlite/sqlite-2.0.3.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-db/sqlite/files/digest-sqlite-2.0.3 b/dev-db/sqlite/files/digest-sqlite-2.0.3
new file mode 100644
index 000000000000..a4e48cd459a5
--- /dev/null
+++ b/dev-db/sqlite/files/digest-sqlite-2.0.3
@@ -0,0 +1 @@
+MD5 4397b0d1f26f8634cc06cb41a757601b sqlite-2.0.3.tar.gz
diff --git a/dev-db/sqlite/sqlite-2.0.3.ebuild b/dev-db/sqlite/sqlite-2.0.3.ebuild
new file mode 100644
index 000000000000..dc77ef51827b
--- /dev/null
+++ b/dev-db/sqlite/sqlite-2.0.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Martin Schlemmer <azarah@gentoo.org>
+
+S=${WORKDIR}/sqlite
+DESCRIPTION="SQLite: An SQL Database Engine in a C Library."
+SRC_URI="http://www.hwaci.com/sw/sqlite/${P}.tar.gz"
+HOMEPAGE="http://www.hwaci.com/sw/sqlite/"
+
+DEPEND="virtual/glibc"
+
+
+src_compile() {
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --sysconfdir=/etc || die
+ emake || die
+ make doc || die
+}
+
+src_install () {
+
+ dodir /usr/{bin,include,lib}
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ sysconfdir=${D}/etc \
+ install || die
+
+ dobin lemon
+
+ dodoc README VERSION
+ docinto html
+ dodoc doc/*.html doc/*.txt doc/*.png
+}