summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/gtk2hs/gtk2hs-0.10.1.ebuild')
-rw-r--r--dev-haskell/gtk2hs/gtk2hs-0.10.1.ebuild14
1 files changed, 6 insertions, 8 deletions
diff --git a/dev-haskell/gtk2hs/gtk2hs-0.10.1.ebuild b/dev-haskell/gtk2hs/gtk2hs-0.10.1.ebuild
index 4e24be4019ca..551cf720f475 100644
--- a/dev-haskell/gtk2hs/gtk2hs-0.10.1.ebuild
+++ b/dev-haskell/gtk2hs/gtk2hs-0.10.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/gtk2hs/gtk2hs-0.10.1.ebuild,v 1.2 2010/03/27 09:01:56 kolmodin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/gtk2hs/gtk2hs-0.10.1.ebuild,v 1.3 2010/06/28 14:28:37 ssuominen Exp $
EAPI="2"
@@ -16,7 +16,7 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="doc profile glade gnome opengl svg xulrunner"
+IUSE="doc profile glade gnome opengl svg"
RDEPEND=">=dev-lang/ghc-6.6
dev-haskell/mtl[doc?]
@@ -26,8 +26,7 @@ RDEPEND=">=dev-lang/ghc-6.6
>=x11-libs/gtksourceview-2.2
gnome-base/gconf )
svg? ( gnome-base/librsvg )
- opengl? ( x11-libs/gtkglext )
- xulrunner? ( =net-libs/xulrunner-1.8* )"
+ opengl? ( x11-libs/gtkglext )"
DEPEND="${RDEPEND}
doc? ( >=dev-haskell/haddock-2.4.1 )
@@ -56,8 +55,9 @@ src_configure() {
$(use_enable gnome gtksourceview2) \
$(use_enable svg svg) \
$(use_enable opengl opengl) \
+ --disable-seamonkey \
--disable-firefox \
- $(use_enable xulrunner xulrunner) \
+ --disable-xulrunner \
$(use_enable doc docs) \
$(use_enable profile profiling) \
|| die "Configure failed"
@@ -90,8 +90,6 @@ src_install() {
$(use svg && echo \
"${D}/usr/$(get_libdir)/gtk2hs/svgcairo.package.conf") \
$(use opengl && echo \
- "${D}/usr/$(get_libdir)/gtk2hs/gtkglext.package.conf") \
- $(use xulrunner && echo \
- "${D}/usr/$(get_libdir)/gtk2hs/mozembed.package.conf")
+ "${D}/usr/$(get_libdir)/gtk2hs/gtkglext.package.conf")
ghc-install-pkg
}