summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libxml2')
-rw-r--r--dev-libs/libxml2/ChangeLog8
-rw-r--r--dev-libs/libxml2/files/digest-libxml2-2.6.279
-rw-r--r--dev-libs/libxml2/libxml2-2.6.27.ebuild110
3 files changed, 126 insertions, 1 deletions
diff --git a/dev-libs/libxml2/ChangeLog b/dev-libs/libxml2/ChangeLog
index f71c91415f25..09351e916380 100644
--- a/dev-libs/libxml2/ChangeLog
+++ b/dev-libs/libxml2/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libxml2
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/ChangeLog,v 1.170 2006/10/27 10:20:02 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/ChangeLog,v 1.171 2006/12/14 01:41:18 leonardop Exp $
+
+*libxml2-2.6.27 (14 Dec 2006)
+
+ 14 Dec 2006; Leonardo Boshell <leonardop@gentoo.org>
+ +libxml2-2.6.27.ebuild:
+ New release.
27 Oct 2006; Fabian Groffen <grobian@gentoo.org> libxml2-2.6.23.ebuild,
libxml2-2.6.23-r1.ebuild, libxml2-2.6.24.ebuild, libxml2-2.6.26.ebuild:
diff --git a/dev-libs/libxml2/files/digest-libxml2-2.6.27 b/dev-libs/libxml2/files/digest-libxml2-2.6.27
new file mode 100644
index 000000000000..c82596f2d593
--- /dev/null
+++ b/dev-libs/libxml2/files/digest-libxml2-2.6.27
@@ -0,0 +1,9 @@
+MD5 f5806f5059ef7bd4d3fcf36cf116d1ef libxml2-2.6.27.tar.gz 4590835
+RMD160 795efee7c91484eb11dd0b275744057d2c82719d libxml2-2.6.27.tar.gz 4590835
+SHA256 d7549485c55e55041ad5a5e531b17935d89ebf474ae8bc98a51ea31eeeb876e9 libxml2-2.6.27.tar.gz 4590835
+MD5 073bb1181a019a3f49ed2a8018e56ffe xsts-2002-01-16.tar.gz 6894439
+RMD160 e8905fe1451a1c367b0104af24edca73bad1db08 xsts-2002-01-16.tar.gz 6894439
+SHA256 55e5c08db29946a91ea8e70e8f2418d3fd30d8b6777941dfba7f54726ffd9914 xsts-2002-01-16.tar.gz 6894439
+MD5 e15e6b539347a9da9a1337c0ac1af7b1 xsts-2004-01-14.tar.gz 2761085
+RMD160 faff2d7826e47ae9968564bc83dab1b54c5e4bf6 xsts-2004-01-14.tar.gz 2761085
+SHA256 09bdf9f81f381ebf9bc158a9472e498e896f7a02eb7461146e9abe1b9493ca17 xsts-2004-01-14.tar.gz 2761085
diff --git a/dev-libs/libxml2/libxml2-2.6.27.ebuild b/dev-libs/libxml2/libxml2-2.6.27.ebuild
new file mode 100644
index 000000000000..50f2b6a7be84
--- /dev/null
+++ b/dev-libs/libxml2/libxml2-2.6.27.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/libxml2-2.6.27.ebuild,v 1.1 2006/12/14 01:41:18 leonardop Exp $
+
+inherit libtool flag-o-matic eutils
+
+DESCRIPTION="Version 2 of the library to manipulate XML files"
+HOMEPAGE="http://www.xmlsoft.org/"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="debug doc ipv6 python readline test"
+
+XSTS_HOME="http://www.w3.org/XML/2004/xml-schema-test-suite"
+XSTS_NAME_1="xmlschema2002-01-16"
+XSTS_NAME_2="xmlschema2004-01-14"
+XSTS_TARBALL_1="xsts-2002-01-16.tar.gz"
+XSTS_TARBALL_2="xsts-2004-01-14.tar.gz"
+
+SRC_URI="ftp://xmlsoft.org/${PN}/${P}.tar.gz
+ test? (
+ ${XSTS_HOME}/${XSTS_NAME_1}/${XSTS_TARBALL_1}
+ ${XSTS_HOME}/${XSTS_NAME_2}/${XSTS_TARBALL_2} )"
+
+RDEPEND="sys-libs/zlib
+ python? ( dev-lang/python )
+ readline? ( sys-libs/readline )"
+
+DEPEND="${RDEPEND}
+ hppa? ( >=sys-devel/binutils-2.15.92.0.2 )"
+
+
+src_unpack() {
+ unpack "${P}.tar.gz"
+ cd "${S}"
+
+ if use test; then
+ cp ${DISTDIR}/${XSTS_TARBALL_1} \
+ ${DISTDIR}/${XSTS_TARBALL_2} \
+ ${S}/xstc/ \
+ || die "Failed to install test tarballs"
+ fi
+
+ epunt_cxx
+}
+
+src_compile() {
+ # USE zlib support breaks gnome2
+ # (libgnomeprint for instance fails to compile with
+ # fresh install, and existing) - <azarah@gentoo.org> (22 Dec 2002).
+
+ # The meaning of the 'debug' USE flag does not apply to the --with-debug
+ # switch (enabling the libxml2 debug module). See bug #100898.
+
+ # --with-mem-debug causes unusual segmentation faults (bug #105120).
+
+ local myconf="--with-zlib \
+ $(use_with debug run-debug) \
+ $(use_with python) \
+ $(use_with readline) \
+ $(use_with readline history) \
+ $(use_enable ipv6)"
+
+ # Please do not remove, as else we get references to PORTAGE_TMPDIR
+ # in /usr/lib/python?.?/site-packages/libxml2mod.la among things.
+ elibtoolize
+
+ # filter seemingly problematic CFLAGS (#26320)
+ filter-flags -fprefetch-loop-arrays -funroll-loops
+
+ econf $myconf || die "Configuration failed"
+
+ # Patching the Makefiles to respect get_libdir
+ # Fixes BUG #86766, please keep this.
+ # Danny van Dyk <kugelfang@gentoo.org> 2005/03/26
+ for x in $(find ${S} -name "Makefile") ; do
+ sed \
+ -e "s|^\(PYTHON_SITE_PACKAGES\ =\ \/usr\/\).*\(\/python.*\)|\1$(get_libdir)\2|g" \
+ -i ${x} \
+ || die "sed failed"
+ done
+
+ emake || die "Copilation failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "Installation failed"
+
+ dodoc AUTHORS ChangeLog Copyright NEWS README* TODO*
+
+ if ! use doc; then
+ rm -rf ${D}/usr/share/gtk-doc
+ rm -rf ${D}/usr/share/doc/${P}/html
+ fi
+}
+
+pkg_postinst() {
+ # need an XML catalog, so no-one writes to a non-existent one
+ CATALOG="${ROOT}etc/xml/catalog"
+
+ # we dont want to clobber an existing catalog though,
+ # only ensure that one is there
+ # <obz@gentoo.org>
+ if [ ! -e ${CATALOG} ]; then
+ [ -d "${ROOT}etc/xml" ] || mkdir -p "${ROOT}etc/xml"
+ /usr/bin/xmlcatalog --create > ${CATALOG}
+ einfo "Created XML catalog in ${CATALOG}"
+ fi
+}