summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/link-grammar')
-rw-r--r--dev-libs/link-grammar/ChangeLog7
-rw-r--r--dev-libs/link-grammar/link-grammar-4.7.8.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/dev-libs/link-grammar/ChangeLog b/dev-libs/link-grammar/ChangeLog
index 3b14b26adcca..0f47ed7983a4 100644
--- a/dev-libs/link-grammar/ChangeLog
+++ b/dev-libs/link-grammar/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/link-grammar
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/link-grammar/ChangeLog,v 1.50 2012/10/16 04:18:07 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/link-grammar/ChangeLog,v 1.51 2012/10/19 18:31:46 pacho Exp $
+
+*link-grammar-4.7.8 (19 Oct 2012)
+
+ 19 Oct 2012; Pacho Ramos <pacho@gentoo.org> +link-grammar-4.7.8.ebuild:
+ Version bump, add missing depend on ant-core (#438266 by Ferenc Erki).
16 Oct 2012; Anthony G. Basile <blueness@gentoo.org>
link-grammar-4.7.6.ebuild:
diff --git a/dev-libs/link-grammar/link-grammar-4.7.8.ebuild b/dev-libs/link-grammar/link-grammar-4.7.8.ebuild
new file mode 100644
index 000000000000..0ce6a8816835
--- /dev/null
+++ b/dev-libs/link-grammar/link-grammar-4.7.8.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/link-grammar/link-grammar-4.7.8.ebuild,v 1.1 2012/10/19 18:31:46 pacho Exp $
+
+EAPI=4
+inherit java-pkg-opt-2 eutils
+
+DESCRIPTION="Link Grammar Parser is a syntactic English parser."
+HOMEPAGE="http://www.abisource.com/projects/link-grammar/ http://www.link.cs.cmu.edu/link/"
+SRC_URI="http://www.abisource.com/downloads/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+# Set the same default as used in app-text/enchant
+IUSE="aspell +hunspell java static-libs threads"
+
+DEPEND="aspell? ( app-text/aspell )
+ hunspell? ( app-text/hunspell )
+ java? ( >=virtual/jdk-1.5
+ dev-java/ant-core )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ java-pkg-opt-2_pkg_setup
+ if use aspell && use hunspell; then
+ ewarn "You have enabled 'aspell' and 'hunspell' support, but both cannot coexist,"
+ ewarn "only aspell will be build. Press Ctrl+C and set only 'hunspell' USE flag if"
+ ewarn "you want hunspell support."
+ fi
+}
+
+src_configure() {
+ local myconf
+
+ use hunspell && myconf="${myconf} --with-hunspell-dictdir=/usr/share/myspell"
+ econf \
+ --enable-shared \
+ $(use_enable aspell) \
+ $(use_enable hunspell) \
+ $(use_enable java java-bindings) \
+ $(use_enable static-libs static) \
+ $(use_enable threads pthreads) \
+ ${myconf}
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}