summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/cl-yaclml/ChangeLog10
-rw-r--r--dev-lisp/cl-yaclml/Manifest3
-rw-r--r--dev-lisp/cl-yaclml/cl-yaclml-0.5.2.ebuild40
-rw-r--r--dev-lisp/cl-yaclml/files/digest-cl-yaclml-0.5.21
-rw-r--r--dev-lisp/cl-yaclml/metadata.xml5
5 files changed, 59 insertions, 0 deletions
diff --git a/dev-lisp/cl-yaclml/ChangeLog b/dev-lisp/cl-yaclml/ChangeLog
new file mode 100644
index 000000000000..4d4780c7138b
--- /dev/null
+++ b/dev-lisp/cl-yaclml/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-lisp/cl-yaclml
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-yaclml/ChangeLog,v 1.1 2005/01/11 18:49:29 mkennedy Exp $
+
+*cl-yaclml-0.5.2 (11 Jan 2005)
+
+ 11 Jan 2005; Matthew Kennedy <mkennedy@gentoo.org> +metadata.xml,
+ +cl-yaclml-0.5.2.ebuild:
+ Initial port. Ebuild contributed by Matthew Kennedy <mkennedy@gentoo.org>
+
diff --git a/dev-lisp/cl-yaclml/Manifest b/dev-lisp/cl-yaclml/Manifest
new file mode 100644
index 000000000000..f94461d9b286
--- /dev/null
+++ b/dev-lisp/cl-yaclml/Manifest
@@ -0,0 +1,3 @@
+MD5 005cee2d5bdcdc70e1f1e5f0ca559f4c cl-yaclml-0.5.2.ebuild 1076
+MD5 ff897f603d1e4c01cc2732d02e362ef1 metadata.xml 587
+MD5 43a726ae37ba350b881aac58bd6f8b49 files/digest-cl-yaclml-0.5.2 63
diff --git a/dev-lisp/cl-yaclml/cl-yaclml-0.5.2.ebuild b/dev-lisp/cl-yaclml/cl-yaclml-0.5.2.ebuild
new file mode 100644
index 000000000000..db7e943c1fa9
--- /dev/null
+++ b/dev-lisp/cl-yaclml/cl-yaclml-0.5.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-yaclml/cl-yaclml-0.5.2.ebuild,v 1.1 2005/01/11 18:49:29 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="yaclml is a collection of macros and utilities for generating XML/HTML like markup from lisp code"
+HOMEPAGE="http://common-lisp.net/project/bese/yaclml.html"
+SRC_URI="ftp://ftp.common-lisp.net/pub/project/bese/yaclml_${PV}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc"
+DEPEND="dev-lisp/cl-iterate
+ dev-lisp/cl-arnesi
+ doc? ( virtual/tetex )"
+
+CLPACKAGE="yaclml"
+
+S=${WORKDIR}/yaclml_${PV}
+
+src_unpack() {
+ unpack ${A}
+ find ${S}/ -type d -name .arch-ids -exec rm -rf '{}' \; &>/dev/null
+}
+
+src_compile() {
+ use doc && make -C docs || die
+}
+
+src_install() {
+ dodir /usr/share/common-lisp/source/yaclml
+ dodir /usr/share/common-lisp/systems
+ cp -R src ${D}/usr/share/common-lisp/source/yaclml/
+ common-lisp-install yaclml.asd
+ common-lisp-system-symlink
+ dosym /usr/share/common-lisp/source/yaclml/yaclml.asd \
+ /usr/share/common-lisp/systems/
+ use doc && dodoc docs/yaclml.pdf
+}
diff --git a/dev-lisp/cl-yaclml/files/digest-cl-yaclml-0.5.2 b/dev-lisp/cl-yaclml/files/digest-cl-yaclml-0.5.2
new file mode 100644
index 000000000000..c8979cc1354b
--- /dev/null
+++ b/dev-lisp/cl-yaclml/files/digest-cl-yaclml-0.5.2
@@ -0,0 +1 @@
+MD5 c2180144e96c6ce9aa6ae612d31fd04a yaclml_0.5.2.tar.gz 55805
diff --git a/dev-lisp/cl-yaclml/metadata.xml b/dev-lisp/cl-yaclml/metadata.xml
new file mode 100644
index 000000000000..f418045b09c8
--- /dev/null
+++ b/dev-lisp/cl-yaclml/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>common-lisp</herd>
+</pkgmetadata>