summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/autopep8')
-rw-r--r--dev-python/autopep8/ChangeLog7
-rw-r--r--dev-python/autopep8/autopep8-0.5.2.ebuild32
2 files changed, 38 insertions, 1 deletions
diff --git a/dev-python/autopep8/ChangeLog b/dev-python/autopep8/ChangeLog
index 8cb69b65dc13..c988b191f142 100644
--- a/dev-python/autopep8/ChangeLog
+++ b/dev-python/autopep8/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/autopep8
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/autopep8/ChangeLog,v 1.3 2012/02/27 18:26:15 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/autopep8/ChangeLog,v 1.4 2012/03/12 13:10:53 xarthisius Exp $
+
+*autopep8-0.5.2 (12 Mar 2012)
+
+ 12 Mar 2012; Kacper Kowalik <xarthisius@gentoo.org> +autopep8-0.5.2.ebuild:
+ Version bump
*autopep8-9999 (27 Feb 2012)
diff --git a/dev-python/autopep8/autopep8-0.5.2.ebuild b/dev-python/autopep8/autopep8-0.5.2.ebuild
new file mode 100644
index 000000000000..848b68495fbc
--- /dev/null
+++ b/dev-python/autopep8/autopep8-0.5.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/autopep8/autopep8-0.5.2.ebuild,v 1.1 2012/03/12 13:10:53 xarthisius Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="*"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide"
+HOMEPAGE="https://github.com/hhatto/autopep8 http://pypi.python.org/pypi/autopep8"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/pep8"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+PYTHON_MODNAME="${PN}.py"
+
+src_test() {
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" test/test_${PN}.py
+ }
+ python_execute_function testing
+}