summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/httplib2')
-rw-r--r--dev-python/httplib2/ChangeLog7
-rw-r--r--dev-python/httplib2/httplib2-0.7.6.ebuild30
2 files changed, 36 insertions, 1 deletions
diff --git a/dev-python/httplib2/ChangeLog b/dev-python/httplib2/ChangeLog
index 3b8378cc091f..02cab55c95d9 100644
--- a/dev-python/httplib2/ChangeLog
+++ b/dev-python/httplib2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/httplib2
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/httplib2/ChangeLog,v 1.29 2012/08/02 18:15:40 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/httplib2/ChangeLog,v 1.30 2012/09/21 12:22:44 radhermit Exp $
+
+*httplib2-0.7.6 (21 Sep 2012)
+
+ 21 Sep 2012; Tim Harder <radhermit@gentoo.org> +httplib2-0.7.6.ebuild:
+ Version bump.
02 Aug 2012; Sébastien Fabbro <bicatali@gentoo.org> httplib2-0.7.4.ebuild:
Keyword amd64-linux and x86-linux
diff --git a/dev-python/httplib2/httplib2-0.7.6.ebuild b/dev-python/httplib2/httplib2-0.7.6.ebuild
new file mode 100644
index 000000000000..174a0beddcea
--- /dev/null
+++ b/dev-python/httplib2/httplib2-0.7.6.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/httplib2/httplib2-0.7.6.ebuild,v 1.1 2012/09/21 12:22:44 radhermit Exp $
+
+EAPI="4"
+PYTHON_DEPEND="2 3:3.2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.1"
+
+RESTRICT="test" # tests connect to random remote sites and exploderate badly
+
+inherit distutils
+
+DESCRIPTION="A comprehensive HTTP client library"
+HOMEPAGE="http://code.google.com/p/httplib2/ http://pypi.python.org/pypi/httplib2"
+SRC_URI="http://httplib2.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x64-macos ~x86-linux"
+IUSE=""
+
+src_test() {
+ testing() {
+ pushd "python$(python_get_version --major)" > /dev/null
+ "$(PYTHON)" httplib2test.py
+ popd > /dev/null
+ }
+ python_execute_function testing
+}