summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/matplotlib')
-rw-r--r--dev-python/matplotlib/ChangeLog7
-rw-r--r--dev-python/matplotlib/matplotlib-1.1.1.ebuild4
-rw-r--r--dev-python/matplotlib/matplotlib-1.2.0-r2.ebuild4
-rw-r--r--dev-python/matplotlib/matplotlib-1.2.1.ebuild4
-rw-r--r--dev-python/matplotlib/matplotlib-1.3.0.ebuild4
5 files changed, 14 insertions, 9 deletions
diff --git a/dev-python/matplotlib/ChangeLog b/dev-python/matplotlib/ChangeLog
index e36f73bbf9f2..09e780421a2c 100644
--- a/dev-python/matplotlib/ChangeLog
+++ b/dev-python/matplotlib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/matplotlib
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/ChangeLog,v 1.155 2013/09/05 18:46:20 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/ChangeLog,v 1.156 2013/09/12 22:29:33 mgorny Exp $
+
+ 12 Sep 2013; Michał Górny <mgorny@gentoo.org> matplotlib-1.1.1.ebuild,
+ matplotlib-1.2.0-r2.ebuild, matplotlib-1.2.1.ebuild, matplotlib-1.3.0.ebuild:
+ Replace virtual/pyparsing dep with dev-python/pyparsing. The split versions
+ were removed and all in-tree versions support all impls now.
05 Sep 2013; Michał Górny <mgorny@gentoo.org> matplotlib-1.2.0-r2.ebuild,
matplotlib-1.2.1.ebuild:
diff --git a/dev-python/matplotlib/matplotlib-1.1.1.ebuild b/dev-python/matplotlib/matplotlib-1.1.1.ebuild
index 1865627d6d41..e870facedf6d 100644
--- a/dev-python/matplotlib/matplotlib-1.1.1.ebuild
+++ b/dev-python/matplotlib/matplotlib-1.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-1.1.1.ebuild,v 1.9 2013/06/09 17:21:43 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-1.1.1.ebuild,v 1.10 2013/09/12 22:29:33 mgorny Exp $
EAPI="3"
@@ -58,7 +58,7 @@ DEPEND="${CDEPEND}
test? ( dev-python/nose )"
RDEPEND="${CDEPEND}
- virtual/pyparsing
+ dev-python/pyparsing
cairo? ( dev-python/pycairo )
excel? ( dev-python/xlwt )
fltk? ( dev-python/pyfltk )
diff --git a/dev-python/matplotlib/matplotlib-1.2.0-r2.ebuild b/dev-python/matplotlib/matplotlib-1.2.0-r2.ebuild
index 3b5669acef72..5c760b27a4b4 100644
--- a/dev-python/matplotlib/matplotlib-1.2.0-r2.ebuild
+++ b/dev-python/matplotlib/matplotlib-1.2.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-1.2.0-r2.ebuild,v 1.13 2013/09/05 18:46:20 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-1.2.0-r2.ebuild,v 1.14 2013/09/12 22:29:33 mgorny Exp $
EAPI=5
@@ -55,7 +55,7 @@ DEPEND="${COMMON_DEPEND}
test? ( dev-python/nose[${PYTHON_USEDEP}] )"
RDEPEND="${COMMON_DEPEND}
- virtual/pyparsing[${PYTHON_USEDEP}]
+ dev-python/pyparsing[${PYTHON_USEDEP}]
cairo? ( dev-python/pycairo[${PYTHON_USEDEP}] )
excel? ( dev-python/xlwt[${PY2_USEDEP}] )
fltk? ( dev-python/pyfltk[${PY2_USEDEP}] )
diff --git a/dev-python/matplotlib/matplotlib-1.2.1.ebuild b/dev-python/matplotlib/matplotlib-1.2.1.ebuild
index 9062a13386ae..1dad7acda0ad 100644
--- a/dev-python/matplotlib/matplotlib-1.2.1.ebuild
+++ b/dev-python/matplotlib/matplotlib-1.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-1.2.1.ebuild,v 1.5 2013/09/05 18:46:20 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-1.2.1.ebuild,v 1.6 2013/09/12 22:29:33 mgorny Exp $
EAPI=5
@@ -56,7 +56,7 @@ DEPEND="${COMMON_DEPEND}
test? ( dev-python/nose[${PYTHON_USEDEP}] )"
RDEPEND="${COMMON_DEPEND}
- virtual/pyparsing[${PYTHON_USEDEP}]
+ dev-python/pyparsing[${PYTHON_USEDEP}]
cairo? ( dev-python/pycairo[${PYTHON_USEDEP}] )
excel? ( dev-python/xlwt[${PY2_USEDEP}] )
fltk? ( dev-python/pyfltk[${PY2_USEDEP}] )
diff --git a/dev-python/matplotlib/matplotlib-1.3.0.ebuild b/dev-python/matplotlib/matplotlib-1.3.0.ebuild
index 4da2b7049c50..6080ecc49cad 100644
--- a/dev-python/matplotlib/matplotlib-1.3.0.ebuild
+++ b/dev-python/matplotlib/matplotlib-1.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-1.3.0.ebuild,v 1.2 2013/08/23 08:43:47 heroxbd Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-1.3.0.ebuild,v 1.3 2013/09/12 22:29:33 mgorny Exp $
EAPI=5
@@ -57,7 +57,7 @@ DEPEND="${COMMON_DEPEND}
test? ( dev-python/nose[${PYTHON_USEDEP}] )"
RDEPEND="${COMMON_DEPEND}
- virtual/pyparsing[${PYTHON_USEDEP}]
+ dev-python/pyparsing[${PYTHON_USEDEP}]
cairo? ( dev-python/pycairo[${PYTHON_USEDEP}] )
excel? ( dev-python/xlwt[${PY2_USEDEP}] )
fltk? ( dev-python/pyfltk[${PY2_USEDEP}] )