summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/nose/nose-0.10.3.ebuild')
-rw-r--r--dev-python/nose/nose-0.10.3.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/nose/nose-0.10.3.ebuild b/dev-python/nose/nose-0.10.3.ebuild
new file mode 100644
index 000000000000..26c0c8e0ed2a
--- /dev/null
+++ b/dev-python/nose/nose-0.10.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/nose/nose-0.10.3.ebuild,v 1.1 2008/06/25 10:26:21 hawking Exp $
+
+inherit distutils eutils
+
+DESCRIPTION="A unittest extension offering automatic test suite discovery and easy test authoring"
+HOMEPAGE="http://somethingaboutorange.com/mrl/projects/nose/"
+SRC_URI="http://somethingaboutorange.com/mrl/projects/nose/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+RDEPEND="dev-python/setuptools"
+DEPEND="${RDEPEND}
+ test? ( dev-python/twisted )"
+
+src_unpack() {
+ distutils_src_unpack
+
+ # Disable tests that access the network
+ epatch "${FILESDIR}/${PN}-0.10.0-tests-nonetwork.patch"
+}
+
+src_install() {
+ DOCS="AUTHORS"
+ distutils_src_install --install-data /usr/share
+
+ use doc && dohtml doc/*
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
+
+src_test() {
+ # Create the missing empty directory, that's required for tests to pass
+ if [[ ! -e "${S}"/functional_tests/support/empty ]]; then
+ mkdir "${S}"/functional_tests/support/empty
+ fi
+ PYTHONPATH=. "${python}" setup.py test || die "test failed"
+}