summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/bundler')
-rw-r--r--dev-ruby/bundler/ChangeLog5
-rw-r--r--dev-ruby/bundler/bundler-1.3.5.ebuild43
2 files changed, 4 insertions, 44 deletions
diff --git a/dev-ruby/bundler/ChangeLog b/dev-ruby/bundler/ChangeLog
index 488e9cc00e39..2f9347cf94db 100644
--- a/dev-ruby/bundler/ChangeLog
+++ b/dev-ruby/bundler/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ruby/bundler
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bundler/ChangeLog,v 1.74 2015/01/24 10:11:44 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bundler/ChangeLog,v 1.75 2015/01/24 10:34:02 graaff Exp $
+
+ 24 Jan 2015; Hans de Graaff <graaff@gentoo.org> -bundler-1.3.5.ebuild:
+ Cleanup vulnerable version for bug 523798.
24 Jan 2015; Agostino Sarubbo <ago@gentoo.org> bundler-1.7.3.ebuild:
Stable for x86, wrt bug #523798
diff --git a/dev-ruby/bundler/bundler-1.3.5.ebuild b/dev-ruby/bundler/bundler-1.3.5.ebuild
deleted file mode 100644
index ac6904c63bab..000000000000
--- a/dev-ruby/bundler/bundler-1.3.5.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bundler/bundler-1.3.5.ebuild,v 1.7 2014/08/15 17:03:27 armin76 Exp $
-
-EAPI=5
-
-# jruby → Many tests fail and test suite hangs.
-USE_RUBY="ruby19"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec"
-
-# No documentation task
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md ISSUES.md UPGRADING.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="An easy way to vendor gem dependencies"
-HOMEPAGE="http://github.com/carlhuda/bundler"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-ruby_add_rdepend virtual/rubygems
-
-ruby_add_bdepend "test? ( app-text/ronn )"
-
-RDEPEND+=" dev-vcs/git"
-DEPEND+=" test? ( dev-vcs/git )"
-
-all_ruby_prepare() {
- # Bundler only supports running the specs from git:
- # http://github.com/carlhuda/bundler/issues/issue/738
- sed -i -e '/when Bundler is bundled/,/^ end/ s:^:#:' spec/runtime/setup_spec.rb || die
-
- # Fails randomly and no clear cause can be found. Might be related
- # to bug 346357. This was broken in previous releases without a
- # failing spec, so patch out this spec for now since it is not a
- # regression.
- sed -i -e '/works when you bundle exec bundle/,/^ end/ s:^:#:' spec/install/deploy_spec.rb || die
-}