summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/celluloid')
-rw-r--r--dev-ruby/celluloid/ChangeLog10
-rw-r--r--dev-ruby/celluloid/celluloid-0.12.4.ebuild30
-rw-r--r--dev-ruby/celluloid/metadata.xml5
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-ruby/celluloid/ChangeLog b/dev-ruby/celluloid/ChangeLog
new file mode 100644
index 000000000000..b2d3a12de634
--- /dev/null
+++ b/dev-ruby/celluloid/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-ruby/celluloid
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/celluloid/ChangeLog,v 1.1 2012/12/14 07:08:56 graaff Exp $
+
+*celluloid-0.12.4 (14 Dec 2012)
+
+ 14 Dec 2012; Hans de Graaff <graaff@gentoo.org> +celluloid-0.12.4.ebuild,
+ +metadata.xml:
+ Initial import. New dependency for dev-ruby/adhearsion.
+
diff --git a/dev-ruby/celluloid/celluloid-0.12.4.ebuild b/dev-ruby/celluloid/celluloid-0.12.4.ebuild
new file mode 100644
index 000000000000..bec82b819144
--- /dev/null
+++ b/dev-ruby/celluloid/celluloid-0.12.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/celluloid/celluloid-0.12.4.ebuild,v 1.1 2012/12/14 07:08:56 graaff Exp $
+
+EAPI=5
+# rbx or jruby recommended, but only in 1.9 mode.
+USE_RUBY="ruby19"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Celluloid provides a simple and natural way to build fault-tolerant concurrent programs in Ruby"
+HOMEPAGE="https://github.com/celluloid/celluloid"
+SRC_URI="https://github.com/celluloid/celluloid/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+IUSE=""
+SLOT="0"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+
+ruby_add_rdepend ">=dev-ruby/facter-1.6.12
+ >=dev-ruby/timers-1.0.0"
+
+all_ruby_prepare() {
+ rm Gemfile .rspec || die
+}
diff --git a/dev-ruby/celluloid/metadata.xml b/dev-ruby/celluloid/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/celluloid/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>