summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/coderay')
-rw-r--r--dev-ruby/coderay/ChangeLog8
-rw-r--r--dev-ruby/coderay/coderay-1.0.0.ebuild43
-rw-r--r--dev-ruby/coderay/coderay-1.0.7.ebuild39
3 files changed, 6 insertions, 84 deletions
diff --git a/dev-ruby/coderay/ChangeLog b/dev-ruby/coderay/ChangeLog
index 4f37dc22bf2b..2e9b23796063 100644
--- a/dev-ruby/coderay/ChangeLog
+++ b/dev-ruby/coderay/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/coderay
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/coderay/ChangeLog,v 1.62 2012/11/07 03:33:57 jer Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/coderay/ChangeLog,v 1.63 2013/02/28 13:47:41 graaff Exp $
+
+ 28 Feb 2013; Hans de Graaff <graaff@gentoo.org> -coderay-1.0.0.ebuild,
+ -coderay-1.0.7.ebuild:
+ Cleanup.
07 Nov 2012; Jeroen Roovers <jer@gentoo.org> coderay-1.0.6.ebuild:
Stable for HPPA (bug #427594).
diff --git a/dev-ruby/coderay/coderay-1.0.0.ebuild b/dev-ruby/coderay/coderay-1.0.0.ebuild
deleted file mode 100644
index 778a97990d30..000000000000
--- a/dev-ruby/coderay/coderay-1.0.0.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/coderay/coderay-1.0.0.ebuild,v 1.3 2012/10/28 17:38:33 armin76 Exp $
-
-EAPI=4
-
-USE_RUBY="ruby18 ree18 ruby19 jruby"
-
-# The test target also contains test:exe but that requires
-# shoulda-context which we do not have packaged yet.
-RUBY_FAKEGEM_TASK_TEST="test:functional test:units"
-
-RUBY_FAKEGEM_TASK_DOC="doc"
-RUBY_FAKEGEM_DOCDIR="doc"
-
-RUBY_FAKEGEM_EXTRADOC="Changes-1.0.textile Changes.textile IDEA README.textile TODO"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A Ruby library for syntax highlighting."
-HOMEPAGE="http://coderay.rubychan.de/"
-SRC_URI="https://github.com/rubychan/coderay/tarball/v${PV} -> ${P}.tgz"
-
-RUBY_S="rubychan-coderay-*"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
-IUSE=""
-
-# Redcloth is optional but automagically tested, so we add this
-# dependency to ensure that we get at least a version that works: bug
-# 330621. We use this convoluted way because redcloth isn't available
-# yet for jruby.
-USE_RUBY="${USE_RUBY/jruby/}" ruby_add_bdepend "test? ( >=dev-ruby/redcloth-4.2.2 )"
-
-all_ruby_prepare() {
- # Don't run two tests that are known to break on jruby 1.5. We
- # should depend on jruby 1.6 to fix this, but only the tests are
- # broken. https://github.com/rubychan/coderay/issues/4
- sed -i -e '22,35d' test/unit/file_type.rb || die
- sed -i -e '48,61d' test/unit/plugin.rb || die
-}
diff --git a/dev-ruby/coderay/coderay-1.0.7.ebuild b/dev-ruby/coderay/coderay-1.0.7.ebuild
deleted file mode 100644
index fc7b1a7af8c7..000000000000
--- a/dev-ruby/coderay/coderay-1.0.7.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/coderay/coderay-1.0.7.ebuild,v 1.2 2012/10/28 17:38:33 armin76 Exp $
-
-EAPI=4
-
-USE_RUBY="ruby18 ree18 ruby19 jruby"
-
-# The test target also contains test:exe but that requires
-# shoulda-context which we do not have packaged yet.
-RUBY_FAKEGEM_TASK_TEST="test:functional test:units"
-
-RUBY_FAKEGEM_TASK_DOC="doc"
-RUBY_FAKEGEM_DOCDIR="doc"
-
-RUBY_FAKEGEM_EXTRADOC="Changes-pre-1.0.textile Changes.textile FOLDERS README_INDEX.rdoc README.textile"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A Ruby library for syntax highlighting."
-HOMEPAGE="http://coderay.rubychan.de/"
-SRC_URI="https://github.com/rubychan/coderay/tarball/v${PV} -> ${P}.tgz"
-
-RUBY_S="rubychan-coderay-*"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-# Redcloth is optional but automagically tested, so we add this
-# dependency to ensure that we get at least a version that works: bug
-# 330621. We use this convoluted way because redcloth isn't available
-# yet for jruby.
-USE_RUBY="${USE_RUBY/jruby/}" ruby_add_bdepend "test? ( >=dev-ruby/redcloth-4.2.2 )"
-
-all_ruby_prepare() {
- sed -i -e '/git ls-files/ s:^:#:' coderay.gemspec || die
-}