summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/minitest')
-rw-r--r--dev-ruby/minitest/ChangeLog6
-rw-r--r--dev-ruby/minitest/minitest-5.0.6.ebuild10
2 files changed, 7 insertions, 9 deletions
diff --git a/dev-ruby/minitest/ChangeLog b/dev-ruby/minitest/ChangeLog
index 7f2d1bbb3b33..640dd1b91954 100644
--- a/dev-ruby/minitest/ChangeLog
+++ b/dev-ruby/minitest/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/minitest
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/minitest/ChangeLog,v 1.124 2013/07/02 07:42:35 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/minitest/ChangeLog,v 1.125 2013/07/17 06:41:49 graaff Exp $
+
+ 17 Jul 2013; Hans de Graaff <graaff@gentoo.org> minitest-5.0.6.ebuild:
+ Drop ruby18 blocker since the problem cannot be reproduced. Add missing hoe
+ dependency for FEATURES=test.
02 Jul 2013; Agostino Sarubbo <ago@gentoo.org> minitest-4.7.4.ebuild:
Stable for sh, wrt bug #472904
diff --git a/dev-ruby/minitest/minitest-5.0.6.ebuild b/dev-ruby/minitest/minitest-5.0.6.ebuild
index 88a2b429d19b..9e39d46d57c4 100644
--- a/dev-ruby/minitest/minitest-5.0.6.ebuild
+++ b/dev-ruby/minitest/minitest-5.0.6.ebuild
@@ -1,13 +1,10 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/minitest/minitest-5.0.6.ebuild,v 1.1 2013/06/29 08:19:23 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/minitest/minitest-5.0.6.ebuild,v 1.2 2013/07/17 06:41:49 graaff Exp $
EAPI=5
USE_RUBY="ruby18 ruby19 jruby"
-# Rake is the easiest way to go through this unfortunately.
-RUBY_FAKEGEM_RECIPE_TEST="rake"
-
RUBY_FAKEGEM_TASK_DOC="docs"
RUBY_FAKEGEM_DOCDIR="doc"
@@ -25,10 +22,7 @@ IUSE="doc test"
ruby_add_bdepend "
doc? ( dev-ruby/hoe dev-ruby/rdoc )
- ruby_targets_ruby18? ( !!dev-ruby/minitest[ruby_targets_ruby18] )"
-
-# There is a nasty bug that tests fail if minitest is loaded already
-# from the system.
+ test? ( dev-ruby/hoe )"
each_ruby_prepare() {
case ${RUBY} in