summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/confix/ChangeLog13
-rw-r--r--dev-util/confix/confix-2.1.0-r4.ebuild (renamed from dev-util/confix/confix-2.1.0-r3.ebuild)31
-rw-r--r--dev-util/confix/confix-2.3.0-r3.ebuild76
-rw-r--r--dev-util/confix/confix-9999.ebuild6
-rw-r--r--dev-util/confix/files/2.1.0/local-libs-first.patch38
-rw-r--r--dev-util/confix/files/2.3.0/exeext.patch (renamed from dev-util/confix/files/2.2.0/exeext.patch)0
-rw-r--r--dev-util/confix/files/2.3.0/ext-ac-archive.patch (renamed from dev-util/confix/files/2.2.0/ext-ac-archive.patch)0
-rw-r--r--dev-util/confix/files/2.3.0/local-libs-first.patch39
-rw-r--r--dev-util/confix/files/2.3.0/new-automake.patch12
9 files changed, 208 insertions, 7 deletions
diff --git a/dev-util/confix/ChangeLog b/dev-util/confix/ChangeLog
index 3d210e89a675..7dce2b1bec9e 100644
--- a/dev-util/confix/ChangeLog
+++ b/dev-util/confix/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for dev-util/confix
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/confix/ChangeLog,v 1.12 2010/02/08 08:56:51 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/confix/ChangeLog,v 1.13 2010/07/13 11:57:23 mduft Exp $
+
+*confix-2.3.0-r3 (13 Jul 2010)
+*confix-2.1.0-r4 (13 Jul 2010)
+
+ 13 Jul 2010; Markus Duft <mduft@gentoo.org>
+ +files/2.1.0/local-libs-first.patch, -files/2.2.0/exeext.patch,
+ -files/2.2.0/ext-ac-archive.patch, +files/2.3.0/exeext.patch,
+ +files/2.3.0/ext-ac-archive.patch, +files/2.3.0/local-libs-first.patch,
+ +files/2.3.0/new-automake.patch, -confix-2.1.0-r3.ebuild,
+ +confix-2.1.0-r4.ebuild, +confix-2.3.0-r3.ebuild, confix-9999.ebuild:
+ applied changes from private overlay. added new confix-2.3.0
08 Feb 2010; Peter Volkov <pva@gentoo.org> confix-2.1.0.ebuild,
confix-2.1.0-r3.ebuild, confix-9999.ebuild:
diff --git a/dev-util/confix/confix-2.1.0-r3.ebuild b/dev-util/confix/confix-2.1.0-r4.ebuild
index b4637a6ab281..54b36a60b3b7 100644
--- a/dev-util/confix/confix-2.1.0-r3.ebuild
+++ b/dev-util/confix/confix-2.1.0-r4.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/confix/confix-2.1.0-r3.ebuild,v 1.4 2010/02/08 08:56:51 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/confix/confix-2.1.0-r4.ebuild,v 1.1 2010/07/13 11:57:23 mduft Exp $
-inherit eutils distutils
+inherit distutils
DESCRIPTION="Confix: A Build Tool on Top of GNU Automake"
HOMEPAGE="http://confix.sourceforge.net"
@@ -10,7 +10,7 @@ SRC_URI="mirror://sourceforge/confix/Confix-${PV}.tar.bz2"
LICENSE="GPL-2"
SLOT="2"
-KEYWORDS="~amd64 ~x86 ~ppc-aix ~ia64-hpux ~x86-interix ~x86-linux ~sparc-solaris ~x86-solaris"
+KEYWORDS="~amd64 ~x86 ~ppc-aix ~hppa-hpux ~ia64-hpux ~x86-interix ~x86-linux ~sparc-solaris ~x86-solaris"
IUSE=""
DEPEND="dev-lang/python"
@@ -40,6 +40,8 @@ src_unpack() {
epatch "${FILESDIR}"/${PV}/private-headers.patch
# enable fast installation rules.
epatch "${FILESDIR}"/${PV}/fast-install.patch
+ # link local libraries first.
+ epatch "${FILESDIR}"/${PV}/local-libs-first.patch
# need to store repos in exact versioned share/confix-PV/repo
sed -i -e "s,'confix2','confix-${PV}'," \
@@ -52,3 +54,26 @@ src_unpack() {
libconfix/core/utils/const.py \
|| die "cannot adjust confix version"
}
+
+pkg_preinst() {
+ if has_version '<dev-util/confix-2.1.0-r03.1'; then
+ einfo "After upgrading to ${P} you likely want to remerge all packages built"
+ einfo "with <dev-util/confix-2.1.0-r03.1 in your EPREFIX to fix a bug in"
+ einfo "libtool's la-files created using the old ${PN}."
+ ewarn
+ ewarn "Use this command (copy&paste) to identify packages built with <confix-2.1.0-r3"
+ ewarn "needing a remerge in your particular instance of Gentoo Prefix:"
+ ewarn
+ # use 'echo' to get this command from here:
+ ewarn "( cd \$(portageq envvar EPREFIX)/var/db/pkg || exit 1;" \
+ "pattern=\$(cd ../../.. && echo \$(grep -l" \
+ "'/portage/[^/]*/[^/]*/work/' usr/lib/lib*.la)" \
+ "| sed -e 's, ,|,g'); if [[ -z \${pattern} ]]; then" \
+ "echo 'No more packages were built with broken Confix.'; exit 0; fi;" \
+ "emerge --ask --oneshot \$(grep -lE \"(\${pattern})\"" \
+ "*/*/CONTENTS | xargs grep -l usr/share/confix-2.1.0/repo" \
+ "| sed -e 's,^,=,;s,/CONTENTS,,')" \
+ ")"
+ ewarn
+ fi
+}
diff --git a/dev-util/confix/confix-2.3.0-r3.ebuild b/dev-util/confix/confix-2.3.0-r3.ebuild
new file mode 100644
index 000000000000..41f44e1a71ef
--- /dev/null
+++ b/dev-util/confix/confix-2.3.0-r3.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/confix/confix-2.3.0-r3.ebuild,v 1.1 2010/07/13 11:57:23 mduft Exp $
+
+inherit distutils
+
+DESCRIPTION="Confix: A Build Tool on Top of GNU Automake"
+HOMEPAGE="http://confix.sourceforge.net"
+SRC_URI="mirror://sourceforge/confix/Confix-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~amd64 ~x86 ~ppc-aix ~hppa-hpux ~ia64-hpux ~x86-interix ~x86-linux ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="dev-lang/python"
+RDEPEND="${DEPEND}
+ sys-devel/automake
+ sys-devel/libtool
+ sys-devel/autoconf-archive
+ dev-util/confix-wrapper
+"
+
+S="${WORKDIR}/Confix-${PV}"
+PYTHON_MODNAME="libconfix tests"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # find jni-include dirs on hpux.
+ epatch "${FILESDIR}"/2.1.0/jni-hpux.patch
+ # add .exe extension to TESTS
+ epatch "${FILESDIR}"/${PV}/exeext.patch
+ # use external autoconf archive
+ epatch "${FILESDIR}"/${PV}/ext-ac-archive.patch
+ # link local libraries first.
+ epatch "${FILESDIR}"/${PV}/local-libs-first.patch
+ # don't use automake 1.9, but any newer too...
+ epatch "${FILESDIR}"/${PV}/new-automake.patch
+
+ # need to store repos in exact versioned share/confix-PV/repo
+ sed -i -e "s,\<confix2\>,confix-${PV}," \
+ libconfix/plugins/automake/repo_automake.py \
+ libconfix/core/machinery/repo.py \
+ || die "cannot adjust repo dir"
+ # libconfix/plugins/cmake/consts.py \
+
+ # adjust version-printing to have same version as share/confix-PV/repo,
+ # to ease revdep-rebuild-alike scripts for rebuilding confix-packages.
+ sed -i -e "/^CONFIX_VERSION[ ]*=/s,.*,CONFIX_VERSION = '${PV}'," \
+ libconfix/core/utils/const.py \
+ || die "cannot adjust confix version"
+}
+
+pkg_preinst() {
+ if has_version "<dev-util/confix-${PV}"; then
+ einfo "After merging ${P} you might have to remerge all packages built"
+ einfo "with !=dev-util/confix-${PV}* in your EPREFIX to get all the"
+ einfo "repo files useable with current ${PN}".
+ ewarn
+ ewarn "Use this command (copy&paste) to identify packages built with confix"
+ ewarn "needing a remerge in your particular instance of Gentoo Prefix:"
+ ewarn
+ # use 'echo' to get this command from here:
+ ewarn "( cd \$(portageq envvar EPREFIX)/var/db/pkg || exit 1;" \
+ "pattern=\$(cd ../../.. && echo \$(ls -d" \
+ "usr/share/confix*/repo | grep -v confix-${PV}) |" \
+ "sed -e 's, ,|,g'); if [[ -z \${pattern} ]]; then echo" \
+ "'No more packages were built with broken Confix.'; exit 0;" \
+ "fi; emerge --ask --oneshot \$(grep -lE \"(\${pattern})\"" \
+ "*/*/CONTENTS | sed -e 's,^,=,;s,/CONTENTS,,')" \
+ ")"
+ ewarn
+ fi
+}
diff --git a/dev-util/confix/confix-9999.ebuild b/dev-util/confix/confix-9999.ebuild
index 9a271355ca95..ad9a40ec151e 100644
--- a/dev-util/confix/confix-9999.ebuild
+++ b/dev-util/confix/confix-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/confix/confix-9999.ebuild,v 1.3 2010/02/08 08:56:51 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/confix/confix-9999.ebuild,v 1.4 2010/07/13 11:57:23 mduft Exp $
EAPI=2
@@ -34,9 +34,9 @@ src_prepare() {
# does not apply to trunk anymore
# epatch "${FILESDIR}"/2.1.0/CALL_RESCAN_HACK.patch
# add .exe extension to TESTS
- epatch "${FILESDIR}"/2.2.0/exeext.patch
+ epatch "${FILESDIR}"/2.3.0/exeext.patch
# use external autoconf archive
- epatch "${FILESDIR}"/2.2.0/ext-ac-archive.patch
+ epatch "${FILESDIR}"/2.3.0/ext-ac-archive.patch
# enable SET_FILE_PROPERTIES(file, { 'PRIVATE_CINCLUDE', 1 })
# does not apply to trunk anymore
# epatch "${FILESDIR}"/2.1.0/private-headers.patch
diff --git a/dev-util/confix/files/2.1.0/local-libs-first.patch b/dev-util/confix/files/2.1.0/local-libs-first.patch
new file mode 100644
index 000000000000..26f9c754dde5
--- /dev/null
+++ b/dev-util/confix/files/2.1.0/local-libs-first.patch
@@ -0,0 +1,38 @@
+With libtool, link local libraries with /path/to/libfile.la instead of libpath,
+to avoid encoding local libpath into installed la-file.
+These also have to be linked first, to avoid finding already installed
+libraries of previous versions during libtool-relink.
+--- libconfix/plugins/c/linked.py.orig 2010-06-25 11:30:40.885595798 +0200
++++ libconfix/plugins/c/linked.py 2010-06-25 11:31:07.055184455 +0200
+@@ -128,6 +128,8 @@
+ pass
+
+ def get_linkline(self):
++ local_paths = []
++ local_libraries = []
+ native_paths = []
+ native_libraries = []
+ external_linkline = []
+@@ -150,8 +152,11 @@
+
+ for bi in native_libs_to_use:
+ if isinstance(bi, BuildInfo_CLibrary_NativeLocal):
+- native_paths.append('-L'+'/'.join(['$(top_builddir)']+bi.dir()))
+- native_libraries.append('-l'+bi.name())
++ if self.__use_libtool:
++ local_libraries.append('/'.join(['$(top_builddir)']+bi.dir()+['lib'+bi.name()+'.la']))
++ else:
++ local_paths.append('-L'+'/'.join(['$(top_builddir)']+bi.dir()))
++ local_libraries.append('-l'+bi.name())
+ continue
+ if isinstance(bi, BuildInfo_CLibrary_NativeInstalled):
+ using_installed_library = True
+@@ -173,7 +178,7 @@
+ external_linkline.extend(elem)
+ pass
+
+- return native_paths + native_libraries + external_linkline
++ return local_paths + local_libraries + native_paths + native_libraries + external_linkline
+
+ def __init_buildinfo(self):
+ self.__buildinfo_direct_dependent_native_libs = []
diff --git a/dev-util/confix/files/2.2.0/exeext.patch b/dev-util/confix/files/2.3.0/exeext.patch
index 98576f5c9f8b..98576f5c9f8b 100644
--- a/dev-util/confix/files/2.2.0/exeext.patch
+++ b/dev-util/confix/files/2.3.0/exeext.patch
diff --git a/dev-util/confix/files/2.2.0/ext-ac-archive.patch b/dev-util/confix/files/2.3.0/ext-ac-archive.patch
index 32122c95bfe2..32122c95bfe2 100644
--- a/dev-util/confix/files/2.2.0/ext-ac-archive.patch
+++ b/dev-util/confix/files/2.3.0/ext-ac-archive.patch
diff --git a/dev-util/confix/files/2.3.0/local-libs-first.patch b/dev-util/confix/files/2.3.0/local-libs-first.patch
new file mode 100644
index 000000000000..29d4a7a1cc9d
--- /dev/null
+++ b/dev-util/confix/files/2.3.0/local-libs-first.patch
@@ -0,0 +1,39 @@
+With libtool, link local libraries with /path/to/libfile.la instead of libpath,
+to avoid encoding local libpath into installed la-file.
+These also have to be linked first, to avoid finding already installed
+libraries of previous versions during libtool-relink.
+diff -ru Confix-2.3.0.orig/libconfix/plugins/automake/c/out_c.py Confix-2.3.0/libconfix/plugins/automake/c/out_c.py
+--- Confix-2.3.0.orig/libconfix/plugins/automake/c/out_c.py 2010-07-06 12:55:59.286540943 +0200
++++ Confix-2.3.0/libconfix/plugins/automake/c/out_c.py 2010-07-06 13:01:23.574428852 +0200
+@@ -411,6 +411,8 @@
+ """
+ assert isinstance(linked_builder, LinkedBuilder)
+
++ local_paths = []
++ local_libraries = []
+ native_paths = []
+ native_libraries = []
+ external_linkline = []
+@@ -424,8 +426,11 @@
+
+ for bi in native_libs_to_use:
+ if isinstance(bi, BuildInfo_CLibrary_NativeLocal):
+- native_paths.append('-L'+'/'.join(['$(top_builddir)']+bi.dir()))
+- native_libraries.append('-l'+bi.basename())
++ if self.__use_libtool:
++ local_libraries.append('/'.join(['$(top_builddir)']+bi.dir()+['lib'+bi.basename()+'.la']))
++ else:
++ local_paths.append('-L'+'/'.join(['$(top_builddir)']+bi.dir()))
++ local_libraries.append('-l'+bi.basename())
+ continue
+ if isinstance(bi, BuildInfo_CLibrary_NativeInstalled):
+ using_installed_library = True
+@@ -447,7 +452,7 @@
+ external_linkline.extend(elem)
+ pass
+
+- return native_paths + native_libraries + external_linkline
++ return local_paths + local_libraries + native_paths + native_libraries + external_linkline
+
+ def external_libpath(self):
+ """ For unit tests only. """
diff --git a/dev-util/confix/files/2.3.0/new-automake.patch b/dev-util/confix/files/2.3.0/new-automake.patch
new file mode 100644
index 000000000000..d6f24a4cae81
--- /dev/null
+++ b/dev-util/confix/files/2.3.0/new-automake.patch
@@ -0,0 +1,12 @@
+diff -ru Confix-2.3.0.orig/libconfix/plugins/automake/out_automake.py Confix-2.3.0/libconfix/plugins/automake/out_automake.py
+--- Confix-2.3.0.orig/libconfix/plugins/automake/out_automake.py 2010-07-12 13:15:49.254867387 +0200
++++ Confix-2.3.0/libconfix/plugins/automake/out_automake.py 2010-07-12 13:17:29.755908602 +0200
+@@ -170,7 +170,7 @@
+
+
+ # our minimum required automake version is 1.9
+- self.makefile_am().add_automake_options('1.9')
++ # self.makefile_am().add_automake_options('1.9')
+
+
+ # enable dist'ing in the following formats