summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/mercurial')
-rw-r--r--dev-vcs/mercurial/ChangeLog6
-rw-r--r--dev-vcs/mercurial/mercurial-2.4.1-r2.ebuild12
-rw-r--r--dev-vcs/mercurial/mercurial-9999.ebuild13
3 files changed, 19 insertions, 12 deletions
diff --git a/dev-vcs/mercurial/ChangeLog b/dev-vcs/mercurial/ChangeLog
index f75584c8b3f1..72a9adbdd30f 100644
--- a/dev-vcs/mercurial/ChangeLog
+++ b/dev-vcs/mercurial/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-vcs/mercurial
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/mercurial/ChangeLog,v 1.95 2012/12/31 07:52:12 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/mercurial/ChangeLog,v 1.96 2012/12/31 08:11:55 djc Exp $
+
+ 31 Dec 2012; Dirkjan Ochtman <djc@gentoo.org> mercurial-2.4.1-r2.ebuild,
+ mercurial-9999.ebuild:
+ Synchronize ebuilds some more.
*mercurial-2.4.1-r2 (31 Dec 2012)
diff --git a/dev-vcs/mercurial/mercurial-2.4.1-r2.ebuild b/dev-vcs/mercurial/mercurial-2.4.1-r2.ebuild
index ff02ac832885..f21be40a6cfb 100644
--- a/dev-vcs/mercurial/mercurial-2.4.1-r2.ebuild
+++ b/dev-vcs/mercurial/mercurial-2.4.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/mercurial/mercurial-2.4.1-r2.ebuild,v 1.1 2012/12/31 07:52:12 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/mercurial/mercurial-2.4.1-r2.ebuild,v 1.2 2012/12/31 08:11:55 djc Exp $
EAPI=3
PYTHON_DEPEND="2"
@@ -104,18 +104,18 @@ src_test() {
rm -rf *svn* || die # Subversion tests fail with 1.5
rm -f test-archive || die # Fails due to verbose tar output changes
rm -f test-convert-baz* || die # GNU Arch baz
- rm -f test-convert-cvs* || die # CVS
+ rm -f test-convert-cvs* || die # CVS
rm -f test-convert-darcs* || die # Darcs
rm -f test-convert-git* || die # git
- rm -f test-convert-mtn* || die # monotone
- rm -f test-convert-tla* || die # GNU Arch tla
+ rm -f test-convert-mtn* || die # monotone
+ rm -f test-convert-tla* || die # GNU Arch tla
rm -f test-doctest* || die # doctest always fails with python 2.5.x
if [[ ${EUID} -eq 0 ]]; then
einfo "Removing tests which require user privileges to succeed"
rm -f test-command-template || die # Test is broken when run as root
rm -f test-convert || die # Test is broken when run as root
- rm -f test-lock-badness || die # Test is broken when run as root
- rm -f test-permissions || die # Test is broken when run as root
+ rm -f test-lock-badness || die # Test is broken when run as root
+ rm -f test-permissions || die # Test is broken when run as root
rm -f test-pull-permission || die # Test is broken when run as root
rm -f test-clone-failure || die
rm -f test-journal-exists || die
diff --git a/dev-vcs/mercurial/mercurial-9999.ebuild b/dev-vcs/mercurial/mercurial-9999.ebuild
index 376808750b4d..a0b01a745a16 100644
--- a/dev-vcs/mercurial/mercurial-9999.ebuild
+++ b/dev-vcs/mercurial/mercurial-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/mercurial/mercurial-9999.ebuild,v 1.14 2012/12/30 15:46:31 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/mercurial/mercurial-9999.ebuild,v 1.15 2012/12/31 08:11:55 djc Exp $
EAPI=3
PYTHON_DEPEND="2"
@@ -17,7 +17,7 @@ EHG_REPO_URI="http://selenic.com/repo/hg"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE="bugzilla emacs gpg test tk zsh-completion"
+IUSE="bugzilla doc emacs gpg test tk zsh-completion"
RDEPEND="bugzilla? ( dev-python/mysql-python )
gpg? ( app-crypt/gnupg )
@@ -27,7 +27,8 @@ RDEPEND="bugzilla? ( dev-python/mysql-python )
DEPEND="emacs? ( virtual/emacs )
test? ( app-arch/unzip
dev-python/pygments )
- app-text/asciidoc"
+ doc? ( app-text/asciidoc
+ dev-python/docutils )"
PYTHON_CFLAGS=(
"2.* + -fno-strict-aliasing"
@@ -39,7 +40,6 @@ SITEFILE="70${PN}-gentoo.el"
src_prepare() {
distutils_src_prepare
-
# fix up logic that won't work in Gentoo Prefix (also won't outside in
# certain cases), bug #362891
sed -i -e 's:xcodebuild:nocodebuild:' setup.py || die
@@ -48,13 +48,16 @@ src_prepare() {
src_compile() {
distutils_src_compile
+ if use doc; then
+ make doc || die
+ fi
+
if use emacs; then
cd "${S}"/contrib || die
elisp-compile mercurial.el || die "elisp-compile failed!"
fi
rm -rf contrib/{win32,macosx} || die
- make doc || die
}
src_install() {