summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-action/slune')
-rw-r--r--games-action/slune/ChangeLog5
-rw-r--r--games-action/slune/slune-1.0.15-r1.ebuild9
2 files changed, 10 insertions, 4 deletions
diff --git a/games-action/slune/ChangeLog b/games-action/slune/ChangeLog
index 50b2b2498b21..3ef3d5338154 100644
--- a/games-action/slune/ChangeLog
+++ b/games-action/slune/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-action/slune
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/slune/ChangeLog,v 1.21 2013/01/11 18:51:15 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/slune/ChangeLog,v 1.22 2013/01/12 15:36:03 hasufell Exp $
+
+ 12 Jan 2013; Julian Ospald <hasufell@gentoo.org> slune-1.0.15-r1.ebuild:
+ remove inherit magic and call functions explicitly
11 Jan 2013; Julian Ospald <hasufell@gentoo.org> slune-1.0.15-r1.ebuild:
inherit eutils explicitly
diff --git a/games-action/slune/slune-1.0.15-r1.ebuild b/games-action/slune/slune-1.0.15-r1.ebuild
index 1e37057d68b0..928b63cfb6d6 100644
--- a/games-action/slune/slune-1.0.15-r1.ebuild
+++ b/games-action/slune/slune-1.0.15-r1.ebuild
@@ -1,13 +1,12 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/slune/slune-1.0.15-r1.ebuild,v 1.2 2013/01/11 18:51:15 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/slune/slune-1.0.15-r1.ebuild,v 1.3 2013/01/12 15:36:03 hasufell Exp $
EAPI=5
PYTHON_COMPAT=( python2_5 python2_6 python2_7 )
-# inherit base explicitly to avoid overrides on distutils-r1
-inherit base eutils gnome2-utils python-utils-r1 distutils-r1 games
+inherit gnome2-utils python-utils-r1 distutils-r1 games
DESCRIPTION="A 3D action game with multiplayer mode and amazing graphics"
HOMEPAGE="http://oomadness.tuxfamily.org/en/slune/"
@@ -42,6 +41,10 @@ python_install() {
done
}
+src_prepare() {
+ distutils-r1_src_prepare
+}
+
src_compile() {
distutils-r1_src_compile
}