summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-board/pysolfc/pysolfc-2.0.ebuild')
-rw-r--r--games-board/pysolfc/pysolfc-2.0.ebuild14
1 files changed, 6 insertions, 8 deletions
diff --git a/games-board/pysolfc/pysolfc-2.0.ebuild b/games-board/pysolfc/pysolfc-2.0.ebuild
index e25801a87633..f096772f4640 100644
--- a/games-board/pysolfc/pysolfc-2.0.ebuild
+++ b/games-board/pysolfc/pysolfc-2.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/pysolfc/pysolfc-2.0.ebuild,v 1.6 2010/05/31 18:12:51 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/pysolfc/pysolfc-2.0.ebuild,v 1.7 2011/04/06 20:01:31 arfrever Exp $
-EAPI=2
+EAPI=3
PYTHON_USE_WITH="tk"
PYTHON_DEPEND="2:2.6"
@@ -28,6 +28,8 @@ RDEPEND="sound? ( dev-python/pygame )
!minimal? ( dev-python/imaging[tk]
dev-tcltk/tktable )"
+PYTHON_MODNAME="pysollib"
+
pkg_setup() {
python_set_active_version 2
python_pkg_setup
@@ -73,9 +75,5 @@ src_install() {
pkg_postinst() {
games_pkg_postinst
- python_mod_optimize $(python_get_sitedir)/pysollib
-}
-
-pkg_postrm() {
- python_mod_cleanup $(python_get_sitedir)/pysollib
+ distutils_pkg_postinst
}