summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle/kiki')
-rw-r--r--games-puzzle/kiki/ChangeLog8
-rw-r--r--games-puzzle/kiki/files/digest-kiki-1.0.2-r23
-rw-r--r--games-puzzle/kiki/kiki-1.0.2-r2.ebuild70
3 files changed, 80 insertions, 1 deletions
diff --git a/games-puzzle/kiki/ChangeLog b/games-puzzle/kiki/ChangeLog
index ac221f9513b6..915337c9c3e8 100644
--- a/games-puzzle/kiki/ChangeLog
+++ b/games-puzzle/kiki/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-puzzle/kiki
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/kiki/ChangeLog,v 1.11 2006/07/07 17:28:12 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/kiki/ChangeLog,v 1.12 2006/11/13 12:16:37 nyhm Exp $
+
+*kiki-1.0.2-r2 (13 Nov 2006)
+
+ 13 Nov 2006; Tristan Heaven <nyhm@gentoo.org> -kiki-1.0.2-r1.ebuild,
+ +kiki-1.0.2-r2.ebuild:
+ Fix for new swig versions, bug #139570 by onur@pardus.org.tr
*kiki-1.0.2-r1 (07 Jul 2006)
diff --git a/games-puzzle/kiki/files/digest-kiki-1.0.2-r2 b/games-puzzle/kiki/files/digest-kiki-1.0.2-r2
new file mode 100644
index 000000000000..1162d1e6a149
--- /dev/null
+++ b/games-puzzle/kiki/files/digest-kiki-1.0.2-r2
@@ -0,0 +1,3 @@
+MD5 eb4966eae85d3a073aab521bf1ba33e2 kiki-1.0.2-src.tgz 3366523
+RMD160 78e71cae75f7d6957d06fb8c7323d607bc232499 kiki-1.0.2-src.tgz 3366523
+SHA256 7651f57543ce61c22bcc01daf6a68e0ab31ba353f9b2fbc067e323bbba6e1246 kiki-1.0.2-src.tgz 3366523
diff --git a/games-puzzle/kiki/kiki-1.0.2-r2.ebuild b/games-puzzle/kiki/kiki-1.0.2-r2.ebuild
new file mode 100644
index 000000000000..decd9be97833
--- /dev/null
+++ b/games-puzzle/kiki/kiki-1.0.2-r2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/kiki/kiki-1.0.2-r2.ebuild,v 1.1 2006/11/13 12:16:37 nyhm Exp $
+
+inherit eutils python toolchain-funcs games
+
+DESCRIPTION="Fun 3D puzzle game using SDL/OpenGL"
+HOMEPAGE="http://kiki.sourceforge.net/"
+SRC_URI="mirror://sourceforge/kiki/${P}-src.tgz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="ppc x86"
+IUSE=""
+
+DEPEND=">=media-libs/libsdl-1.2
+ >=media-libs/sdl-image-1.2.2
+ >=media-libs/sdl-mixer-1.2.5
+ >=dev-lang/python-2.2
+ dev-lang/swig
+ virtual/glut"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch \
+ "${FILESDIR}/${P}"-gcc41.patch \
+ "${FILESDIR}/${P}"-freeglut.patch
+ # There are CVS directories in the tgz file
+ rm -rf $(find -name CVS -type d)
+ rm -rf $(find -name .cvsignore)
+
+ # Change the hard-coded data dir for sounds, etc...
+ sed -i \
+ -e "s:kiki_home += \"/\";:kiki_home = \"${GAMES_DATADIR}/${PN}/\";:g" \
+ -e "s:KConsole\:\:printf(\"WARNING \:\: environment variable KIKI_HOME not set ...\");::g" \
+ -e "s:KConsole\:\:printf(\" ... assuming resources in current directory\");::g" \
+ src/main/KikiController.cpp \
+ || die "sed KikiController.cpp failed"
+ python_version
+ sed -i \
+ -e "/^PYTHON_VERSION/s/2.3/${PYVER}/" \
+ -e '/lib-dynload/d' \
+ -e '/^PYTHONLIBS/s:\\:-lpython$(PYTHON_VERSION):' \
+ linux/Makefile \
+ || die "sed kiki_src/kiki/linux/Makefile failed"
+
+ # Bug 139570
+ cd SWIG
+ swig -c++ -python -globals kiki -o KikiPy_wrap.cpp KikiPy.i || die
+ cp -f kiki.py ../py
+}
+
+src_compile() {
+ tc-export AR CXX
+ emake -C kodilib/linux || die "emake in kodilib/linux failed"
+ emake -C linux || die "emake in linux failed"
+}
+
+src_install() {
+ dogamesbin linux/kiki || die "dogamesbin failed"
+
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r py sound || die "doins failed"
+
+ dodoc Readme.txt Thanks.txt
+ prepgamesdirs
+}