summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/wesnoth/ChangeLog7
-rw-r--r--games-strategy/wesnoth/Manifest2
-rw-r--r--games-strategy/wesnoth/files/digest-wesnoth-0.7.11
-rw-r--r--games-strategy/wesnoth/wesnoth-0.7.1.ebuild37
4 files changed, 46 insertions, 1 deletions
diff --git a/games-strategy/wesnoth/ChangeLog b/games-strategy/wesnoth/ChangeLog
index dda4fa121e73..3b3ad4dc37fc 100644
--- a/games-strategy/wesnoth/ChangeLog
+++ b/games-strategy/wesnoth/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-strategy/wesnoth
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.16 2004/03/20 03:40:47 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.17 2004/04/03 23:49:02 mr_bones_ Exp $
+
+*wesnoth-0.7.1 (03 Apr 2004)
+
+ 03 Apr 2004; Michael Sterrett <mr_bones_@gentoo.org> wesnoth-0.7.1.ebuild:
+ version bump
*wesnoth-0.7 (19 Mar 2004)
diff --git a/games-strategy/wesnoth/Manifest b/games-strategy/wesnoth/Manifest
index 8a683877597c..3bffa2f1c612 100644
--- a/games-strategy/wesnoth/Manifest
+++ b/games-strategy/wesnoth/Manifest
@@ -2,12 +2,14 @@ MD5 4e2b8d7f20404e2ec067f052d1142fba wesnoth-0.7.ebuild 955
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
MD5 56a6deba85e9178873a7755a7135bf98 ChangeLog 2279
MD5 b26bbbee93ba1b50ca87bdb627c3b3c9 wesnoth-0.6.99.5.ebuild 960
+MD5 4e2b8d7f20404e2ec067f052d1142fba wesnoth-0.7.1.ebuild 955
MD5 f5d5b6d1503a3ba1e0b070681ad7b902 wesnoth-0.6.99.1.ebuild 918
MD5 d341487bf607c02fa430fb1650f842dd wesnoth-0.6.99.2.ebuild 918
MD5 4c49a75ccb2f8d4606b13c6c88812d7c wesnoth-0.6.99.3.ebuild 918
MD5 b82d58a7626460ee0968b43ff5ee2296 wesnoth-0.6.99.4.ebuild 918
MD5 2218dd653ddf591503d9bde5beb4df8c files/digest-wesnoth-0.7 65
MD5 13caea64fa182268adcdf9fca0bd7c1c files/digest-wesnoth-0.6.99.5 70
+MD5 eed8758f69d700eedc02234ae1a428d8 files/digest-wesnoth-0.7.1 67
MD5 54b74b28b80b25f584a88dfdb4e1762d files/digest-wesnoth-0.6.99.1 70
MD5 e966635a1c1ba1490da3e026499af97f files/digest-wesnoth-0.6.99.2 70
MD5 b1d414864c9edca563ad0d94140311f0 files/digest-wesnoth-0.6.99.3 70
diff --git a/games-strategy/wesnoth/files/digest-wesnoth-0.7.1 b/games-strategy/wesnoth/files/digest-wesnoth-0.7.1
new file mode 100644
index 000000000000..b7a5be8795b9
--- /dev/null
+++ b/games-strategy/wesnoth/files/digest-wesnoth-0.7.1
@@ -0,0 +1 @@
+MD5 22f0b38c2fa1d4ac4e633cbbfc2b8b13 wesnoth-0.7.1.tar.gz 20044804
diff --git a/games-strategy/wesnoth/wesnoth-0.7.1.ebuild b/games-strategy/wesnoth/wesnoth-0.7.1.ebuild
new file mode 100644
index 000000000000..ede106dc39f8
--- /dev/null
+++ b/games-strategy/wesnoth/wesnoth-0.7.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-0.7.1.ebuild,v 1.1 2004/04/03 23:49:02 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="A fantasy turn-based strategy game"
+HOMEPAGE="http://www.wesnoth.org/"
+SRC_URI="http://www.wesnoth.org/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 amd64 ppc ~sparc"
+IUSE="server editor tools"
+
+DEPEND=">=media-libs/libsdl-1.2
+ >=media-libs/sdl-image-1.2
+ >=media-libs/sdl-mixer-1.2
+ >=media-libs/sdl-ttf-2.0
+ media-libs/sdl-net
+ virtual/x11"
+
+src_compile() {
+ egamesconf \
+ --disable-dependency-tracking \
+ `use_enable server` \
+ `use_enable editor` \
+ `use_enable tools` \
+ || die "egamesconf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc MANUAL changelog || die "dodoc failed"
+ prepgamesdirs
+}